+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Iphone defaults to video camera setting instead of still camera?!?!!?

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Lately I have gone to take a pic with my iphone and it goes to video camera by default instead of still camera so if I whip it out and
...
  1. #1
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,318
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    Default Iphone defaults to video camera setting instead of still camera?!?!!?
    Lately I have gone to take a pic with my iphone and it goes to video camera by default instead of still camera so if I whip it out and swipe for a quick pic it just screws everything up and starts a movie.

    This just started out of nowhere a day or two ago. Any ideas or at least directions on where to edit the default setting?
    Screw #Winning, I'm #Juanning
    iMac 27" i5 quad 2.8Ghz (1TB), MacBook Pro 17" 2.6, iPhone 4s

  2. #2
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,478
    Thanks
    44
    Thanked 5,328 Times in 3,113 Posts

    Sounds like user error

  3. #3
    Livin the iPhone Life
    Join Date
    Sep 2009
    Location
    Manchester, England
    Posts
    2,001
    Thanks
    361
    Thanked 515 Times in 379 Posts

    mine defaults to whatever I left it on last.

  4. #4
    Go Giants whereswaldo's Avatar
    Join Date
    Jul 2009
    Location
    Toronto
    Posts
    4,382
    Thanks
    187
    Thanked 359 Times in 257 Posts

    ^me too
    Name? whereswaldo
    iDevice + Firmware? 32GB Black iPhone 4 iOS 5.0
    Computer + OS? Dell Inspiron 15R 2nd Gen i5, 2.3 Ghz, 750GB HDD, 8GB RAM Windows 7 HP
    Location? Toronto
    Found yet? No

  5. #5
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,318
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    anyone? bueller bueller?

    As my hot rod buddies would say, this forum is a bunch of gold chainers.
    Last edited by one1; 11-07-2010 at 07:00 PM. Reason: Automerged Doublepost
    Screw #Winning, I'm #Juanning
    iMac 27" i5 quad 2.8Ghz (1TB), MacBook Pro 17" 2.6, iPhone 4s

  6. #6
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    30,449
    Thanks
    3,711
    Thanked 9,626 Times in 5,901 Posts

    As you did, searched and couldn't find anything really that would help.
    Makes me feel bad that no one has been able to help the guy that has helped so many for so many years.

  7. #7
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,318
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    I remember there being snapshot cache files for the iphone to leave ti in it's last state, but I dunno if the camera follows that rule.

    %$#$%^***%@^&#T!!!!!!!!!!!!!!!!!!
    Last edited by one1; 11-08-2010 at 04:21 PM. Reason: Automerged Doublepost
    Screw #Winning, I'm #Juanning
    iMac 27" i5 quad 2.8Ghz (1TB), MacBook Pro 17" 2.6, iPhone 4s

  8. #8
    What's Jailbreak?
    Join Date
    Nov 2010
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    I'm having the same issue and so far have had no luck finding a solution. Mine defaults to the video camera and the front facing (webcam) camera.

    Stealth, I don't think it's user error because even after I change it to the still-camera and the lens on the back of the phone and then take a picture, it will always open up to the video camera and webcam.

    I recently installed FastSnap to use the volume buttons to take a picture so maybe that's what caused it. I tried uninstalling it but that didn't help. I also decrypted the iOS 4.1 ipsw and tried replacing all the files on my phone in /System/Library/CoreServices/RawCamera.bundle with the original ones but got the same result. I've looked all over the filesystem but nothing stood out as to what could be causing it.

  9. The Following User Says Thank You to Krome20 For This Useful Post:

    jujinz (04-08-2011)

  10. #9
    iPhoneaholic
    Join Date
    Oct 2007
    Posts
    312
    Thanks
    19
    Thanked 36 Times in 34 Posts

    Mine was doing the same thing. The only way I managed to kick it out of this habit was to open the camera app, switch the slider to camera (from video), take a picture, close the app with the home button, then use remove BG to close all apps. The next time I opened my camera app it defaulted to camera instead of video.

  11. #10
    What's Jailbreak?
    Join Date
    Nov 2010
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    I gave that a shot but it didn't work for me. Switched to camera, took a picture, closed it with the home button and killed all open programs with Remove BG from SBsettings but it still opens up to the video camera and the webcam. Thanks for the suggestion though

  12. #11
    iPhone? More like MyPhone
    Join Date
    Sep 2008
    Posts
    105
    Thanks
    13
    Thanked 7 Times in 7 Posts

    I'm having the same problems it sucks I just updated to 4.1 today n installed a bunch of things so I don't know what caused it but I'm hoping after I get home a fresh restore will fix it .. Wish me luck

    Ok so for me I had disable multitasking installed n after uninstalling it works normal now
    Last edited by timmyinpajamas; 11-10-2010 at 05:27 PM. Reason: Automerged Doublepost

  13. #12
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,318
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    I restored my phone yesterday to get rid of the issue.

    Glad to know I am not without company on the issue though. That means next time it happens someone might have an answer for everyone since it is going to keep happening.
    Screw #Winning, I'm #Juanning
    iMac 27" i5 quad 2.8Ghz (1TB), MacBook Pro 17" 2.6, iPhone 4s

  14. #13
    What's Jailbreak?
    Join Date
    Nov 2010
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    I just restored my phone about two weeks ago and finally finished installing everything and setting everything up the way I like so I don't want to have to do that all over again with another restore. It's not a deal breaker for me since I don't use the camera all that often.

    Timmy, glad you figured out which program was causing the issue and got it resolved.

    I went back and uninstalled my 15 most recent things in Cydia but it didn't fix the issue. Oh well

  15. #14
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,318
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    There were two recent cydia updates that I thought might have done it, but I don't know what my two recent updates were. Basic stuff, not 3rd party or anything.
    Screw #Winning, I'm #Juanning
    iMac 27" i5 quad 2.8Ghz (1TB), MacBook Pro 17" 2.6, iPhone 4s

  16. #15
    Banned
    Join Date
    Nov 2009
    Location
    here
    Posts
    2,651
    Thanks
    559
    Thanked 2,938 Times in 1,095 Posts

    Mine was doing it. I also noticed hDR was off when u switched to camera mode after turning hdr then taking a pic now it defaults correctly. So may seem illogical but try cycling hdr on/off

  17. #16
    My iPhone is a Part of Me Madman604x's Avatar
    Join Date
    Aug 2009
    Location
    Canada
    Posts
    655
    Thanks
    38
    Thanked 43 Times in 43 Posts

    i just stared having this issue too. its replacement iPhone 4 too. the old phone had the same issue before
    60% of the time, it works every time.

  18. #17
    My iPhone is a Part of Me Madman604x's Avatar
    Join Date
    Aug 2009
    Location
    Canada
    Posts
    655
    Thanks
    38
    Thanked 43 Times in 43 Posts

    For me it was "z toggle" that caused the camera bug. When I turned of native multitasking, the cam always defaulted to the front cam and movie mode. Turn n multirask, and it screwed up the cameras again.

  19. #18
    My iPhone is a Part of Me Madman604x's Avatar
    Join Date
    Aug 2009
    Location
    Canada
    Posts
    655
    Thanks
    38
    Thanked 43 Times in 43 Posts

    My bad. As long as your cam is set to what you want as default, you can then disable backgrounding and the cam will stay that way. Or coversely, set the cam default and use Backgrounder to keep the default settings.

  20. The Following User Says Thank You to Madman604x For This Useful Post:

    Krome20 (01-18-2011)

  21. #19
    What's Jailbreak?
    Join Date
    Nov 2010
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    Madman you are amazing!!! I just tried that out and it worked! I opened my camera app and changed it from video camera to still camera and front-facing to rear-facing camera and then held down the home button until Backgrounder said "Backgrounding Enabled". I've tried respringing and rebooting a couple times and now it always goes to the way it should be! (rear-facing, still cam) No more switching it to the regular camera every time I open the app! Thanks again!

  22. #20
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I had this problem too, very annoying.

    SOLUTION: (for mine at least)

    Install SnapTap from Cydia

    Open camera, select Camera option with the slider and take a picture.

    Close camera and respring iPhone.

    Mine now defaults to camera or video depending on which is selected upon closing the camera app.

    Hope that works for someone else too.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts