+ Reply
Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 apps only 1/4 screen

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Hi Everyone, my apps are only taking up 1/4 of the screen as you can see in the attached file. The home screen if fine. When most apps load they
...
  1. #1
    What's Jailbreak?
    Join Date
    Apr 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iPhone 4 apps only 1/4 screen
    Hi Everyone, my apps are only taking up 1/4 of the screen as you can see in the attached file. The home screen if fine. When most apps load they start in full screen while they load, but after 1 second they shrink to 1/4 size. Worst of all the touch input is not mapped correctly so i cant use the apps. I have to restore my phone to fix.

    This has happened three times to me. Twice when installing a app from cydia with winterbaord as the prerequisite and once when it ran out of battery.

    What is going wrong, how can i fix it without a restore?

    Thanks for your help.
    Attached Thumbnails Attached Thumbnails iPhone 4 apps only 1/4 screen-img_0004.png  

  2. #2
    My iPhone is a Part of Me
    Join Date
    Mar 2008
    Posts
    850
    Thanks
    12
    Thanked 85 Times in 85 Posts

    Just remove some apps that u recently installed from cydia, one of them has to be causing th problem (most likely a winterboard add on)

  3. #3
    What's Jailbreak?
    Join Date
    Apr 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by Waleed786 View Post
    Just remove some apps that u recently installed from cydia, one of them has to be causing th problem (most likely a winterboard add on)
    Thanks, I tried that the first couple of times. This last time my phone was going fine for about 4 days, with re springs, reboots all kinds of normal stuff. I haven't installed anything for at least a day then I ran out of battery last night, and when it restarted, 1/4 screen apps again.

    I will try removing all from cydia again, but I'm reasonably sure that it doesn't fix it.

    Also its really hard to remove apps. I need to use Veency and the touch input is all wrong.
    Last edited by dominicmck; 10-02-2010 at 05:10 PM. Reason: Automerged Doublepost

  4. #4
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Have you tried restoring and installing your Cydia apps one by one (like one every day or something) until you find the culprit? Cuz I guarantee it's something you keep redownloading every time you restore and jb. Cuz I've had my phones jb for 2 years+ now and never have experienced or seen this before.

    It's got to either be a conflicting app, or an app that isn't iOS 4 compatible yet.

  5. #5
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    30,697
    Thanks
    3,770
    Thanked 9,708 Times in 5,963 Posts

    Set up as a "New Phone" if you restore again also. Don't restore from a back up.

    But, I tend to agree with Annie
    It's got to either be a conflicting app, or an app that isn't iOS 4 compatible yet.

  6. #6
    What's Jailbreak?
    Join Date
    Apr 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thanks everyone, I'm restoring now. Will keep you posted on the "bad app" theory but if anyone else has any ideas I'm willing to try.

  7. #7
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    The best thing to do is like Blkcadi said, set the phone up as new. Do not restore from back up, that will almost always carry over previous problems.

    Thanks B, I forgot to mention that :P "Never restore from back up" happens to be one of my favorite lines lol.

  8. The Following User Says Thank You to i.Annie For This Useful Post:

    blkcadi (10-02-2010)

  9. #8
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    30,697
    Thanks
    3,770
    Thanked 9,708 Times in 5,963 Posts

    You always have my back, a chance for me to pay it forward ya know..............

  10. #9
    iPhone? More like MyPhone bchilton9's Avatar
    Join Date
    Sep 2007
    Posts
    111
    Thanks
    4
    Thanked 21 Times in 21 Posts

    Mine did this when I installed simple background once I removed it didn't have the problem anymore.

  11. The Following User Says Thank You to bchilton9 For This Useful Post:

    SkeleDork (11-23-2010)

  12. #10
    Livin the iPhone Life iNT3Rv3NTiONZz's Avatar
    Join Date
    Feb 2010
    Location
    Cambridge, U.K
    Posts
    1,512
    Thanks
    57
    Thanked 123 Times in 101 Posts

    This is a stupid question, but you don't have zoom on do you? It's in settings under accessibility


    Sent from my iPhone using ModMyi

    iPhone4 16gb black - 4.1 Limera1ned
    iPhone 3G 16gb white - 3.1.2 jailbroken
    Blackra1ned
    THANKYOU ONCE AGAIN GEOHOT!

  13. #11
    What's Jailbreak?
    Join Date
    Aug 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I would have to agree with bchilton9, I had the same problem with Simple Background. My screen would shrink occasionally to 1/4 the normal size, making it all but impossible to use the phone. My solution is to go into "Safe Mode" and reboot. That would take it back to the normal size screen. I really like simple background, but there are no alternatives out available.

  14. #12
    What's Jailbreak?
    Join Date
    Nov 2010
    Posts
    1
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default Simple background is to blame
    Just wanted to confirm that it is SimpleBackground that is causing the issues. First time it happened, I did not know what caused it since my phone worked fine with it for a few days. When it crashed, I had to update to 4.1 and break my jailbreak. When I installed it again on 4.1 and it crashed, I was certain that it was the issue. Thankfully, this time i only had to do an update in iTunes with a 4.1.ipsw file so I didn't lose all my data software, etc. Hope that finally confirms all the assumptions!

    Cheers!

  15. The Following User Says Thank You to the_serb For This Useful Post:

    SkeleDork (11-23-2010)

  16. #13
    My iPhone is a Part of Me
    Join Date
    Mar 2011
    Location
    Nashville
    Posts
    726
    Thanks
    895
    Thanked 1,258 Times in 395 Posts

    If it happens again just open SBSettings and select Power->Safe Mode. When in safe mode just respring and thatll fix it

  17. #14
    What's Jailbreak?
    Join Date
    Jan 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default my fix
    hi there, the only way i was able to find the root error source was to follow this steps:

    1. in SBSettings -> more, go to Mobile Substrate Addons disable all addons. leave SBSettings. After the respring you will have to reboot your phone.
    2. Now check if you have full-screen display, as all addons are off you probably have correct display.

    3. in SBSettings -> more, go to Mobile Substrate Addons and enable first addon, respring, then reboot

    4. check if you have full screen display (I was opening Settings application)

    4.1 Yes -> go to SBSettings and enable the next addon, exit, after the respring, reboot your phone again and go to step 4
    4.2 NO -> the last addon you have enabled is probably the culprit. reboot into safe mode, then respring, then disable the last addon. after this respring, then reboot, go to step 4 but skip the last addon disabled. Do this until you have all the addons that work fine enabled.

    tips: I have about 40 addons in my mobile substrate so I activated them in batches of 10 then until I found the batch that generates the issue, then activated all the rest of 30 and then followed the procedure for those 10.

    5. After you are sure that you have identified (all) bad addons go back to SBSettings, activate them and then go to Cydia and uninstall them. (I have tried to reinstall hoping that will solve the issue but with no succes.)

    In my case the issue was generated by 'AutoLocation', it's weird, maybe it has a conflict with something else... weird error anyway.

    IOS 5.0.1
    Iphone 4
    RedSnow 0.9.10b3 for Win

    Cheers!

  18. #15
    What's Jailbreak?
    Join Date
    May 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Developer suggestion
    I contacted the developer, he suggests uninstalling LastApp and seeing if it is the culprit in conflict with BrowserChanger.

    Try installing BrowserChanger first, then LastApp.

    Luck,
    Misha

  19. #16
    Osa
    Osa is offline
    What's Jailbreak?
    Join Date
    Apr 2012
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Go into safe mode via activator and then restart...u should
    Be ok...if it happens again do it again

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts