+ Reply
Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Iphone 2G and no 4.0 support at all.

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Some of us (probably very few) are still using the Iphone 2G. I honestly have no problem with it. I'm a junior in college, study my *** off, work to
...
  1. #1
    Green Apple
    Join Date
    Feb 2009
    Posts
    61
    Thanks
    4
    Thanked 1 Time in 1 Post
    Default Iphone 2G and no 4.0 support at all.
    Some of us (probably very few) are still using the Iphone 2G. I honestly have no problem with it. I'm a junior in college, study my *** off, work to pay tuition and my cell phone bill. I don't have the REAL Iphone talk/data/text... just the gophone from AT&T PAYG plan which is really perfect for me.

    Anyways, will the 2G just not be able to support 4.0 at all? I could really care less about multitasking. I was actually thinking that if this wasn't supported, future updates of some of my applications/games I bought wouldn't be able to update if they all received 4.0 updates. Or I wouldn't be able to buy new apps/games in the future because my phone doesn't support the firmware.

    Can anyone clear this up for me? Thanks.

    ~Sigz

    Although OS 4.0 is available for everyone in the summer, not every feature will work with every model. Specifically background applications.

    If you have the 3GS or the 3rd generation iPod Touch, all the features of OS 4.0 will work, including multitasking. If you have an iPhone 3G or the 2nd gen iPod Touch, you can install OS 4.0 but you won’t get multitasking.

    As for those you you who own the original iDevices (2G iPhone or 1st gen iPod Touch), there was no mention of OS 4 compatibility for these models. Although when questioned, Steve Jobs said this:

    The old devices will get the update, but they’ll miss some of these features like multitasking. If that’s an incentive for them to upgrade to a new device…terrific.
    Hopefully us old iphone/ipod touch users will at least get the chance to reach 4.0!
    Last edited by Sigz; 04-08-2010 at 03:24 PM. Reason: Automerged Doublepost

  2. #2
    EffenTroll ! Effenpig!'s Avatar
    Join Date
    Jan 2010
    Location
    In a house
    Posts
    1,057
    Thanks
    18
    Thanked 57 Times in 50 Posts

    "The old devices will get the update, but they’ll miss some of these features like multitasking. If that’s an incentive for them to upgrade to a new device…terrific"

  3. #3
    Green Apple
    Join Date
    Feb 2009
    Posts
    61
    Thanks
    4
    Thanked 1 Time in 1 Post
    I wish I could afford an upgrade to a real 3GS Iphone plan. As for now, I'll have to continue being a 'poser' LOL. Hopefully the old devices is including the Iphone 2G.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts