Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: need help jailbreaking my 3gs

  1. #1
    Default need help jailbreaking my 3gs
    i just bought a new iphone 3gs, im not sure whats the correct firmware coz when i connect to itunes it says the sim card is incorrect.. where should i start first.. please help

    btw in the serial it says 88002.. hope that helps.. thanks
    Last edited by llj143; 03-11-2010 at 12:38 AM.

  2. #2
    Livin the iPhone Life screamforme02's Avatar
    Join Date
    Dec 2007
    Location
    In All of Your Hearts
    Posts
    1,635
    Thanks
    57
    Thanked 125 Times in 117 Posts

    there is sections upon sections on how to jailbreak an iphone 3gs and then there is google, its not hard and if itunes is telling you incorrect sim you may just want to bring it back and get it replaced and maybe have them activate it for you
    Hey! A Restore Never Hurts It's True!

  3. #3
    jailbreaks requires restoring right? i tried restoring it to 3.1.2 but it give me this error...

    The iPhone “iPhone” could not be restored. This device isn't eligible for the requested build

  4. #4
    iPhoneaholic dantehman1's Avatar
    Join Date
    Jul 2009
    Location
    Sheffield, UK
    Posts
    352
    Thanks
    6
    Thanked 26 Times in 26 Posts

    That means you have a 3.1.3 device and most likely a teathered jailbrake is the only way to go
    If I've helped you remember to say

  5. #5
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    It would give the same error even if 3.1.2 was the current firmware version so the error doesn't really tell us much.

    @llj143
    You don't need to restore in order to jailbreak. But you do need to find out which firmware version you have. My guess is that you have 3.1.2 so you could try redsn0w 0.9.3 (be very sure to tell redsn0w you have the new bootrom when it asks).

    If it fails, you probably have 3.1.3 and you won't be able to jailbreak in any case and therefore haven't lost out on anything.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •