+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: JB 3GS, 3.1.2 -- videos recorded w/ camera won't play!

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
I don't know when this issue arose, however today I recorded a short video and when I went to the photo library to play it back, I received the error
...
  1. #1
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    Question JB 3GS, 3.1.2 -- videos recorded w/ camera won't play!
    I don't know when this issue arose, however today I recorded a short video and when I went to the photo library to play it back, I received the error message "this movie could not be played." In the library the video shows as a black square. I deleted and tried several more times, rebooted, etc. Same result.

    Nothing seems to be wrong with the camera -- videos appear to be shooting normally, and no issues with photos. I'm stumped.

    Is anyone aware of this issue, and more importantly, is there a way to fix short of a full restore (which I don't want to do since I'm not looking to update to 3.1.3)?

    Thanks in advance!

    Edit: See below. iRealSMS is the culprit.
    Last edited by eballesq; 03-05-2010 at 08:13 PM.

  2. #2
    My iPhone is a Part of Me Frostbite's Avatar
    Join Date
    Jun 2009
    Location
    over the hill across the river and through the candy cane forest
    Posts
    693
    Thanks
    34
    Thanked 72 Times in 61 Posts

    Try emailing them to yourself and seeing if your computer will read them
    If you wanna thank me hit "Thanks" in the lower left of my post. If you would like to follow me on twitter click here

  3. #3
    iPhoneaholic xwinger's Avatar
    Join Date
    Jul 2008
    Location
    Calgary, Canada
    Posts
    470
    Thanks
    39
    Thanked 26 Times in 24 Posts

    ok just a hint:

    you don't have to update to 3.1.3 when you restore. if you press shift (command if you have a mac) and click restore while holding the button, you select 3.1.2 firmware from where it's saved on your computer and then it will restore to 3.1.2
    I am not a jailbreak n00b
    I like to drink iPhoneahol...
    Circa 2008

  4. #4
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    Well, it's definitely an issue with a Cydia-installed package. I completely restored to 3.1.2, and before jailbreaking again I tested the camera and confirmed videos were playable. After re-installing my Cydia apps (through PkgBackup) the video issue reappeared. So I guess I'll be uninstalling, testing, and reinstalling until I find the culprit.

  5. #5
    iPhoneaholic xwinger's Avatar
    Join Date
    Jul 2008
    Location
    Calgary, Canada
    Posts
    470
    Thanks
    39
    Thanked 26 Times in 24 Posts

    once you find it dont forget to tell us here.
    I am not a jailbreak n00b
    I like to drink iPhoneahol...
    Circa 2008

  6. #6
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    Quote Originally Posted by xwinger View Post
    once you find it dont forget to tell us here.
    I will; I'm kind of kicking myself for not re-installing my Cydia apps one at a time. I believe I'm going to do the restore again tonight and go at it that way...it's time-consuming but I'll get my answer.

  7. #7
    What's Jailbreak?
    Join Date
    Jan 2010
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    Came across the same issue today. 3gs phone. 3.1.3 jb, tons of cydia apps. Maybe all that recent saurik substrate/apt updates?

    In systematically disabling mobile substrates in sbsettings, I came up with irealsms being the culprit. I know that had a update recently as well. Anyone else can confirm/ debunk?

    Uninstall-reinstall of irealsms seems to have fixed so far
    Last edited by ssahnan; 03-05-2010 at 07:57 PM. Reason: Automerged Doublepost

  8. The Following User Says Thank You to ssahnan For This Useful Post:

    eballesq (03-05-2010)

  9. #8
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    Bingo ssahnan. Uninstalled iRealSMS, rebooted, and issue gone. Time to visit the iReal thread/forum.

  10. #9
    What's Jailbreak?
    Join Date
    Jan 2010
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hmm there is something more to it, my problem came back

  11. #10
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    Quote Originally Posted by ssahnan View Post
    Hmm there is something more to it, my problem came back
    Interesting. With iReal uninstalled, the problem is gone for me.

  12. #11
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by xwinger View Post
    ok just a hint:

    you don't have to update to 3.1.3 when you restore. if you press shift (command if you have a mac) and click restore while holding the button, you select 3.1.2 firmware from where it's saved on your computer and then it will restore to 3.1.2
    That method doesn't work for 3GS phones.

  13. #12
    What's Jailbreak?
    Join Date
    Jan 2010
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    I had it working after a reinstall but only breifly. Does look like it needs to either be disabled or uninstalled

  14. #13
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    @ dhamien - yes it does.

  15. #14
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by eballesq View Post
    @ dhamien - yes it does.
    Try looking at what I was replying to. Someone said that you could shift-restore to 3.1.2 on a 3GS. That's not possible unless you either have your SHSH files stored or are restoring to a custom firmware on an already jailbroken phone.

  16. #15
    What's Jailbreak?
    Join Date
    Apr 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Anyone still having this problem!? I uninstalled irealsms and it didn't fix the bug for me. Still can't playback camera recorded videos.

    Nevermind. It is irealsms. Uninstall and a restate fixed the problem.
    Last edited by optimusprimal; 03-07-2010 at 07:38 AM. Reason: Automerged Doublepost

  17. #16
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    Quote Originally Posted by dhamien View Post
    Try looking at what I was replying to. Someone said that you could shift-restore to 3.1.2 on a 3GS. That's not possible unless you either have your SHSH files stored or are restoring to a custom firmware on an already jailbroken phone.
    Dude, don't get pissy. Your reply was simply "this method doesn't work for 3GS phones" and that is incorrect. If you had taken a couple of extra seconds to add "unless you have SHSH on file with Saurik" I wouldn't have responded.

    The shift-click restore to 3.1.2 is EXACTLY how I restored my 3GS, and then re-jailbroke it.

  18. #17
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I started having a very similar problem last night. I took three longer movies at my nephew's play, then found the black boxes and "could not be played" message. However, I tried recording a short video after this, and it worked fine. I do have irealsms installed. I'll try uninstalling and see if I can record a long vid successfully.

    Well thus morning I can't record short videos either. I uninstalled irealsms, no change. I uninstalled grooveshark and Resupported as well since both were recent additions, but neither helped.
    Last edited by elastictango; 03-07-2010 at 08:05 AM. Reason: Automerged Doublepost

  19. #18
    My iPhone is a Part of Me
    Join Date
    Jan 2009
    Posts
    605
    Thanks
    68
    Thanked 56 Times in 43 Posts

    Update: a new beta of iReal has been released on the beta repo -- www.irealsms.com/beta_repo -- that seems to have addressed the 3GS video issue.

  20. #19
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I added the repo, upgraded and rebooted, but I'm still having the problem.

    Uh, cancel that; I had resprung. (respringed?) I rebooted and it appears to be working fine now. Thanks a lot eballesq!
    Last edited by elastictango; 03-07-2010 at 08:35 AM. Reason: Automerged Doublepost

  21. #20
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by eballesq View Post
    Dude, don't get pissy. Your reply was simply "this method doesn't work for 3GS phones" and that is incorrect. If you had taken a couple of extra seconds to add "unless you have SHSH on file with Saurik" I wouldn't have responded.

    The shift-click restore to 3.1.2 is EXACTLY how I restored my 3GS, and then re-jailbroke it.
    How was my last reply 'pissy'? In my first post I simply said that shift-restoring didn't work which is right, it doesn't simply work like that.

    Not sure why you're getting offended by my posts.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts