+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3.0 to 3.1 or 3.1.2

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Hello, I havent been on here in months and it looks like alot has changed. Im looking to update my 3.0 3GS to 3.1 or 3.1.2 so that i can
...
  1. #1
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Calgary, Alberta, Canada
    Posts
    129
    Thanks
    5
    Thanked 5 Times in 5 Posts

    Default 3.0 to 3.1 or 3.1.2
    Hello, I havent been on here in months and it looks like alot has changed.

    Im looking to update my 3.0 3GS to 3.1 or 3.1.2 so that i can run the mono bluetooth app.

    I am at a complete loss as how to do this now it seems like it is no longer as simple as shift clicking update and selecting your firmware.

    Any help would be greatly appriciated, and yes i tried the search but it was mostly downgrade stuff and i didnt find anything usefull

    Also the fw faker app in cydia didnt work, i just want the app is there a way to get it on 3.0?

    I do not need to unlock, now or ever

    thanks

  2. #2
    Green Apple
    Join Date
    Sep 2009
    Posts
    68
    Thanks
    11
    Thanked 1 Time in 1 Post
    Quote Originally Posted by southfour View Post
    Hello, I havent been on here in months and it looks like alot has changed.

    Im looking to update my 3.0 3GS to 3.1 or 3.1.2 so that i can run the mono bluetooth app.

    I am at a complete loss as how to do this now it seems like it is no longer as simple as shift clicking update and selecting your firmware.

    Any help would be greatly appriciated, and yes i tried the search but it was mostly downgrade stuff and i didnt find anything usefull

    Also the fw faker app in cydia didnt work, i just want the app is there a way to get it on 3.0?

    I do not need to unlock, now or ever

    thanks
    1. You can no longer update to 3.1.2 as 3.1.3 is out. If you upgrade to 3.1.3 u can JB but no UNLOCK. If you with AT&T OK u don't need unlock. Otherwise stay with 3.0. Sorry.

  3. #3
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Calgary, Alberta, Canada
    Posts
    129
    Thanks
    5
    Thanked 5 Times in 5 Posts

    Can I use blackra1n to jailbreak 3.1.3? Is there anything special that I have to do other than download plug in iPhone and wait? Thanks

  4. #4
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    Do you have your SHSH files stored?

  5. #5
    Green Apple
    Join Date
    Sep 2009
    Posts
    68
    Thanks
    11
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Simtech View Post
    Do you have your SHSH files stored?
    I am not aware of what you mean by SHSH files stored? I never did update to 3.1.2 but wish I had done so to get some of the apps that are 3.1.2 comp. I know of no way now to update to 3.1.2. Any suggestions? Can I use someone elses SHSH file? Thanks!

  6. #6
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    No, the files are unique to each phone. If you don't have these you can only restore to the current FW version (3.1.3). Your only option is to try sn0wbreeze or restore back to factory without JB.

  7. #7
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Calgary, Alberta, Canada
    Posts
    129
    Thanks
    5
    Thanked 5 Times in 5 Posts

    Not on my computer but there in cydia

  8. #8
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    If you have the 3.1.2 SHSH files stored on cydia, change your host file on your computer and perform a <shift> restore to 3.1.2

  9. #9
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Calgary, Alberta, Canada
    Posts
    129
    Thanks
    5
    Thanked 5 Times in 5 Posts

    How do I change the host file?

  10. #10
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    Did you even try to search? I mean I don't mind helping people but sometimes you need to help yourself. Look at Saurik's blog, it explains it all.
    Caching Apple's Signature Server - Jay Freeman (saurik)

  11. #11
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Calgary, Alberta, Canada
    Posts
    129
    Thanks
    5
    Thanked 5 Times in 5 Posts

    I did look, but i didnt find this. Thanks

  12. #12
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by asctony View Post
    1. You can no longer update to 3.1.2 as 3.1.3 is out. If you upgrade to 3.1.3 u can JB but no UNLOCK. If you with AT&T OK u don't need unlock. Otherwise stay with 3.0. Sorry.
    That's pretty bad advice.

    First, the phone can be jailbroken to 3.1.2 if he makes a custom firmware.

    Second, he can't jailbreak if he updates to 3.1.3 - no unlock, and no jailbreak.

    @southfour
    You need to make a custom firmware with pwnagetool. Then just hold down 'shift' and click 'restore' in iTunes. Then point iTunes to the custom firmware you made.

    That way, you'll be jailbroken at 3.1.2 with baseband 04.26.08 which is unlockable with ultrasn0w.

    Also, with this method, you don't need to worry about SHSHs or changing hosts file.

  13. #13
    Green Apple
    Join Date
    Sep 2009
    Posts
    68
    Thanks
    11
    Thanked 1 Time in 1 Post
    Quote Originally Posted by dhamien View Post
    That's pretty bad advice.First, the phone can be jailbroken to 3.1.2 if he makes a custom firmware.Second, he can't jailbreak if he updates to 3.1.3 - no unlock, and no jailbreak.@southfour
    You need to make a custom firmware with pwnagetool. Then just hold down 'shift' and click 'restore' in iTunes. Then point iTunes to the custom firmware you made.That way, you'll be jailbroken at 3.1.2 with baseband 04.26.08 which is unlockable with ultrasn0w.Also, with this method, you don't need to worry about SHSHs or changing hosts file.
    Apparently you didn't read what I said. You added a lot of qualifiers. Let me try to re-explain my answer.
    1. I have a 3G w/OS 3.0 no SHSH. Can I jailbreak to 3.1.2? I found 3.1.2 at anther link as an ISPW file. However, how many people know how to use it?
    2.'Second, he can't jailbreak if he updates to 3.1.3 - no unlock, and no jailbreak.' You better read the other forums-Yes, you can JB, but not Unlock yet.
    Sn0wbreeze 3.1.3 has been released which can jailbreak iPhone 2G, 3G and iPhone 3GS on the latest iPhone 3.1.3 firmware. One thing which is to be noted here is that it will work with iPhone 3GS only if it has the older bootrom (non-MC model). iPhone 3GS users who have upgraded to the stock 3.1.3 are still out of luck.
    3. Make a custom firmware with pwnagetool? Can you supply all of us a custom firmware with pwnagetool? How many people are going to know how to do this?
    4. You may know how to do this, however, there are a lot of individuals who hose their phone just with a normal JB and unlock.

    Anything can be done, but what will it take to get from point a to b?

    Not being smartA--, just trying to be realistic.
    Last edited by asctony; 03-03-2010 at 05:04 PM.

  14. #14
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by asctony View Post
    Apparently you didn't read what I said. You added a lot of qualifiers. Let me try to re-explain my answer.
    1. I have a 3G w/OS 3.0 no SHSH. Can I jailbreak to 3.1.2? I found 3.1.2 at anther link as an ISPW file. However, how many people know how to use it?
    2.'Second, he can't jailbreak if he updates to 3.1.3 - no unlock, and no jailbreak.' You better read the other forums-Yes, you can JB, but not Unlock yet.
    Sn0wbreeze 3.1.3 has been released which can jailbreak iPhone 2G, 3G and iPhone 3GS on the latest iPhone 3.1.3 firmware. One thing which is to be noted here is that it will work with iPhone 3GS only if it has the older bootrom (non-MC model). iPhone 3GS users who have upgraded to the stock 3.1.3 are still out of luck.
    3. Make a custom firmware with pwnagetool? Can you supply all of us a custom firmware with pwnagetool? How many people are going to know how to do this?
    4. You may know how to do this, however, there are a lot of individuals who hose their phone just with a normal JB and unlock.

    Anything can be done, but what will it take to get from point a to b?

    Not being smartA--, just trying to be realistic.
    I wasn't trying to be offensive but what you said isn't true and it is indeed bad advice.

    edit: To be clear here: if he updates to 3.1.3 in iTunes, he'll have lost his ability to jailbreak for a long time. That's why I said it was bad advice.

    If any of what I posted wasn't clear enough, he could simply ask. Ask where to get custom firmwares or how to install them.

    To comment on your points:

    1. Yes, you can either use a custom firmware or an official. One will update the baseband the other won't. I made a short post because I don't want to write an essay every time I reply to something. If I'm not clear enough, people will ask me to explain and I do.

    2. In order for sn0wbreeze or pwnagetool to work on a 3GS, the firmware either has to be 3.1.2 or below, or the device has to be previously jailbroken. A 3GS on 3.1.3 can not be jailbroken by any means - I'm aware that it can be downgraded with SHSHs stored but that's not what we're talking about here.

    3. Here's a guide on how to use pwnagetool: iClarified - iPhone - How to Jailbreak Your iPhone 3GS Using PwnageTool [Mac]
    Last edited by dhamien; 03-03-2010 at 05:20 PM.

  15. #15
    Green Apple
    Join Date
    Sep 2009
    Posts
    68
    Thanks
    11
    Thanked 1 Time in 1 Post
    Quote Originally Posted by dhamien View Post
    I wasn't trying to be offensive but what you said isn't true and it is indeed bad advice.

    edit: To be clear here: if he updates to 3.1.3 in iTunes, he'll have lost his ability to jailbreak for a long time. That's why I said it was bad advice.

    If any of what I posted wasn't clear enough, he could simply ask. Ask where to get custom firmwares or how to install them.

    To comment on your points:

    1. Yes, you can either use a custom firmware or an official. One will update the baseband the other won't. I made a short post because I don't want to write an essay every time I reply to something. If I'm not clear enough, people will ask me to explain and I do.

    2. In order for sn0wbreeze or pwnagetool to work on a 3GS, the firmware either has to be 3.1.2 or below, or the device has to be previously jailbroken. A 3GS on 3.1.3 can not be jailbroken by any means - I'm aware that it can be downgraded with SHSHs stored but that's not what we're talking about here.

    3. Here's a guide on how to use pwnagetool: iClarified - iPhone - How to Jailbreak Your iPhone 3GS Using PwnageTool [Mac]
    Your call. I posted what I thought was asked with the info I see and shared.
    Here is the site that I got my info from:
    Jailbreak iPhone 3.1.3 with Sn0wbreeze | Redmond Pie

    Please read that and let us all know if it is incorrect. Thanks!

    Sn0wBreeze v1.3 To Jailbreak OS3.1.3 [Jailbreak]
    iPhone Hacks
    2 Comments Ľ

    iH8sn0w just released a new version of Sn0wBreeze, this version is made to jailbreak firmware 3.1.3. Sn0wbreeze is a windows desktop application, that looks like the PwnageTool for the Mac. Ľ Sn0wBreeze v1.3 To Jailbreak OS3.1.3 [Jailbreak]

    iPhoneFreakz _ All The Latest And Greatest iPhone News
    Last edited by asctony; 03-03-2010 at 05:33 PM. Reason: Automerged Doublepost

  16. #16
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by asctony View Post
    Please read that and let us all know if it is incorrect. Thanks![/url]
    Please don't be so smug.

    But why don't you read it yourself?

    This is a quote from your link. It's the 3rd and 4th line:

    "iPhone 3GS users who have upgraded to the stock 3.1.3 are still out of luck."

  17. #17
    Green Apple
    Join Date
    Sep 2009
    Posts
    68
    Thanks
    11
    Thanked 1 Time in 1 Post
    Quote Originally Posted by dhamien View Post
    Please don't be so smug.

    But why don't you read it yourself?

    This is a quote from your link. It's the 3rd and 4th line:

    "iPhone 3GS users who have upgraded to the stock 3.1.3 are still out of luck."
    You and I are two of a kind. I know I have read and can read. What is 'stock' 3.1.3 vs 3.1.3?
    Here is another link:
    http://*******************/forums/in...09.0;topicseen

    Last posting to this post from me. I would not want to provide bad info to anyone.

    Please try to read other forums/links, too.
    As for being smug? Your too blatantly smug!

  18. #18
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by asctony View Post
    You and I are two of a kind. I know I have read and can read. What is 'stock' 3.1.3 vs 3.1.3?
    Here is another link:
    http://*******************/forums/in...09.0;topicseen

    Last posting to this post from me. I would not want to provide bad info to anyone.

    Please try to read other forums/links, too.
    As for being smug? Your too blatantly smug!
    Stock 3.1.3 is an unmodified 3.1.3 firmware. It's what's installed on a new 3GS.

    I can't read the link because it's 'stared' out. I'm guessing it's from a forum that isn't allowed here.

    I'm not going to keep fighting but I will keep correcting you. You can link all you want, it won't change the fact that a 3GS on 3.1.3 can't be jailbroken by any means, no matter the bootrom.

    Here's a quote from the iphone dev team's site:

    "If you have an iPhone 3GS: PwnageTool works if youíre currently at version 3.1.2 or below (down to 3.0) and if you know you have a old bootrom. You donít need to be already jailbroken ó PwnageTool will ask you if youíre jailbroken after youíve created the IPSW. Donít use PwnageTool unless you know for sure you have an old bootrom (if youíre not sure, assume the worst and donít use it). Donít use PwnageTool on the iPhone 3GS if youíre at 3.1.3, it just wonít work. Downgrade to 3.1.2 using the methods described here. If you canít downgrade because you donít have your 3GS 3.1.2 hashes on file with Cydia, youíll need to sit out the 3.1.3 jailbreak."

    The sn0wbreeze method won't be any different as sn0wbreeze is just pwnagetool ported to work on windows.

  19. #19
    iPhone? More like MyPhone
    Join Date
    Feb 2009
    Location
    Calgary, Alberta, Canada
    Posts
    129
    Thanks
    5
    Thanked 5 Times in 5 Posts

    Quote Originally Posted by dhamien View Post
    Stock 3.1.3 is an unmodified 3.1.3 firmware. It's what's installed on a new 3GS.

    I can't read the link because it's 'stared' out. I'm guessing it's from a forum that isn't allowed here.

    I'm not going to keep fighting but I will keep correcting you. You can link all you want, it won't change the fact that a 3GS on 3.1.3 can't be jailbroken by any means, no matter the bootrom.

    Here's a quote from the iphone dev team's site:

    "If you have an iPhone 3GS: PwnageTool works if youíre currently at version 3.1.2 or below (down to 3.0) and if you know you have a old bootrom. You donít need to be already jailbroken ó PwnageTool will ask you if youíre jailbroken after youíve created the IPSW. Donít use PwnageTool unless you know for sure you have an old bootrom (if youíre not sure, assume the worst and donít use it). Donít use PwnageTool on the iPhone 3GS if youíre at 3.1.3, it just wonít work. Downgrade to 3.1.2 using the methods described here. If you canít downgrade because you donít have your 3GS 3.1.2 hashes on file with Cydia, youíll need to sit out the 3.1.3 jailbreak."

    The sn0wbreeze method won't be any different as sn0wbreeze is just pwnagetool ported to work on windows.
    iPhone Jailbreak Guides | iPhone Tutorials | ModMyi.com Blog Archive How to Jailbreak/Unlock 3.1.3 iPhone 3GS/3G/2G iPod Touch 2G/1G with sn0wbreeze Windows

    Devices that can be Jailbroken following this guide:

    iPhone 3GS (OLD BOOTROM ONLY. If the 4th/5th digits of the serial # are before 40 the you should have the old bootrom. If your current jailbreak is tethered DO NOT try this.)

    iPhone 3G

    iPhone 2G

    iPod Touch 2G (OLD BOOTROM ONLY. If your current jailbreak is tethered you have the new bootrom so stay away and/or If your model # starts with MC you have the new bootrom so stay away!)

    iPod Touch 1G

  20. #20
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    Quote Originally Posted by southfour View Post
    iPhone Jailbreak Guides | iPhone Tutorials | ModMyi.com Blog Archive How to Jailbreak/Unlock 3.1.3 iPhone 3GS/3G/2G iPod Touch 2G/1G with sn0wbreeze Windows

    Devices that can be Jailbroken following this guide:

    iPhone 3GS (OLD BOOTROM ONLY. If the 4th/5th digits of the serial # are before 40 the you should have the old bootrom. If your current jailbreak is tethered DO NOT try this.)

    iPhone 3G

    iPhone 2G

    iPod Touch 2G (OLD BOOTROM ONLY. If your current jailbreak is tethered you have the new bootrom so stay away and/or If your model # starts with MC you have the new bootrom so stay away!)

    iPod Touch 1G
    Here's a quote from the link you posted:

    "Once again I repeat if you have already upgraded to 3.1.3 you can not follow the steps below! You must have your device ALREADY jailbroken on firmware lower than 3.1.3 to continue!"

    Please just accept that a 3GS on 3.1.3 can't be jailbroken. The various guides are either misinterpreted by you or they have bad wording.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts