Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Tethering on JB 3.1 says "iPhone not connected"

  1. #1
    Default Tethering on JB 3.1 says "iPhone not connected"
    Hi,
    I have a 3GS @ 3.1 and I have troubles with tethering. I tried with the "native" tethering and with MyWi v3.3.1 but I have the following problem. When I enable the tethering (USB) my mac asks me if I want to open the network preferences to configure the new interface. In the network preferences I see the iPhone but it says "Not Connected" (see screenshot)



    Is that supposed to work on a JB 3.1 at all ?

    Thanks,
    Tex

  2. #2
    iPhone? More like MyPhone ltjbigshot's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Posts
    290
    Thanks
    55
    Thanked 25 Times in 21 Posts

    Make sure you have the correct carrier update installed. The easiest thing todo is update both your firmware and carrier update. Then you will be able to find a enable 3gs tethering package in cydia. If you are using mywi the issue might be your firmware as well.

    If you are not looking to update your firmware i would suggest going to
    help.BenM.at on your iphone and navigating to the att tethering carrier update and installing it.
    Sent from my iPad

  3. #3
    Hi,
    Quote Originally Posted by ltjbigshot View Post
    Make sure you have the correct carrier update installed. The easiest thing todo is update both your firmware and carrier update. Then you will be able to find a enable 3gs tethering package in cydia. If you are using mywi the issue might be your firmware as well.

    If you are not looking to update your firmware i would suggest going to
    help.BenM.at on your iphone and navigating to the att tethering carrier update and installing it.
    I already installed the "carrier" from BenM. (Acutually I'm on T-Mobile in Germany which is the official iPhone carrier)

    Do you mean that I should try to switching to OS 3.1.2 ?

    Thanks for helping,
    Tex

  4. #4
    iPhone? More like MyPhone ltjbigshot's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Posts
    290
    Thanks
    55
    Thanked 25 Times in 21 Posts

    I would recommend that unless its not an option for you. I am not to familiar with your carrier since i use ATT in the states.

    What confuses me about your issue is that it is the same problem I had when updating to 3.1.2 until I installed the Enable Tethering package from cydia. But there are not packages for anything before 3.1.2 as far as I know.

    Do you have the RockApp and Rock Extensions properly installed? That also could lead to some issues with MyWi working on your phone
    Sent from my iPad

  5. #5
    Yes the RockApp seems to be correctly installed.

    I will just try to update to 3.1.2 and see. I'll let you know.

    cheers,
    Tex

  6. #6
    iPhone? More like MyPhone ltjbigshot's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Posts
    290
    Thanks
    55
    Thanked 25 Times in 21 Posts

    hope I was of some help!
    Good luck!
    Sent from my iPad

  7. #7
    just FYI, I've just tried on Windows and the behaviour is the same. I see a new network interface but it is not connected. So at least I know that the problem is not on the computer side but on the iPhone.

    Hi,
    so now I have OS 3.1.2, I downloaded the APN from BENM for my carrier but the Tethering menu does not appear

    You were talking about some "carrier update" to install from Cydia .. in which repository is it supposed to be ?

    I also tried MyWi 3.3.1 (latest) and it's the same as before My computer does not react.

    I have the baseband 04.26 (latest is 05.11) but I don't think this could be an issue.

    Thanks,
    Tex

    hallelujah !!

    well I found the problem ! In the Advanced options of my Bluetooth (in OSX) the "Share internet connection with devices" was disabled. Even if I want to tether only via USB, it looks like this option has to be enabled.




    Cheers Tex
    Last edited by Tex-Twil; 12-07-2009 at 02:47 PM. Reason: Automerged Doublepost

  8. #8
    iPhone? More like MyPhone ltjbigshot's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Posts
    290
    Thanks
    55
    Thanked 25 Times in 21 Posts

    Glad to see you figured it out! I will have to remember that next time ad well!
    Sent from my iPad

  9. #9
    Last update,
    I also mentioned that on windows I also had issues ... well I realized that I need iTunes to be installed to get the tethering driver which connects the interface. Now it works also on windows

    Tex

  10. #10
    Hi,
    I reopen this topic because my tethering just stopped working.

    I did not change anything on my iPhone. When I enable the tethering my mac just stays quiet and does not even display the "iPhone" network interface in the Network Preferences"

    Any ideas ?

    cheers,
    Tex

  11. #11
    i have similar problem, internet tethering for usb/blutooth doesnt work, the option is there in iphone settings but the mac doesnt register it connected. it worked before and after i jailbroke the phone, just the last couple of days it stopped working all of a sudden. and just now the tethering option in settings disappeared but i got it back by just rebooting the phone, though the tether still doesnt actually works?

    what wrong with this?
    anyone please give me some assistance ive been looking anywhere for a solution..my tethering is official with vodafone (their answer is just to do an update to 3.1.3 and nothing else, big help!!)
    and i am yet to find anything that helps
    Last edited by Remember God; 03-13-2010 at 12:17 AM.

  12. #12
    i worked out my tethering problem...
    the "tethering sbsettings toggle" add-on causes problems with the iphones native tethering toggle, sometimes the native toggle (settings>general>network>tethering) doesnt turn on or off when u use the "tethering sbsettings toggle" addon. it can cause loss in tether capability for usb and bluetooth, it can also make the native tether disappear all together (i found if the native tether disappeared and i went to sbsettings and turned the tethering toggle on then off a few times the native tether option would re-appear but it still would not connect to the mac). so i deleted this addon then did a full settings reset and my tethering connection came back. i had full function for both usb and blutooth tethering, just to be sure this addon was the cause i reinstalled it and sure enough the same problem occured..so i deleted and reset again...and everything works as normal.
    i tried the other addon "tether toggle" (apposed to the faulty "tethering toggle")sbsetting and this works fine no problem it synced with the native toggle flawlessly so far and i have had no problems....

    so anyone with loss of tethering after a jailbreak, if you use sbsettings and use "tethering toggle" addon get rid of it reset settings and use "tether toggle" addon.

    finally 4days of near sleeplessness computering and its solved!!! for me anyways!!! good luck to anyone else with similar issues i hope this helps.

  13. #13
    Quote Originally Posted by Remember God View Post
    i worked out my tethering problem...
    the "tethering sbsettings toggle" add-on causes problems with the iphones native tethering toggle
    My tethering native setting is actually disappearing but I have no tethering sbsetting toggles installed. I tried to install the "tether" toggle but still my mac does not react.

    What do you mean by "reset" ?

  14. #14
    well I have the impression that it works only when the iPhone has a 3G connection ... not Edge. When it has only Edge, it says "Not connected". Does it make any sense ?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •