+ Reply
Page 3 of 20 FirstFirst 12345 13 ... LastLast
Results 41 to 60 of 384

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [LIST] Language Packages to Delete on 3.0 :: Increased Performance

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Yeah, I know what you mean Grassmasta. The only reason this 2G doesn't have Winterboard is because I did a full restore before starting this process... I would recommend getting
...
  1. #41
    Livin the iPhone Life ALL DAY's Avatar
    Join Date
    Feb 2008
    Location
    Chit-Chat
    Posts
    2,277
    Thanks
    43
    Thanked 196 Times in 163 Posts

    Yeah, I know what you mean Grassmasta. The only reason this 2G doesn't have Winterboard is because I did a full restore before starting this process...

    I would recommend getting up to 3.0 though, it really is nice.
    Respect your elders.

  2. #42
    What's Jailbreak?
    Join Date
    Mar 2009
    Posts
    28
    Thanks
    10
    Thanked 2 Times in 1 Post
    Quote Originally Posted by Grassmasta View Post
    On my 8gb 2g, I am currently seeing 50 MB! Thats from no use for the last hour and having no processes running. Thats the best I've ever experienced a 2g to run at! Although, I've heard of people who have built their own custom .ipsw via pwnage tool getting near that; but, I myself have never experienced such great performance on this 2 + year old device! How about you guys (not you 3gs folks...every time I hear about it...its just depressing how excited I'm getting about my measly 50 MB! )?
    i have 54mb free without doing this. did you use the memory free up after doing it?

  3. #43
    Livin the iPhone Life
    Join Date
    May 2009
    Posts
    1,269
    Thanks
    43
    Thanked 277 Times in 239 Posts

    something from the first post bricked my phone... i took my time and didn't delete anything i wasn't supposed to.. time to restore

  4. #44
    Peanut Brain confucious's Avatar
    Join Date
    Oct 2008
    Location
    Woking
    Posts
    10,255
    Thanks
    138
    Thanked 907 Times in 823 Posts

    @All Day - I wasn't particularly careful when I went through but didn't think I'd done anything wrong. Your list isn't in alphabetical order (it might be worth copying to Excel and sorting?) but I thought I'd got everything right. I was going in with WinSCP clicking on the first lproj, shift clicking on the last then control clicking on Englich.lproj and uk.lproj in each directory apart from the one with en.lproj instead of English.lproj
    When it didn't work at the end I thought I must have made a mistake but as others are reporting the same problem I'm not so sure I did.
    I've since run Peteo's scripts in the 3 directories he suggested and it's worked so can't try again.
    Short of restoring and trying again I can't really tell if the error is in your list or my deleting, sorry.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  5. #45
    Livin the iPhone Life ALL DAY's Avatar
    Join Date
    Feb 2008
    Location
    Chit-Chat
    Posts
    2,277
    Thanks
    43
    Thanked 196 Times in 163 Posts

    It seems to be my list...

    If that is the case, sorry to the three of you who got messed up. I'll redo the entire process tomorrow and see what the problem is.
    Respect your elders.

  6. The Following User Says Thank You to ALL DAY For This Useful Post:

    br1sk (11-02-2009)

  7. #46
    Peanut Brain confucious's Avatar
    Join Date
    Oct 2008
    Location
    Woking
    Posts
    10,255
    Thanks
    138
    Thanked 907 Times in 823 Posts

    Like I say, I can't guarantee it was not me. Thinking about it, why should deleting unused language files from any app make any difference? What are we missing?
    You're going to feel really p!ssed if you go through and find your list is correct...
    Could it even be some other app (that you might not have) is calling on a language pack (probably in one of the system files) so it works for you and only doesn't work if you have some weird app installed?
    I am not convinced the problem lies in your list - it might not be that straightforward.
    Thanks for all your help
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  8. #47
    My iPhone is a Part of Me ekidd's Avatar
    Join Date
    Nov 2007
    Posts
    564
    Thanks
    9
    Thanked 40 Times in 34 Posts

    i dont think deleting language files from anything more than /applications will even make a difference. This is just what i noticed though. ALso, I was unable to reboot after this guide,looks like i accidentally deleted something i wasnt supposed to.

  9. #48
    Livin the iPhone Life bobright's Avatar
    Join Date
    May 2009
    Posts
    1,894
    Thanks
    444
    Thanked 216 Times in 149 Posts

    Quote Originally Posted by StallionM5 View Post
    Take care in some folders specially in System Folders your eye will trick you to add other folders that are not proj folders
    Leave any en.proj too

    I have done all and also system files and everything is fine
    Ok so if I wanted to wipe all languages except for english I would have to leave "English.lproj" as well as any "en.projl" folders?

  10. #49
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    Trying to work out who I should be playing with - huge breasted office girl or iPhone? Got 30 minutes to decide.

  11. #50
    Peanut Brain confucious's Avatar
    Join Date
    Oct 2008
    Location
    Woking
    Posts
    10,255
    Thanks
    138
    Thanked 907 Times in 823 Posts

    You can play with your iPhone all night - can you do that with the HBOG?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  12. #51
    iPhone? More like MyPhone
    Join Date
    Jul 2008
    Location
    right in the middle of the US
    Posts
    140
    Thanks
    4
    Thanked 7 Times in 5 Posts

    i've noticed a small decrease in load times of apps and have had more free memory. after a reboot and free memory i'm running at 64mb free. i switched from winterboard to bosspaper though.

    one weird note, after deleting language files, bosspaper has switched icons to the last installed app. same thing swirly did when it was first released for 3.0. anybody else notice this or know how to fix it?

  13. #52
    Livin the iPhone Life ALL DAY's Avatar
    Join Date
    Feb 2008
    Location
    Chit-Chat
    Posts
    2,277
    Thanks
    43
    Thanked 196 Times in 163 Posts

    ^Reboot your device; it happens.

    On a related note, did you do everything listed in the list on the first page?
    Respect your elders.

  14. #53
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    2
    Thanked 0 Times in 0 Posts

    i manually deleted the language files (except English and that one en.proj indicated on the first post and it works great - alot faster loading times. Only issue I have is that my FREE MEMORY button in SBSettings doesnt seem to work very often (it just disappears). I'm hoping a reinstall of SBSettings will solve that.

    Thanks alot for the conversation that lead to this end result!

  15. #54
    Livin the iPhone Life ALL DAY's Avatar
    Join Date
    Feb 2008
    Location
    Chit-Chat
    Posts
    2,277
    Thanks
    43
    Thanked 196 Times in 163 Posts

    ^Well WTF... I'm still going to try this on a fresh restore, it's just weird that some people have no problem with it while some are getting messed up.

    It looks like it has to be some app that you all have that I don't that requires some of these files.
    Respect your elders.

  16. #55
    My iPhone is a Part of Me
    Join Date
    Aug 2008
    Location
    The Internet
    Posts
    617
    Thanks
    51
    Thanked 55 Times in 51 Posts

    I think confucious might be on to something. It doesn't seem too far fetched. But then again if the supposed app that may be calling on the missing .iproj doesn't run on start up, why are these folks getting the boot loop?

  17. #56
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    I followed the list (in that order, except I did framework folder first and them privateframework) on your first post and no problem so far. i kept English, Japanese, and the 2 Chinese folders for all of them. The only things i did not delete are the carrier bundles. I would respring after a few folders to make sure I'm still okay and did a hard reboot at the end when i was done. no problem so far.

    @confucious do you think you may have accidentally deleted a folder called "project" in some of the directories? i saw a few of them and almost accidentally deleted them.

  18. #57
    Peanut Brain confucious's Avatar
    Join Date
    Oct 2008
    Location
    Woking
    Posts
    10,255
    Thanks
    138
    Thanked 907 Times in 823 Posts

    Quote Originally Posted by jtesnani View Post
    @confucious do you think you may have accidentally deleted a folder called "project" in some of the directories? i saw a few of them and almost accidentally deleted them.
    Anything is possible - any idea which folders have 'project' folders in them? I could then have a look and see if it's likely.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  19. #58
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    Quote Originally Posted by confucious View Post
    Anything is possible - any idea which folders have 'project' folders in them? I could then have a look and see if it's likely.
    wish i could tell you but i don't know. i don't think i saw more than 5 of them and they're in frameworks/privateframework directory...

  20. #59
    Peanut Brain confucious's Avatar
    Join Date
    Oct 2008
    Location
    Woking
    Posts
    10,255
    Thanks
    138
    Thanked 907 Times in 823 Posts

    I haven't come across any 'project' folders but have just come across 'support' in CoreTelephony.Framework.

    I was selecting the first folder then the last then unselecting the 2 I wanted to keep.

    Yup - I deleted stuff I wasn't supposed too. Can't speak for the others but mine was definably my fault.

    Sorry All-Day and appologies to anyone else I confused through my stupidity.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  21. #60
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    sorry you're right. its "support" not "project

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts