+ Reply
Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Iphone keeps connecting then disconnecting?

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
I got a new laptop this week, and installed XP on it. well today i tried to connect my iPhone 3g to it, and it connects for less than 2
...
  1. #1
    iPhone? More like MyPhone jaredb03's Avatar
    Join Date
    Sep 2007
    Posts
    173
    Thanks
    3
    Thanked 13 Times in 9 Posts

    Default Iphone keeps connecting then disconnecting?
    I got a new laptop this week, and installed XP on it. well today i tried to connect my iPhone 3g to it, and it connects for less than 2 seconds then disconnects. It just repeats over and over. I know it isn't the iPhone or the cable, because it still connects fine to my Desktop computer.

    The laptop is a Compaq CQ60-210US. All my other USB stuff works(Mouse, Jump Drives, camera, etc...). Has anyone had this problem? or knows what i can try to fix it? Please let me know.
    Thanks, Jared

  2. #2
    Moderator Admin Broomhead's Avatar
    Join Date
    Sep 2007
    Location
    Outside Chicago IL
    Posts
    17,097
    Thanks
    488
    Thanked 1,641 Times in 1,146 Posts

    Never heard of this one before. Sorry I can't help you. Just wanted to say... That must be sooooo annoying

  3. #3
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,478
    Thanks
    44
    Thanked 5,328 Times in 3,113 Posts

    I would try plugging in a usb hub and trying it. you never know

  4. #4
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,825
    Thanks
    551
    Thanked 515 Times in 427 Posts

    Maybe something installed wrong with your phone drivers. If other periphreals are working in the USB slots that is where I would look first.

    Read this: Apple - Support - Discussions - iphone keeps disconnecting and ...

  5. #5
    iPhone? More like MyPhone dangerousandre's Avatar
    Join Date
    Sep 2007
    Posts
    119
    Thanks
    35
    Thanked 0 Times in 0 Posts

    Same thing used to happen to me on my desktop but with the first gen iPhone... I just plugged it into a different usb port in the back and it stopped...

  6. #6
    iPhone? More like MyPhone jaredb03's Avatar
    Join Date
    Sep 2007
    Posts
    173
    Thanks
    3
    Thanked 13 Times in 9 Posts

    I have tried all the ports on the laptop but none are working. And like captainchoas said i am pretty sure that the drivers did not install correctly. is there any way to install the drivers from a file rather then the phone?

  7. #7
    What's Jailbreak?
    Join Date
    Nov 2007
    Location
    Vancouver, BC
    Posts
    16
    Thanks
    3
    Thanked 3 Times in 3 Posts

    You do have iTunes installed?

  8. #8
    iPhone? More like MyPhone jaredb03's Avatar
    Join Date
    Sep 2007
    Posts
    173
    Thanks
    3
    Thanked 13 Times in 9 Posts

    Quote Originally Posted by Steen View Post
    You do have iTunes installed?
    What is iTunes???

    Of course i have itunes installed!!!!

  9. #9
    My iPhone is a Part of Me lach's Avatar
    Join Date
    Jan 2009
    Location
    Australia
    Posts
    519
    Thanks
    30
    Thanked 82 Times in 67 Posts

    i had a similar problem, i removed iTunes from my computer, the on my iPhone 3G i reset all content and settings, then reinstalled iTunes and connected my iPhone to the computer and it worked. I am also using vista. I have no idea how it fixed it but thought id let you know anyway!

  10. #10
    What's Jailbreak?
    Join Date
    Jun 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Deja-Vu
    Dude, I have the EXACT same problem as you and its pretty annoying, my laptops a Compaq Presario CQ60 and every 2 seconds it connects then disconnects, then it connects for 5 seconds then goes back to doing its 2 second thing. I think/hope using a USB hub will work? I have no idea how affective the other ways are though.

  11. #11
    What's Jailbreak? Baldycoot's Avatar
    Join Date
    Jun 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I've just installed a new Shuttle XPC SX58J (LGA1366 motherboard with W7 x64)... experienced the same issue, USB keeps rejecting connection. Reinstalled Apple Mobile Device driver, no good. Checked the USB hub drivers... they were installed from the Shuttle driver DVD, Intel chipset but certified by Microsoft, reinstalled, no good.

    Googled for more information and went to Intel site and downloaded the latest chipset drivers... installed, rebooted, sorted!

  12. #12
    What's Jailbreak?
    Join Date
    Aug 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thumbs up Hope it will solve the problem... dont ask me I too late replied :)
    Dear all I found its solution, I was too much tired and wasted approx 2 days with installing fresh windows 7 64bits for four times as there was same problem and it was disconnecting and reconnecting within seconds

    Actually there was problem with incorrect iPhone data cable, if you are not using original cable which came with iPhone then it will work for you too, because there is available iPhone cables in market those are not compatible with iPhone 4 or 4S, I had data cable and there were 4 pins inside of 30 pins connector and when I connected 5 pins inside of 30 pins connector my iPhone is working perfect

    Correct pins configuration is hereunder

    iPhoneConnectorConfig.jpg

    Hope it will work for you

    Regards,


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts