+ Reply
Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Safari doesn't keep history on 2.1. Usual fixes don't work

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
So, I upgraded to 2.1 from 1.1.4, using QuickPwn. Everything works pretty good (especially after I uninstalled Winterboard, which made my iPhone laggy as WinXP on 80286). I had to
...
  1. #1
    Green Apple
    Join Date
    Mar 2008
    Posts
    79
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Default [SOLVED] Safari doesn't keep history on 2.1/2.2. Usual fixes don't work
    So, I upgraded to 2.1 from 1.1.4, using QuickPwn. Everything works pretty good (especially after I uninstalled Winterboard, which made my iPhone laggy as WinXP on 80286).

    I had to use BossPrefs' "fix user dirs" button to fix mail and SMS apps crashing, but I still have one thing left - Safari will not keep history no matter what.

    I checked /mobile/Library/Safari and I can tell that the only two files appearing there while browsing on iPhone are Bookmarks.plist and SuspendState.plist. No History.plist (should it be there?). Safari does keep cookies, by the way.

    So, does anyone have any ideas here?

    Specs:
    iPhone 1st gen, 2.1FW QuickPwned
    WinXP SP3
    iTunes 8.0.1
    Okay, this time same thing happened on 2.2. Note that it started not right after jb, but after installation of some app from Cydia. History was keeping only three days of entries and the last day must have been the day of app installation.

    In short: Scrobble (the one with SB icon). Uninstalled it - safari saves history again. This is sad, because Scrobbled (the one that goes into Preferences) doesn't work at all.

    Sucks.
    Last edited by asmodeus_dhoine; 11-28-2008 at 07:21 PM.

  2. #2
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,356
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    hmmmm that's a good one. I had a cookie issue with mine and nothing fixed it without a repwn.

  3. #3
    Green Apple
    Join Date
    Mar 2008
    Posts
    79
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Oh, shitballs! ))
    Really? Let's see what others have to say

  4. #4
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,825
    Thanks
    551
    Thanked 515 Times in 427 Posts

    I have the opposite issue. Safari will not erase history ?

  5. #5
    Green Apple
    Join Date
    Mar 2008
    Posts
    79
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by CaptainChaos View Post
    I have the opposite issue. Safari will not erase history ?
    Hmmm. Could you find that history file on your iPhone? Maybe in /mobile/Library/Safari or do a search with Total Commander T-Pot plugin.

    Am I the only one with this issue on 2.1?
    Last edited by asmodeus_dhoine; 10-24-2008 at 12:03 PM. Reason: Automerged Doublepost

  6. #6
    My iPhone is a Part of Me
    Join Date
    Oct 2007
    Location
    Colorado
    Posts
    569
    Thanks
    10
    Thanked 53 Times in 41 Posts

    I have this same issue, but I stopped caring. If someone finds a way to fix it without restoring that would be great, but otherwise I will wait until the next firmware update to restore.

  7. #7
    Green Apple
    Join Date
    Mar 2008
    Posts
    79
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Well, I'll restore and repwn it tonight. I don't want to put up with these bugs. And this time I also try avoiding winterboard and bossprefs. See what happens.

  8. #8
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,356
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    It's quickpwn, not boss or wb. My issues came from a stock phone after a pwn. Sometimes it misfires when breaking up the factory firmware for the pwn.
    Screw #Winning, I'm #Juanning
    iMac 27" i5 quad 2.8Ghz (1TB), MacBook Pro 17" 2.6, iPhone 4s

  9. #9
    Green Apple
    Join Date
    Mar 2008
    Posts
    79
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by one1 View Post
    It's quickpwn, not boss or wb. My issues came from a stock phone after a pwn. Sometimes it misfires when breaking up the factory firmware for the pwn.
    BossPrefs has been linked to poor signal somewhere here and WB just makes iphone slow as hell. But I'll think about BP - it's useful so I might install it.
    Anyway, I'll post when I repwn, in an hour or so.
    Btw, my backspace sometimes get stuck. In safari, for example.

    Well, repwned, safari keeps history now and overall iphone seems more responsive. I did install bossprefs.
    Last edited by asmodeus_dhoine; 10-25-2008 at 06:14 AM. Reason: Automerged Doublepost

  10. #10
    Green Apple
    Join Date
    Mar 2008
    Posts
    79
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Okay, so it seems that I found the source of the problem.

    I repwned, checked Safari - it worked fine and history was there. Then I installed some apps from Cydia. And guess what? History was gone again!

    But it gets better. When I open Safari history was empty. After I go to any website - it would add to history (for the current session) AND the old history would appear! It was just like there was this history that saved before I installed some app and it would reappear in Safari every time history is created. After restart, history would be empty again and reappear exactly as it was before the app.

    And I also found the app that caused all this - Safari DL Plugin. Since I removed it history saves just fine. It was standalone package from BigBoss.

    Then I installed ********** and it installed SafariDL. This didn't affect me.

  11. #11
    Green Apple
    Join Date
    Mar 2008
    Posts
    79
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Great!

    The issue is back and now uninstalling Safari DL didn't help. And I don't want to restore/repwn.

    Heeeelp! Srsly.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts