Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone headset jack problem fix.

  1. #1
    Default iPhone headset jack problem fix.
    I've noticed that besides me, a lot of people is having trouble with the headset still showing like plugged in problem, and no getting sound from their phones as well. (well, just from the headset)

    So, as I wasnt able to find a solution, I went on to find it myself. And here it is: iPhone Headset Jack REAL Fix

    I hope it does help more people out there with the same problem.

  2. #2
    Hi,

    I have ordered TWO new headphone-jack parts for iFixit. Here are my observations :

    If i disconnect the hole set of buttons, i hear the sound from the keypad for example. When I connect it, no more sound.

    Then I put in my headphone : sound comes back on the iphone (but not the headphones!). Conclusion : when the headphone are in, the Iphone thinks he is in normal mode (so sound comes out normally) but when the headset are removed, the iphone might think headset are in, so disactivates the sound of the iphone ! Bottom line : it works great, but in reverse order !!!!

    Any ideas ?

  3. #3
    Quote Originally Posted by GogNav View Post
    Hi,

    I have ordered TWO new headphone-jack parts for iFixit. Here are my observations :

    If i disconnect the hole set of buttons, i hear the sound from the keypad for example. When I connect it, no more sound.

    Then I put in my headphone : sound comes back on the iphone (but not the headphones!). Conclusion : when the headphone are in, the Iphone thinks he is in normal mode (so sound comes out normally) but when the headset are removed, the iphone might think headset are in, so disactivates the sound of the iphone ! Bottom line : it works great, but in reverse order !!!!

    Any ideas ?
    I have the exact same issue! Any one have any ideas on this?

    Finally got all my replacement parts in and now this.

    If I plug the headphones in I get audio out the speakers, If i unplug them I get no audio but it plays like normal (sound seems to be outputting to the headphones (which are not plugged in). It is backwards. If I plug my old audio jack in it works fine. But the vibrate switch on that one is broken off so it does me no good.

    OK Found this on iFixIt. :

    Note: There are two different versions of the headphone jack for the 1st Gen iPhone. The older version 821-0449 and the newer version 821-0600 are not compatible with one another. If you have part number 821-0600, then part number 821-0449 will not work in your iPhone.


    My iphone needs the 821-600 model. How come no one sells this???? I can't find it for sale anywhere online. Only the order model.

    Also if you take the ends of and look at them like in the article OP has linked above you will see the contacts patter differently which is why it picks up the way it does.
    Last edited by Pyrofallout; 2008-11-26 at 10:52 PM. Reason: Automerged Doublepost

  4. #4
    Has anybody found a source for the 821-600 headphone jack? My original power button failed so I replaced the button only to run into this same issue.

    Also purchased a replacement back for it and have since found that it is for the old jack... So now I've got a back and button incompatible with my phone.

  5. #5
    Quote Originally Posted by GogNav View Post
    Hi,

    I have ordered TWO new headphone-jack parts for iFixit. Here are my observations :

    If i disconnect the hole set of buttons, i hear the sound from the keypad for example. When I connect it, no more sound.

    Then I put in my headphone : sound comes back on the iphone (but not the headphones!). Conclusion : when the headphone are in, the Iphone thinks he is in normal mode (so sound comes out normally) but when the headset are removed, the iphone might think headset are in, so disactivates the sound of the iphone ! Bottom line : it works great, but in reverse order !!!!

    Any ideas ?
    Ok so here is what I found. I had this issue and replaced my part 821-0449-A with the same from ebay. It had the problem described above. I found that the contact inside the jack is different causing the problem. I decided to try the other part out(821-600-a) which should not have worked but it did to my supprise and it is all in working order with a new back and flex cable. I found my part 821-0600-a on ebay for 15 bucks. So my suggestion would be try the other part out if you are having this problem.

    Quote Originally Posted by Cindobley View Post
    Has anybody found a source for the 821-600 headphone jack? My original power button failed so I replaced the button only to run into this same issue.

    Also purchased a replacement back for it and have since found that it is for the old jack... So now I've got a back and button incompatible with my phone.
    Do an ebay search for "0600 iphone" and it comes right up.
    Last edited by fester99; 2009-12-29 at 05:00 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •