+ Reply
Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How To: Use gMail to Get Exchange Support

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
This will allow you to send mail from your phone and have it appear as if they were coming directly from the exchange server. I figured this out last week
...
  1. #1
    iPhoneaholic EmoRebellion's Avatar
    Join Date
    Aug 2007
    Posts
    406
    Thanks
    4
    Thanked 24 Times in 23 Posts

    Default How To: Use gMail to Get Exchange Support
    This will allow you to send mail from your phone and have it appear as if they were coming directly from the exchange server. I figured this out last week while trying to use the "send as" feature in gMail.

    Create a gMail account and Log in from a computer (or safari on the phone). Go to settings, and click the account tab. In send "send mail as" section, click add a new email address. Fill in the information for your exchange account. You will receive an email in your exchange box asking you to confirm that you own the account. Log in to gmail and set your exchange account as the default mail account.

    On your iPhone, create a new POP account (NOT a gMail account). Use your exchange address for the email address. Set pop.gmail.com as your incoming server, with your username and password (without the @gmail.com). Set smtp.gmail.com as your outgoing mail server, with your gmail username and password.

    Forward all your incoming mail to your gmail account, and you will have almost full exchange email support! When you send an email, it will come from your exchange address, and replies will automatically be sent there. The recipient will never see the gmail address.

  2. The Following User Says Thank You to EmoRebellion For This Useful Post:

    eg6motion (08-28-2007)

  3. #2
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,893
    Thanks
    340
    Thanked 15,273 Times in 652 Posts

    not bad

  4. #3
    iPhone? More like MyPhone
    Join Date
    Jul 2007
    Location
    Austin, Texas
    Posts
    106
    Thanks
    1
    Thanked 22 Times in 7 Posts

    lol...nice thinking. I did this exact same thing with like 10 of my users on Blackberries with their BIS service before I built a blackberry server. Right now I am accessing my exchange server through imap but this is very good. Very creative.

  5. #4
    iPhoneaholic EmoRebellion's Avatar
    Join Date
    Aug 2007
    Posts
    406
    Thanks
    4
    Thanked 24 Times in 23 Posts

    Thanks. It was the only way I could get my email without wanting to smash my phone every 2 hours.

  6. #5
    iPhoneaholic
    Join Date
    Aug 2007
    Posts
    391
    Thanks
    13
    Thanked 53 Times in 34 Posts

    except if your company uses outlook 2003, then they see your gmail account. Mail appears as "[email protected] on behalf of [email protected]". Otherwise it works great. Guess its a big complaint with gmail too.

  7. #6
    iPhoneaholic EmoRebellion's Avatar
    Join Date
    Aug 2007
    Posts
    406
    Thanks
    4
    Thanked 24 Times in 23 Posts

    The version of outlook doesnt have anything to do it. That is just a client used to download messages from the Exchange server. Did you set up your phone exactly the way I explained it? If you select gMail as your provider on your phone, it will not work correctly. You must select a POP account, and put [email protected] as your email address.

  8. #7
    iPhoneaholic
    Join Date
    Aug 2007
    Posts
    391
    Thanks
    13
    Thanked 53 Times in 34 Posts

    yep, did it that way. Outlook still picks up the sender field that gmail puts in online. Normally most other clients only read the "from" field in which it would only display the exchange address. But because gmail submits both from and sender fields, the whole "on behalf of" part shows up in outlook Did a quick google search and everyone seems to have that problem when using outlook. But if they use webmail or another client than all they see is the exchange account.
    Last edited by eg6motion; 08-29-2007 at 08:13 AM.

  9. #8
    Green Apple
    Join Date
    Oct 2007
    Posts
    61
    Thanks
    2
    Thanked 1 Time in 1 Post
    i'm having a problem with my outlook...i set it up just the way you explained but outlook does not forward the e-mail to my gmail account..i have the rule set up for ANY mail that i receive in my inbox to be forwarded to my gmail....any help?

  10. #9
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Probably your Exchange server doesn't allow automatic forwarding to internet adresses.
    Check with your administrator to see if this feature is enabled.

  11. #10
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    You should setup a rule to redirect all email to the gmail account, not forward. Then the email comes from the actual sender, not your exchange account. Hope this helps...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts