I have had my Iphone for two days and I either made the mistake of upgrading to 1.1.2 or it came that way but in order for me to use IMAGE DIALER i have to have the 1.1.1? or the can i have the latest version? And if its ok to have the latest version how the heck to put it on my phone? new to this whole movement...any other tips will be greatly appreciated. Could you lead me to the right thread to learn more about going back to 1.1.2 or how to put on those cool backgrounds EVERYONE has....please help and im not the greatest when it comes to directions...so if anyone has easy to understand directions..please help..THANKS.