Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Lots of Earpiece Static

  1. #1
    Default Lots of Earpiece Static
    I have tons of static in my earpiece for all calls on my iPhone. It's not a reception issue because I have full bars, and when the SIM is swapped to my K750i, reception is perfect and no static.

    iPhone is running on 1.1.4 and Jailbroken (out of warranty).

    Anyone else have this issue? Thanks in advance.

  2. #2
    I'm having the same problem. It worked great for months. Now it has tons of static. However.. when I use my plantronics 3xx the static is gone. Has anyone found a fix for this issue?

  3. #3
    I'm having the same problem. I think it's an issue with the antenna. Did you take the antenna cover off. Try pressing on different places on the antenna cover. Does that make any change. The connection to the antenna may be loose. I had to force the cover back on and may have loosened it I wonder if thats the problem.

  4. #4
    My god! this is the same problem I'm having! STATIC noises whenever I place a call or receive... but when I plug in the earphones, the static noise disappears.. .any ideas?! Please help!!

  5. #5
    I found that if I takecthe antenna cover off it goes away. If that's the same for the rest of you guys then it may be the issue try a new antenna cover they're $20 on eBay.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •