+ Reply
Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: repair needed

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
i tryed to downgrade my iphone but all it says now is ''repair needed iphone cannot make or receive calls. www.apple.com/support '' have i damaged my phone or is there
...
  1. #1
    iPhone? More like MyPhone coiledserpent's Avatar
    Join Date
    Sep 2007
    Location
    Galway, Ireland, Ireland
    Posts
    120
    Thanks
    14
    Thanked 1 Time in 1 Post
    Default repair needed
    i tryed to downgrade my iphone but all it says now is ''repair needed iphone cannot make or receive calls.www.apple.com/support''

    have i damaged my phone or is there a way out of this?
    plz plz plz can someone help

  2. #2
    My iPhone is a Part of Me pokekid's Avatar
    Join Date
    Sep 2007
    Location
    Manteca
    Posts
    812
    Thanks
    29
    Thanked 77 Times in 66 Posts

    i remember someone here had that and fixed it themselves..try ibrickr to boot the phone after u put it in recovery

  3. #3
    iPhone? More like MyPhone coiledserpent's Avatar
    Join Date
    Sep 2007
    Location
    Galway, Ireland, Ireland
    Posts
    120
    Thanks
    14
    Thanked 1 Time in 1 Post
    i did that already but no luck
    i will try it again just to make sure
    i have no wifi or modem too

  4. #4
    Moderator / DRP Dev Team jedinight's Avatar
    Join Date
    Jul 2007
    Location
    c.s. texas
    Posts
    969
    Thanks
    49
    Thanked 113 Times in 89 Posts

    you where trying to downgrade baseband,or the firmware?

  5. #5
    iPhone? More like MyPhone coiledserpent's Avatar
    Join Date
    Sep 2007
    Location
    Galway, Ireland, Ireland
    Posts
    120
    Thanks
    14
    Thanked 1 Time in 1 Post
    its on 1.0.2 m8 im activated but no sim no sound no wifi and no firmware when i type the code in the keypad and look for firmware theres nothing
    so what im tryin to do is get it back to 1.0.2 activated unlocked and sound and all back
    whatever you think bud ill give it a go

  6. #6
    iPhoneaholic rusty778's Avatar
    Join Date
    Jun 2007
    Location
    Miami,FL
    Posts
    373
    Thanks
    4
    Thanked 61 Times in 49 Posts

    that happened to mine I was using the new ifuntastic and it got stuck while in dfu mode so i tried to restore it back to 1.1.1 and it said that at the iphone needs to be repaired at the activation screen. I think it means the baseband and wifi is completely corrupt. I took it to the apple store and told them I was in the middle of updating to 1.1.1 and the dock accidentally got yanked out of the usb port and they gave me a new one. best of luck to you
    Last edited by rusty778; 10-25-2007 at 04:03 PM. Reason: typo

  7. #7
    iPhone? More like MyPhone coiledserpent's Avatar
    Join Date
    Sep 2007
    Location
    Galway, Ireland, Ireland
    Posts
    120
    Thanks
    14
    Thanked 1 Time in 1 Post
    awww ur jokin me i do have a years warranty but i live in ireland and my phone is modded i dont think they will give me a new 1.
    is there any other way around this like software based
    im no longer getting the repair needed message but still no wifi or sound or modem
    would it be down to a program i used or something to do with the commcenter?

    should i go back to 1.1.1 and try from there?

    when i go into dfu mode and try to restore with itunes i get an unknown error occurred (1012)
    Last edited by coiledserpent; 10-25-2007 at 04:53 PM. Reason: Automerged Doublepost

  8. #8
    iPhoneaholic rusty778's Avatar
    Join Date
    Jun 2007
    Location
    Miami,FL
    Posts
    373
    Thanks
    4
    Thanked 61 Times in 49 Posts

    sorry im not but if you are still running 1.0.2 try jailbreaking it and the new revirginizeing process

  9. #9
    iPhone? More like MyPhone coiledserpent's Avatar
    Join Date
    Sep 2007
    Location
    Galway, Ireland, Ireland
    Posts
    120
    Thanks
    14
    Thanked 1 Time in 1 Post
    ok i tried to jailbreak it with wiNstaller even though it was already activated and what not but this is what i got
    Looking for restore files
    Ramdisk: 009-7698-4.dmg
    Kernelcache: kernelcache.release.s5l8900xrb
    iPhone connected
    Please connect the iPhone
    Checking for jailbreak
    Checking for activation
    Notified of connection
    Jailbreaking...
    Sending temp fstab
    Sending temp Services.plist
    Entering recovery mode
    iPhone disconnected
    iPhone connected in recovery mode
    Entering restore mode
    Sending ramdisk
    Issuing ramdisk command
    Sending kernelcache
    Booting to restore mode
    iPhone disconnected from recovery mode
    iPhone connected
    Performing restore mode activities
    Filesystem check 1
    Filesystem check 2
    Mount /dev/disk0s1
    Mount /dev/disk0s2
    Copy fstab
    Copy Services.plist
    Remove temp fstab
    Remove temp Services.plist
    Unmount /mnt2
    Unmount /mnt1
    Exit restore mode
    iPhone disconnected
    iPhone connected in recovery mode
    Exiting recovery mode
    iPhone disconnected from recovery mode
    iPhone connected
    Checking for jailbreak
    iPhone is jailbroken
    Checking for activation
    Notified of connection
    Performing final steps
    Activating!
    Could not retrieve the ICCID (make sure the SIM is inserted).
    Jailbreak complete!

  10. #10
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have the same problem that you. Did you resolved it?? I use Mac but if you have the solution in windows please, tell me. I have two phones in this state!!!

  11. #11
    iPhone? More like MyPhone coiledserpent's Avatar
    Join Date
    Sep 2007
    Location
    Galway, Ireland, Ireland
    Posts
    120
    Thanks
    14
    Thanked 1 Time in 1 Post
    no m8 im still stuck wondering what i can do
    can any1 here at this brill site give us a heads up?

    update: my phone is back to normal after following these two guides
    http://www.hackint0sh.org/forum/showthread.php?t=13255

    http://modmyi.com/forums/showthread.php?t=10461

    i hope it works for ye guys with the same problems i had.
    Last edited by coiledserpent; 10-28-2007 at 06:41 AM. Reason: Automerged Doublepost

  12. #12
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hi Guys!

    I finally realized how to fix my problem (just restoring the phones...)

    What I did:

    Wait till the battery was almost empty and shows in the screen the red battery asking you to connect to the power and then I connected it to the main power supply till the apple logo appear.

    Then I used the 10/15 sec trick for restoring the 1.0.2 firmware I downloaded (remember I had both phones in the state they didn't recognize what firmware they have) and It went succesfully done.

    Now I have both phones with the "Activate phone" screen and 1.0.2 firmware.

    What shoyld I do now?


    Thanks!!!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts