the question i have i curently with ATT eunning 1.0.2 what do i have to do to get 1.1.1 running with apps? to many posts here my phone is with ATT i do not have to unlock, or do i?