Hi I am running iTunes 10.5 and wanted to update to iOS 5 but it gives the message that I am not eligible for that build. I have updated my iPad to 4.3.5 using the ipsw file.
But it will not let do anything more. Can someone help please.
Even jail breaking and trying to update that way does not work.

Thanks Kerry