+ Reply
Page 2 of 36 FirstFirst 1234 12 ... LastLast
Results 21 to 40 of 705

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SBHTML: SpringBoard HTML Wallpaper Platform

is a discussion within the

File Mods

forums, a part of the

iPhone Modding

section;
Should springboard wallpapers show up behind the SB widgets? I'm using Dacals Animation only widget and it's working great but just have a white background behind it. Wondering why my
...
  1. #21
    The Formulator Marty McFly's Avatar
    Join Date
    Mar 2013
    Location
    Barrie
    Posts
    1,310
    Thanks
    4,051
    Thanked 4,566 Times in 1,020 Posts

    Should springboard wallpapers show up behind the SB widgets? I'm using Dacals Animation only widget and it's working great but just have a white background behind it. Wondering why my SB wallpaper won't show. Thoughts?

  2. #22
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,275
    Thanks
    6,652
    Thanked 14,873 Times in 6,898 Posts

    Quote Originally Posted by Marty McFly View Post
    Should springboard wallpapers show up behind the SB widgets? I'm using Dacals Animation only widget and it's working great but just have a white background behind it. Wondering why my SB wallpaper won't show. Thoughts?
    The webview has a white canvas right now. If Jake makes it transparent like groovylock is then we should be able to see wallpaper behind the widget. Assuming the widget doesn't show it's own wallpaper of course.

  3. The Following User Says Thank You to Simon For This Useful Post:

    Marty McFly (05-18-2014)

  4. #23
    The Big D NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,469
    Thanks
    3,764
    Thanked 8,554 Times in 4,330 Posts

    Quote Originally Posted by Marty McFly View Post
    Should springboard wallpapers show up behind the SB widgets? I'm using Dacals Animation only widget and it's working great but just have a white background behind it. Wondering why my SB wallpaper won't show. Thoughts?
    Springboard Wallpapers, built into SB Widgets should show behind animation if you have them switched on. IF however you want to see your Apple Wallpaper chosen in Settings behind an SB widget you have to put a transparent image where a wallpaper image is called for in the html or the js file.

    Quote Originally Posted by Simon View Post
    The webview has a white canvas right now. If Jake makes it transparent like groovylock is then we should be able to see wallpaper behind the widget. Assuming the widget doesn't show it's own wallpaper of course.
    Yeah. What Simon said. He explained it better. Didn't see his post when I made mine..
    Last edited by NewdestinyX; 05-18-2014 at 05:44 PM.
    Here to help if I can. If I can't I know someone who can!

  5. The Following 3 Users Say Thank You to NewdestinyX For This Useful Post:

    killerdroid (05-20-2014), menard_00 (05-18-2014), rjr1124 (05-22-2014)

  6. #24
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,275
    Thanks
    6,652
    Thanked 14,873 Times in 6,898 Posts

    Quote Originally Posted by NewdestinyX View Post
    One of the simplest codes out there - Ian's Timed Walls -- alone.. Only 15 lines of code..
    PM me the link if you can. Wanna try out same one and see if I'm getting similar issues. None if mine are doing that on any of the versions of sbhtml I've tried.

  7. #25
    The Big D NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,469
    Thanks
    3,764
    Thanked 8,554 Times in 4,330 Posts

    Quote Originally Posted by Simon View Post
    PM me the link if you can. Wanna try out same one and see if I'm getting similar issues. None if mine are doing that on any of the versions of sbhtml I've tried.
    Will do when I get home..

    So when we're seeing the white, Simon, it's because our widget hasn't launched yet. Right?
    Here to help if I can. If I can't I know someone who can!

  8. #26
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,275
    Thanks
    6,652
    Thanked 14,873 Times in 6,898 Posts

    Quote Originally Posted by NewdestinyX View Post
    Will do when I get home..

    So when we're seeing the white, Simon, it's because our widget hasn't launched yet. Right?
    Yup, the white is the default webview right now with nothing loaded. Groovylock was same way at first until jake made the webview transparent.

  9. The Following User Says Thank You to Simon For This Useful Post:

    menard_00 (05-18-2014)

  10. #27
    iPhone? More like MyPhone menard_00's Avatar
    Join Date
    Feb 2013
    Location
    My House
    Posts
    207
    Thanks
    881
    Thanked 298 Times in 133 Posts

    I'm on i5 and getting same white screen. Loaded a new theme 10 times and lock/unlock has worked for me every time.

  11. The Following User Says Thank You to menard_00 For This Useful Post:

    RKO1195 (05-18-2014)

  12. #28
    The Big D NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,469
    Thanks
    3,764
    Thanked 8,554 Times in 4,330 Posts

    Quote Originally Posted by Simon View Post
    Yup, the white is the default webview right now with nothing loaded. Groovylock was same way at first until jake made the webview transparent.
    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    Here to help if I can. If I can't I know someone who can!

  13. #29
    iPhone? More like MyPhone Azon3's Avatar
    Join Date
    Mar 2014
    Posts
    106
    Thanks
    1,114
    Thanked 158 Times in 56 Posts

    Thanks to this amazing tweak I have pano walls on my sb again. Running MJSmashPanoLite_v1 and all is well .

  14. The Following User Says Thank You to Azon3 For This Useful Post:

    MamaJaay (05-19-2014)

  15. #30
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,275
    Thanks
    6,652
    Thanked 14,873 Times in 6,898 Posts

    Quote Originally Posted by NewdestinyX View Post
    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    I haven't. Not sure if I have any of those ones.

  16. #31
    Evil Genius Developer GroovyCarrot's Avatar
    Join Date
    Jan 2012
    Location
    Liverpool, United Kingdom
    Posts
    483
    Thanks
    93
    Thanked 1,686 Times in 408 Posts

    Quote Originally Posted by NewdestinyX View Post
    I'm having the same problem of white screen until a reboot. A simple respring or going in and out of an app doesn't fix it for me on 5S.

    I'm gonna start going through and turning of MobileSubstrates of tweaks like SpringPaper that attempt to do the same thing as SBHTML. THough I've turned off the enable button for SpringPaper - I haven't turned off its MobileSubstrate with iCleanerPro.

    Report your findings here so Jake can work out the final issues.

    Are any of you on iPhone 5 getting the white screen issue? Or is it confined to 5S? I know Bliken, who will report in here shortly has a 5S and is having the same issue.

    JKauff, are you on a 5S? Do you use any other SpringBoard Wallpaper tweaks by any chance?

    This hasn't worked for me, Simon. After several attempts - only the reboot worked.
    Logic-wise I would say any tweak that affects the dock may steal the events that this tweak hooks? If that's a start

    Also transparency fixed and icon courtesy of Simon: https://www.dropbox.com/s/htbkr99qi4...html-1.0.4.deb

  17. The Following 12 Users Say Thank You to GroovyCarrot For This Useful Post:

    Azon3 (05-18-2014), chevymusclecar (05-19-2014), It's Mi (05-28-2014), jawonder (05-19-2014), Jkauf55 (05-18-2014), kristatos (05-18-2014), Laxu (05-21-2014), MamaJaay (05-19-2014), menard_00 (05-18-2014), riassan (05-19-2014), RKO1195 (05-18-2014), Simon (05-18-2014)

  18. #32
    iPhone? More like MyPhone kristatos's Avatar
    Join Date
    Nov 2011
    Location
    Chicago, IL, USA
    Posts
    228
    Thanks
    3,728
    Thanked 620 Times in 165 Posts

    Quote Originally Posted by GroovyCarrot View Post
    Logic-wise I would say any tweak that affects the dock may steal the events that this tweak hooks? If that's a start

    Also transparency fixed and icon courtesy of Simon: https://www.dropbox.com/s/htbkr99qi4...html-1.0.4.deb
    I bow before thee, Sir...running 7.0.4 with SB animations....sweet!...

    7.0.4 with SB widget.jpg

  19. The Following User Says Thank You to kristatos For This Useful Post:

    It's Mi (05-28-2014)

  20. #33
    My iPhone is a Part of Me bliken's Avatar
    Join Date
    Apr 2013
    Posts
    691
    Thanks
    651
    Thanked 400 Times in 270 Posts

    I too am having the white background with nothing showing up. Using UNIAW6.4SB

    Opened apps and closed them....respring doesn't do anything either

  21. #34
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    8,869
    Thanks
    39,251
    Thanked 16,427 Times in 6,010 Posts

    Quote Originally Posted by NewdestinyX View Post
    I did a brief beta for Jake on this -- and only 1.0.1, is working perfectly for me - with no white screen.

    All I get is a white screen.
    Last edited by King_O_Hill; 05-18-2014 at 09:17 PM.
    Widget-Weather App Now Available! Also with MyLocation Support!
    Check out the thread here - Widget-Weather
    To install the Widget-Weather app, just go to Cydia and install. This will also remove MyLocation, as it is built in!
    Want to protect your JailBreak! Add this repo http://cydia.myrepospace.com/iLEXiNFO/ & Install "iLEX R.A.T."
    It will allow you to bring your phone back to a fresh jailbroken state!

  22. #35
    widget modder RKO1195's Avatar
    Join Date
    Aug 2010
    Location
    Alabama
    Posts
    2,219
    Thanks
    9,861
    Thanked 5,022 Times in 1,714 Posts

    You need to only lock the phone and unlock and it will work nothing else
    WidgetWeather ​Thread

  23. #36
    My iPhone is a Part of Me
    Join Date
    Mar 2011
    Location
    Nashville
    Posts
    696
    Thanks
    859
    Thanked 1,228 Times in 381 Posts

    Quote Originally Posted by NewdestinyX View Post
    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    No I'm on ip5. No other tweaks beside iwidget and GroovyLock. After updating to 1.0.4 it's been loading better. If not a simple lock, waiting a few secs, and unlocking has fixed it.

    That's what I'm using (older style SB w/ Overlay).

    Last edited by Jkauf55; 05-18-2014 at 07:01 PM.

  24. The Following User Says Thank You to Jkauf55 For This Useful Post:

    It's Mi (05-28-2014)

  25. #37
    iPhone? More like MyPhone kristatos's Avatar
    Join Date
    Nov 2011
    Location
    Chicago, IL, USA
    Posts
    228
    Thanks
    3,728
    Thanked 620 Times in 165 Posts

    Quote Originally Posted by NewdestinyX View Post
    I'm having the same problem of white screen until a reboot. A simple respring or going in and out of an app doesn't fix it for me on 5S.

    I'm gonna start going through and turning of MobileSubstrates of tweaks like SpringPaper that attempt to do the same thing as SBHTML. THough I've turned off the enable button for SpringPaper - I haven't turned off its MobileSubstrate with iCleanerPro.

    Report your findings here so Jake can work out the final issues.

    Are any of you on iPhone 5 getting the white screen issue? Or is it confined to 5S? I know Bliken, who will report in here shortly has a 5S and is having the same issue.

    JKauff, are you on a 5S? Do you use any other SpringBoard Wallpaper tweaks by any chance?

    This hasn't worked for me, Simon. After several attempts - only the reboot worked.
    I have an iP5 running 7.0.4 and had the white screen a couple of times after I change the icon layout through the settings.app...
    But it was fixed after respring with CC GUI cleaner...but it only happened after changing the icon layout...I have resprung several times
    using different methods and it hasn't happened again...this was with 1.0.3 version and also 1.0.4...I use Iconoclasm still...not HSD...

    Also...it happened after I unlock the phone right away after respring (before the LS dims)...I changed the icon layout again but waited for the LS to dim (I have it set for 30 secs) and it was OK...

    Quote Originally Posted by NewdestinyX View Post
    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    See my post #32...Sb widget from a theme that hasn't been ported to iOS7..been waiting months to use that SB...thanks GC...
    Last edited by kristatos; 05-18-2014 at 06:56 PM.

  26. #38
    My iPhone is a Part of Me
    Join Date
    Mar 2011
    Location
    Nashville
    Posts
    696
    Thanks
    859
    Thanked 1,228 Times in 381 Posts

    Quote Originally Posted by GroovyCarrot View Post

    Also transparency fixed and icon courtesy of Simon: https://www.dropbox.com/s/htbkr99qi4...html-1.0.4.deb
    Icon on Springboard?

  27. #39
    Livin the iPhone Life TeddyDiesel's Avatar
    Join Date
    May 2013
    Location
    USA
    Posts
    1,069
    Thanks
    4,947
    Thanked 2,869 Times in 875 Posts

    Here is using an old one from Mone, and it works great!


    Running ip5, 7.0.4, and only having to lock/unlock to get it to kick in.

    Amazing work, thank you!


    Edit: Also, ClassicDock still good to go.
    Last edited by TeddyDiesel; 05-18-2014 at 07:07 PM.

  28. The Following User Says Thank You to TeddyDiesel For This Useful Post:

    It's Mi (05-28-2014)

  29. #40
    My iPhone is a Part of Me bliken's Avatar
    Join Date
    Apr 2013
    Posts
    691
    Thanks
    651
    Thanked 400 Times in 270 Posts

    Well after a few reboots and a hard reset. I have UNIAW6.4SB working with times walls.

    ImageUploadedByModMyi1400462427.317072.jpg

    ImageUploadedByModMyi1400462435.931369.jpg

    ImageUploadedByModMyi1400462443.484739.jpg

  30. The Following User Says Thank You to bliken For This Useful Post:

    It's Mi (05-28-2014)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts