+ Reply
Page 49 of 206 FirstFirst ... 394748495051 59 99 149 ... LastLast
Results 961 to 980 of 4114

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Widget Weather

is a discussion within the

File Mods

forums, a part of the

iPhone Modding

section;
Originally Posted by The_Durben When on Constant or Semi and Neighborhood Location is toggled on I have not seen a delay on additional location info. (Besides a few seconds delay
...
  1. #961
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,611
    Thanks
    3,991
    Thanked 8,805 Times in 4,429 Posts

    Quote Originally Posted by The_Durben View Post
    When on Constant or Semi and Neighborhood Location is toggled on I have not seen a delay on additional location info. (Besides a few seconds delay for an iWidget on springboard compared to a lock screen) (locks check again on unlock/lock, iWidget sticks with the 20 second interval checking the xml)

    The only time I've seen a delay in the extra location info changing is when Fixed is selected.
    The locks or widgets using main name/city change right away to your set woeid and weather info for it.
    The extra location information doesn't change until the next refresh of the xml. (Something to do with the tweak sending that woeid back to get additional location info for that woeid and then updating it)
    On fixed this shouldn't be an issue as your telling the widgets what city you want to see and you get that city.


    Sorry if I didn't get what was being asked, it's early and I'm confused
    I think you understood my question perfectly, D. But I can confirm, simply by the way I've constructed my widgets, that in Constant mode there is often a misalignment between the main city name and the extra location information in terms of the update time. It's usually only separated by 30 seconds to 2 min, but that's still a big separation (for a mode called "constant") that I wonder if Stephen knows about. Or if it's part of the design (or limitation of the hardware/firmware). I'm not gonna be jumping up-and-down insisting on some kind of fix. But I just wanted to let you know that there definitely is a timing misalignment often thru the day When you watch a single widget that calls for both the main city data and some of the extra location data.

    And I haven't heard you speak into my question from several pages back about why the weather.app, when set to local weather, only when this new tweak is installed, shows a lot of county information rather than city. That never happened before the installation of WW. Is there some aspect of the tweak's "takeover" of weather.app that would cause this? I really never reference weather.app at all. But I'm sure others do and might wonder about this.
    Last edited by NewdestinyX; 08-29-2013 at 12:13 PM.
    Here to help if I can. If I can't I know someone who can!

  2. #962
    The Mechanic The_Durben's Avatar
    Join Date
    Aug 2010
    Location
    Vancouver Canada
    Posts
    8,424
    Thanks
    34,944
    Thanked 40,561 Times in 7,513 Posts

    The whole GPS piece is being redone when Stephen gets time.
    Really not worried about the timing of the info being updated right now until we see what the new deb is doing.
    A lot of people using this right now don't have an issue with the main city and its info that shows.


    As for the weather app, yes it does weird things with names. Has always done this.
    I've seen postal codes show in it before so county or other names are not a surprise.

  3. The Following 4 Users Say Thank You to The_Durben For This Useful Post:

    Alfroggy (08-29-2013), lostinthemes (08-31-2013), RKO1195 (08-29-2013), TEK_2012 (08-29-2013)

  4. #963
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,611
    Thanks
    3,991
    Thanked 8,805 Times in 4,429 Posts

    Quote Originally Posted by The_Durben View Post
    The whole GPS piece is being redone when Stephen gets time.
    Really not worried about the timing of the info being updated right now until we see what the new deb is doing.
    Understood. Perfectly fine. Glad to hear that Stephen's thinking of improvements even to something so wonderful as is. Thanks for the reply.
    A lot of people using this right now don't have an issue with the main city and its info that shows.
    And I have no problem with Main City either.. It can just be strange when you have a widget that shows both Main City and some other element of the Extra Location stuff - and they don't update at the same time. That's all I was referring to.

    As for the weather app, yes it does weird things with names. Has always done this.
    I've seen postal codes show in it before so county or other names are not a surprise.
    Though some city data isn't always accurate with Weather.app and never has been - there is a very distinctly different behavior when WW is installed that is a very repeatable behavior in testing.
    Without WW installed - Weather.app 99% of the time pulls a city name.
    With WW installed Weather.app pulls a County name (in US) 80% of the time when constant mode is on (haven't tested other settings in tweak besides constant).

    Just more data for you guys to have in your tweaking the tweak stages.

    Thanks, D!
    Grant
    Here to help if I can. If I can't I know someone who can!

  5. The Following User Says Thank You to NewdestinyX For This Useful Post:

    King_O_Hill (08-29-2013)

  6. #964
    Full Moon Krima's Avatar
    Join Date
    Jul 2011
    Location
    Nashville, Tn
    Posts
    3,068
    Thanks
    3,904
    Thanked 7,611 Times in 2,394 Posts

    For me Grant, even without the WW tweak, the weather app almost always pulled county for me when set to local weather. I'm not gonna throw out some percentage that I can't prove so ill just leave it at "almost always". Just not comfortable giving a percentage that can't be backed up with data.

    So, I really don't think the tweak did anything. You may just not have noticed it before.
    Last edited by Krima; 08-29-2013 at 12:37 PM.

  7. The Following 7 Users Say Thank You to Krima For This Useful Post:

    Alfroggy (08-29-2013), King_O_Hill (08-29-2013), Marty McFly (08-30-2013), NewdestinyX (08-29-2013), RKO1195 (08-29-2013), Simon (08-29-2013), The_Durben (08-29-2013)

  8. #965
    The Mechanic The_Durben's Avatar
    Join Date
    Aug 2010
    Location
    Vancouver Canada
    Posts
    8,424
    Thanks
    34,944
    Thanked 40,561 Times in 7,513 Posts

    Quote Originally Posted by Krima View Post
    For me Grant, even without the WW tweak, the weather app almost always pulled county for me when set to local weather. I'm not gonna throw out some percentage that I can't prove so ill just leave it at "almost always". Just not comfortable giving a percentage that can't be backed up with data.

    So, I really don't think the tweak did anything. You may just not have noticed it before.
    Exactly, those stats mean nothing.
    I have the tweak on one phone and not on another one.
    Weather app on both has exact same info wherever I am.

  9. The Following 6 Users Say Thank You to The_Durben For This Useful Post:

    King_O_Hill (08-29-2013), Krima (08-29-2013), Marty McFly (08-30-2013), NewdestinyX (08-29-2013), Simon (08-29-2013), TEK_2012 (08-29-2013)

  10. #966
    Full Moon Krima's Avatar
    Join Date
    Jul 2011
    Location
    Nashville, Tn
    Posts
    3,068
    Thanks
    3,904
    Thanked 7,611 Times in 2,394 Posts

    Quote Originally Posted by The_Durben View Post
    Exactly, those stats mean nothing.
    I have the tweak on one phone and not on another one.
    Weather app on both has exact same info wherever I am.
    Exactly Durben. I too have another non jail broken 4s and the weather app shows my county at times just like my jail broken i5. I really just think he never paid attention before because native sucked and GPS ruled the streets.

  11. The Following 6 Users Say Thank You to Krima For This Useful Post:

    Alfroggy (08-29-2013), King_O_Hill (08-29-2013), Marty McFly (08-30-2013), NewdestinyX (08-29-2013), RKO1195 (08-29-2013), The_Durben (08-29-2013)

  12. #967
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,611
    Thanks
    3,991
    Thanked 8,805 Times in 4,429 Posts

    Quote Originally Posted by Krima View Post
    For me Grant, even without the WW tweak, the weather app almost always pulled county for me when set to local weather. I'm not gonna throw out some percentage that I can't prove so ill just leave it at "almost always". Just not comfortable giving a percentage that can't be backed up with data.

    So, I really don't think the tweak did anything. You may just not have noticed it before.
    Completely appropriate observation. I've just done current testing over a couple of phones and there seemed to be a difference when tweak was installed and when not. But I will completely concede that it certainly isn't conclusive testing.

    Quote Originally Posted by The_Durben View Post
    Exactly, those stats mean nothing.
    I have the tweak on one phone and not on another one.
    Weather app on both has exact same info wherever I am.
    Yeah, fair enough, D. It could be pure coincidence. I will drop it. It helps hearing from others - their experiences.
    Last edited by NewdestinyX; 08-29-2013 at 01:25 PM.
    Here to help if I can. If I can't I know someone who can!

  13. The Following 4 Users Say Thank You to NewdestinyX For This Useful Post:

    Alfroggy (08-29-2013), King_O_Hill (08-30-2013), lostinthemes (08-31-2013), The_Durben (08-29-2013)

  14. #968
    The Mechanic The_Durben's Avatar
    Join Date
    Aug 2010
    Location
    Vancouver Canada
    Posts
    8,424
    Thanks
    34,944
    Thanked 40,561 Times in 7,513 Posts

    Also the extra location info was put in as a backup for if there was an issue with city showing.
    I can see that some like to have it all showing but it's intention is for showing as an alternative.
    Making widgets that use just that info (locale information) is an option sure but looking at "fixing" a timing issue to support that is least on the list of to-do's
    We will see how an update to the GPS localization goes before trying to change anything with the current deb.

    Another thing is compatibility issues with lockinfo will also be looked at but there's no promise they can be compatible.

  15. The Following 7 Users Say Thank You to The_Durben For This Useful Post:

    Alfroggy (08-29-2013), j0k3r (08-29-2013), King_O_Hill (08-29-2013), lostinthemes (08-31-2013), NewdestinyX (08-29-2013), RKO1195 (08-29-2013), TEK_2012 (08-29-2013)

  16. #969
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,611
    Thanks
    3,991
    Thanked 8,805 Times in 4,429 Posts

    Quote Originally Posted by The_Durben View Post
    Also the extra location info was put in as a backup for if there was an issue with city showing.
    I can see that some like to have it all showing but it's intention is for showing as an alternative.
    Making widgets that use just that info (locale information) is an option sure but looking at "fixing" a timing issue to support that is least on the list of to-do's
    We will see how an update to the GPS localization goes before trying to change anything with the current deb.
    Yes, I can completely see that time aligning between main city and extra location being low priority and not what the intent was for the extra location. Having them align time-wise would be more of a luxury. But a guy can dream, can't he??.. I won't be waiting around with baited breath to get them to align perfectly. Although IF people prefer the alternate location data - they are waiting longer for it to appear. That may or may not give it any more priority. I trust the team. I've been thrilled so far as I've said over and over.

    But I 'am' hoping that the 'general' lag timing in the Main City function in Constant mode, within the first 30 minutes of use after waking from sleep or reengaging Location Services, is a bug that can be tracked down.

    I have found a workaround - that's been pretty consistently working for me. If when you wake from deep sleep and/or have had Location Services off and then switch them on. Switch Location service off and back on - one more time. And that seems to reset the timing such that in Constant mode - there is no lag from there forward. A city auto changes when a new GPS location is achieved in Constant mode.

    The reason why I think 'that' is a bug that needs to be fixed - is that not even the tweak reaching the time interval will update it. It just seems to randomly get stuck and then start working again after 20-30 minutes.
    Last edited by NewdestinyX; 08-29-2013 at 02:16 PM.
    Here to help if I can. If I can't I know someone who can!

  17. The Following 4 Users Say Thank You to NewdestinyX For This Useful Post:

    Alfroggy (08-29-2013), King_O_Hill (08-30-2013), lostinthemes (08-31-2013), The_Durben (08-29-2013)

  18. #970
    Livin the iPhone Life TEK_2012's Avatar
    Join Date
    Apr 2012
    Posts
    1,169
    Thanks
    6,731
    Thanked 2,162 Times in 852 Posts

    This does look real good with Ezra thanks again Durben ImageUploadedByModMyi1377817459.755669.jpg

  19. The Following 4 Users Say Thank You to TEK_2012 For This Useful Post:

    Alfroggy (08-29-2013), King_O_Hill (08-29-2013), RKO1195 (08-29-2013), The_Durben (08-29-2013)

  20. #971
    My iPhone is a Part of Me
    Join Date
    Feb 2008
    Posts
    668
    Thanks
    406
    Thanked 204 Times in 145 Posts

    Quote Originally Posted by The_Durben View Post
    Another thing is compatibility issues with lockinfo will also be looked at but there's no promise they can be compatible.
    ...thanks for that info, i hope the LockInfo issue will be fixed out .

  21. The Following 3 Users Say Thank You to j0k3r For This Useful Post:

    Alfroggy (08-29-2013), King_O_Hill (08-30-2013), The_Durben (08-29-2013)

  22. #972
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in Philippines.
    Posts
    4,906
    Thanks
    7,514
    Thanked 19,006 Times in 3,871 Posts

    Quote Originally Posted by j0k3r View Post
    ...thanks for that info, i hope the LockInfo issue will be fixed out .
    LockInfo has always had issues with lock screen that utilize touch functions, I think it's LockInfo that needs fixed, not the other way around.

    "If it's not broken, I'll fix it till it is"

  23. The Following 5 Users Say Thank You to Ian Nicoll For This Useful Post:

    Hip5 (09-17-2013), King_O_Hill (08-30-2013), lostinthemes (08-31-2013), RKO1195 (08-30-2013), The_Durben (08-30-2013)

  24. #973
    iPhone? More like MyPhone
    Join Date
    Aug 2012
    Posts
    214
    Thanks
    154
    Thanked 155 Times in 76 Posts

    Hy,

    Could anyone tell me how to disable the wiper in Dacalīs mod, i donīt see the option in the config.js file.?

  25. #974
    Theme Modder
    Join Date
    Apr 2012
    Posts
    1,239
    Thanks
    1,920
    Thanked 5,279 Times in 1,027 Posts

    Quote Originally Posted by isostar View Post
    Hy,

    Could anyone tell me how to disable the wiper in Dacalīs mod, i donīt see the option in the config.js file.?
    I think you may very well be the only person to consider that, Lol....but have you tried to add a "display: none;" to #wiperContainer? in the Main CSS file? You want to keep the raindrops?

  26. The Following 4 Users Say Thank You to ferlop15 For This Useful Post:

    Ian Nicoll (08-30-2013), isostar (08-30-2013), King_O_Hill (08-30-2013), Marty McFly (08-30-2013)

  27. #975
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in Philippines.
    Posts
    4,906
    Thanks
    7,514
    Thanked 19,006 Times in 3,871 Posts

    Quote Originally Posted by isostar View Post
    Hy,

    Could anyone tell me how to disable the wiper in Dacalīs mod, i donīt see the option in the config.js file.?
    Adding display none will hide it but the code is still running, if it's for battery issues best follow this:

    I'm afraid you need to look at every .js file that has the wiper, those are from the folder Javascript/Weather/iph4 (or iph5 or both)

    hail.js
    rain.js
    showers_cloud.js
    sleet.js
    snow.js
    thunderstorm.js

    Look for this in each file:
    Code:
    // Wiper from Ian
    container3.appendChild(createAwiper());
    container3.appendChild(createAwiper_trace());
    container3.appendChild(createAwiper_water());


    Change it to this:
    Code:
    // Wiper from Ian
    if (ShowWiper == true) {
    container3.appendChild(createAwiper());
    container3.appendChild(createAwiper_trace());
    container3.appendChild(createAwiper_water());
    }


    Then in the Config.js file add this line:
    Code:
    var ShowWiper = false; // Set to false to disable the wiper in wet weather conditions.

    "If it's not broken, I'll fix it till it is"

  28. The Following 10 Users Say Thank You to Ian Nicoll For This Useful Post:

    Dacal (08-30-2013), ferlop15 (08-30-2013), Heine (08-30-2013), Hip5 (09-17-2013), King_O_Hill (08-30-2013), lostinthemes (08-31-2013), Marty McFly (08-30-2013), NewdestinyX (08-30-2013), RKO1195 (08-30-2013), The_Durben (08-30-2013)

  29. #976
    iPhone? More like MyPhone
    Join Date
    Aug 2012
    Posts
    214
    Thanks
    154
    Thanked 155 Times in 76 Posts

    Quote Originally Posted by ferlop15 View Post
    I think you may very well be the only person to consider that, Lol....but have you tried to add a "display: none;" to #wiperContainer? in the Main CSS file? You want to keep the raindrops?
    lol yes i could be the only one i think =), the display: none thing worked fine for me. I do want to keep the rain drops so all good now, thank you M8

    Quote Originally Posted by Ian Nicoll View Post
    Adding display none will hide it but the code is still running, if it's for battery issues best follow this:

    I'm afraid you need to look at every .js file that has the wiper, those are from the folder Javascript/Weather/iph4 (or iph5 or both)

    hail.js
    rain.js
    showers_cloud.js
    sleet.js
    snow.js
    thunderstorm.js

    Look for this in each file:
    Code:
    // Wiper from Ian
    container3.appendChild(createAwiper());
    container3.appendChild(createAwiper_trace());
    container3.appendChild(createAwiper_water());


    Change it to this:
    Code:
    // Wiper from Ian
    if (ShowWiper == true) {
    container3.appendChild(createAwiper());
    container3.appendChild(createAwiper_trace());
    container3.appendChild(createAwiper_water());
    }


    Then in the Config.js file add this line:
    Code:
    var ShowWiper = false; // Set to false to disable the wiper in wet weather conditions.
    wow, didnīt see your post Ian, thats nice, thanks you very much is much apreciated buddy.

  30. The Following 6 Users Say Thank You to isostar For This Useful Post:

    Dacal (08-30-2013), Ian Nicoll (08-30-2013), King_O_Hill (08-30-2013), lostinthemes (08-31-2013), Marty McFly (08-30-2013), The_Durben (08-30-2013)

  31. #977
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,611
    Thanks
    3,991
    Thanked 8,805 Times in 4,429 Posts

    I've actually been experiencing more lag with Main City name than normal today. Respring doesn't update it but toggling off then on of Location services.

    If it's any help to the dev team. The lag is ONLY for Main City. When you use any widget that's set to use the Extra Location Data - it has no lag at all. I find that interesting. The way I can tell is with the City/AltLoc iWidget I created that shows both main city and extraLocCity in the same widget. I can also verify from the XML update log which will show two refreshes - one when the Additional Loc data updates and then again when City does.
    Here to help if I can. If I can't I know someone who can!

  32. The Following User Says Thank You to NewdestinyX For This Useful Post:

    King_O_Hill (08-30-2013)

  33. #978
    The Mechanic The_Durben's Avatar
    Join Date
    Aug 2010
    Location
    Vancouver Canada
    Posts
    8,424
    Thanks
    34,944
    Thanked 40,561 Times in 7,513 Posts

    Quote Originally Posted by Ian Nicoll View Post
    LockInfo has always had issues with lock screen that utilize touch functions, I think it's LockInfo that needs fixed, not the other way around.
    That is definitely on lockinfo. The disabling of touch is a pain.
    There is a part of lockinfo that ties to weather though, that is causing issues as well.
    We will see if its possible on our end but if not, it likely won't get fixed.

    Personally don't see the need for this tweak at all since stock notifications are there. But to each their own

  34. The Following 7 Users Say Thank You to The_Durben For This Useful Post:

    Heine (08-30-2013), Hip5 (09-17-2013), Ian Nicoll (08-30-2013), King_O_Hill (08-30-2013), lostinthemes (08-31-2013), RKO1195 (08-30-2013), TEK_2012 (08-30-2013)

  35. #979
    My iPhone is a Part of Me bliken's Avatar
    Join Date
    Apr 2013
    Posts
    704
    Thanks
    686
    Thanked 414 Times in 278 Posts

    ok one question....the UV INDEX....WW doesn't have this?

    i don't see it and just wondering

  36. #980
    The Mechanic The_Durben's Avatar
    Join Date
    Aug 2010
    Location
    Vancouver Canada
    Posts
    8,424
    Thanks
    34,944
    Thanked 40,561 Times in 7,513 Posts

    Quote Originally Posted by bliken View Post
    ok one question....the UV INDEX....WW doesn't have this?

    i don't see it and just wondering
    No it doesn't

  37. The Following 3 Users Say Thank You to The_Durben For This Useful Post:

    bliken (08-30-2013), King_O_Hill (08-30-2013), TEK_2012 (08-30-2013)

LinkBacks (?)

  1. 08-08-2013, 04:14 PM

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts