+ Reply
Page 37 of 209 FirstFirst ... 273536373839 47 87 137 ... LastLast
Results 721 to 740 of 4176

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Widget Weather

is a discussion within the

File Mods

forums, a part of the

iPhone Modding

section;
I've seen detail 3 and 7 Ian but not in last two versions it means something lol thanks
...
  1. #721
    widget modder RKO1195's Avatar
    Join Date
    Aug 2010
    Location
    Alabama
    Posts
    2,328
    Thanks
    10,680
    Thanked 5,378 Times in 1,811 Posts

    I've seen detail 3 and 7 Ian but not in last two versions it means something lol thanks

  2. The Following 4 Users Say Thank You to RKO1195 For This Useful Post:

    Heine (08-23-2013), Ian Nicoll (08-22-2013), Simon (08-22-2013), The_Durben (08-23-2013)

  3. #722
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,900
    Thanks
    4,227
    Thanked 9,034 Times in 4,536 Posts

    Quote Originally Posted by Ian Nicoll View Post
    Hi Grant,

    This is the hardest things to fix as all seems good on Druben's phone, I also have this weird things often when I work with Dacal on the UniAW, things that don't work for me work for him LOL.. and so it's difficult to pinpoint the issue when it's not their.
    Part of the problem with Dacal & I was I had poor internet connection and Dacal's was stable, so I was seeing issues he didn't.

    If Derrick & Brian have internet on all the time I believe they may never see this issue as it does seem only to be an issue with those of us who disconnect periodically.

    It's not a major thing and if it really is an issue then it will happen to Derrick/Brian sooner or later, then they will get a chance to troubleshoot.

    Maybe Derrick, Brian or Dacal would be willing to turn off their internet or go on Airplane mode or whatever for a few hours and test what happens when they switch back on, thing is I don't know how long we have to be disconnected before we see some issue, all night does it for me.
    Yes. I understand. But I have excellent signal all day. Like Brian, I have amazing LTE and rarely use WIFI. But I do notice noticeable battery drain when I keep Location services on all day as opposed to when I'm only outdoors in my car. I use a Mophie case for extra battery for UniAW mainly.. But still - a part of me feels like I should turn off LOC services when not using. And it's so easy to toggle with BatterDoctorPro. I will say that my entire testing period from Philly to Harrisburg was with Loc Services on, obviously - BUT - prior to getting on the road - Loc Services had been off.

    I'm going to try tomorrow - with Loc Services on ALL DAY. And see if that makes any difference.
    Here to help if I can. If I can't I know someone who can!

  4. The Following User Says Thank You to NewdestinyX For This Useful Post:

    Alfroggy (08-23-2013)

  5. #723
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,503
    Thanks
    6,796
    Thanked 15,203 Times in 6,978 Posts

    I definitely see better weather displaying using WW than mylocation. Don't always pay close attention to how often it updates but just the difference in how these two work I would think means that even in bad Internet areas the widgets always have readings to pull from. That is why my WW widgets never display nothing like mylocation widgets randomly do. It's kinda like having Dacals cookie built right into the tweak lol. I don't know about everybody but I would rather have slightly dated weather in bad Internet areas than no weather being displayed or demo modes.

  6. The Following 3 Users Say Thank You to Simon For This Useful Post:

    King_O_Hill (08-22-2013), RKO1195 (08-22-2013), The_Durben (08-23-2013)

  7. #724
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in the Philippines.
    Posts
    4,957
    Thanks
    7,613
    Thanked 19,244 Times in 3,922 Posts

    Agree with you Simon, it's very similar to Dacal's cookie but without all the cookie code for me to break but now I think we need to change the "Last Update" in our widgets to instead show the last update of the .xml file instead of the last time our widget looked at the .xml file, (I'm talking about the UniAW BTW), I would say you can have both update times but in the case of the UniAW there is simply no more room!

    "If it's not broken, I'll fix it till it is"

  8. The Following 4 Users Say Thank You to Ian Nicoll For This Useful Post:

    King_O_Hill (08-23-2013), RKO1195 (08-22-2013), Simon (08-22-2013), The_Durben (08-23-2013)

  9. #725
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,503
    Thanks
    6,796
    Thanked 15,203 Times in 6,978 Posts

    Quote Originally Posted by Ian Nicoll View Post
    Agree with you Simon, it's very similar to Dacal's cookie but without all the cookie code for me to break but now I think we need to change the "Last Update" in our widgets to instead show the last update of the .xml file instead of the last time our widget looked at the .xml file, (I'm talking about the UniAW BTW), I would say you can have both update times but in the case of the UniAW there is simply no more room!
    Lol, yup, no more cookie breaking for you
    Most of the new widgets coming from the beta group have the XML file as last update. I think I saw one of these guys had one with both updates but agree, the XML one is probably the more important one when using this tweak.

  10. The Following 3 Users Say Thank You to Simon For This Useful Post:

    Alfroggy (08-23-2013), Ian Nicoll (08-23-2013), King_O_Hill (08-23-2013)

  11. #726
    widget modder RKO1195's Avatar
    Join Date
    Aug 2010
    Location
    Alabama
    Posts
    2,328
    Thanks
    10,680
    Thanked 5,378 Times in 1,811 Posts

    It's easy Ian just use xmlupdate and take lastupdate out. And I run location 24/7 and don't see any difference in battery drain, I've alway left it on!

  12. The Following 3 Users Say Thank You to RKO1195 For This Useful Post:

    Ian Nicoll (08-23-2013), King_O_Hill (08-23-2013), The_Durben (08-23-2013)

  13. #727
    The Mechanic The_Durben's Avatar
    Join Date
    Aug 2010
    Location
    Vancouver Canada
    Posts
    8,424
    Thanks
    34,944
    Thanked 40,561 Times in 7,513 Posts

    My iOS 7 lock shows the last update of the XML
    Not the last time the widget checked it. There is no doubt the widget is checking the file so no need for it.
    Good night y'all

  14. The Following 6 Users Say Thank You to The_Durben For This Useful Post:

    Alfroggy (08-23-2013), Heine (08-23-2013), Ian Nicoll (08-23-2013), King_O_Hill (08-23-2013), RKO1195 (08-22-2013), TEK_2012 (08-23-2013)

  15. #728
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in the Philippines.
    Posts
    4,957
    Thanks
    7,613
    Thanked 19,244 Times in 3,922 Posts

    Quote Originally Posted by The_Durben View Post
    My iOS 7 lock shows the last update of the XML
    Not the last time the widget checked it. There is no doubt the widget is checking the file so no need for it.
    Good night y'all
    Agreed, but in these early stages I will have both in the UniAW version (yet another choice LOL..)

    EDIT: Now I have it working as a fader similar to the moonrise text in the accu version, it fades from "XML checked at:" to "XML updated at:"
    I also removed the seconds from the xmlupdate with my method below.
    Looks pretty cool.

    Not sure if this will be of much use to any of you, but if you want to get rid of the seconds in the xml update time you can do this, but it also removes the AM/PM so maybe not for all of you.

    In the .js file look for this line:
    Code:
    document.getElementById("xmlupdate").innerHTML = xmlupdatetext + obj.updatetimestring.slice(11);
    CHANGE IT TO THIS:
    Code:
    document.getElementById("xmlupdate").innerHTML = xmlupdatetext + obj.updatetimestring.slice(11, 16);
    Last edited by Ian Nicoll; 08-23-2013 at 02:57 AM.

    "If it's not broken, I'll fix it till it is"

  16. The Following 4 Users Say Thank You to Ian Nicoll For This Useful Post:

    Dacal (08-23-2013), King_O_Hill (08-23-2013), RKO1195 (08-23-2013), The_Durben (08-23-2013)

  17. #729
    Addicted to Code Dacal's Avatar
    Join Date
    Nov 2010
    Posts
    1,891
    Thanks
    2,903
    Thanked 8,488 Times in 1,500 Posts

    Quote Originally Posted by Simon View Post
    Lol, yup, no more cookie breaking for you
    Most of the new widgets coming from the beta group have the XML file as last update. I think I saw one of these guys had one with both updates but agree, the XML one is probably the more important one when using this tweak.
    Lol ! Now we have an XML file generated, no need to have a cookie, i think Ian is happy .

    BTW, concerning the update, now we have the update interval in the XML, i can add a display for a sort of "Offline" mode, in case the XML has not been updated and the interval time is reached. Maybe usefull for debugging.

    I will look today.


    My themes : Jade HD, Silex HD, BaSalt HD,ToPaz
    All are on Cydia and/or Theme It.

  18. The Following 7 Users Say Thank You to Dacal For This Useful Post:

    Heine (08-23-2013), Ian Nicoll (08-23-2013), King_O_Hill (08-23-2013), RKO1195 (08-23-2013), Simon (08-23-2013), TEK_2012 (08-23-2013), The_Durben (08-23-2013)

  19. #730
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in the Philippines.
    Posts
    4,957
    Thanks
    7,613
    Thanked 19,244 Times in 3,922 Posts

    Here is what I did for debugging, I added the xmlupdate and a fader between the two, they say a picture is worth a thousand words LOL...
    This time I had constant internet but I switched off logging this morning so don't have the log for this but it's clear there is some small issue.

    EDIT: Now 19:28 here and still no update since 17:24. So I re-spring, still no update, so I re-boot, still no update!! I think I broke it LOL...

    If any of you want to use this for testing, here is the link to the complete lock screen:

    http://www.mediafire.com/download/7v...iAW6_LSWW3.zip

    Attached Thumbnails Attached Thumbnails Widget Weather-1.png  
    Last edited by Ian Nicoll; 08-23-2013 at 05:34 AM.

    "If it's not broken, I'll fix it till it is"

  20. The Following 5 Users Say Thank You to Ian Nicoll For This Useful Post:

    Alfroggy (08-23-2013), King_O_Hill (08-23-2013), RKO1195 (08-23-2013), TeddyDiesel (08-23-2013), The_Durben (08-23-2013)

  21. #731
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,900
    Thanks
    4,227
    Thanked 9,034 Times in 4,536 Posts

    Quote Originally Posted by RKO1195 View Post
    It's easy Ian just use xmlupdate and take lastupdate out. And I run location 24/7 and don't see any difference in battery drain, I've alway left it on!
    Do you mean SigChange On in myLocation? Or Constant in WW? Which one did you find gives no battery drain?

    Quote Originally Posted by Ian Nicoll View Post
    This time I had constant internet but I switched off logging this morning so don't have the log for this but it's clear there is some small issue.

    EDIT: Now 19:28 here and still no update since 17:24. So I re-spring, still no update, so I re-boot, still no update!! I think I broke it LOL...

    If any of you want to use this for testing, here is the link to the complete lock screen:
    Yes.. I have the same experience with intermittency of updating while in Constant mode. And no respring or reboot gets me the right ( updated) city. Only switching to manual mode and opening NC gets it working again.

    When it's working completely as designed - its a crazy awesome updating machine! Still so glad Derrick & Brian thought of this method of getting weather data.. And agreed.... takes away all need for a cookie.. Stephen will get this little update bug worked out. I'm not worried. Still unclear what we can provide the team from our phones to prove/show what we're experiencing.. And if this is not an "every phone problem" it's gonna get tricky tracking down the problem.

    Quote Originally Posted by Dacal View Post
    .,I can add a display for a sort of "Offline" mode, in case the XML has not been updated and the interval time is reached. Maybe usefull for debugging.
    That would be great, Dacal!!
    Last edited by NewdestinyX; 08-23-2013 at 05:46 AM.
    Here to help if I can. If I can't I know someone who can!

  22. The Following User Says Thank You to NewdestinyX For This Useful Post:

    Ian Nicoll (08-23-2013)

  23. #732
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in the Philippines.
    Posts
    4,957
    Thanks
    7,613
    Thanked 19,244 Times in 3,922 Posts

    Hey Grant, you just saved me M8, I was completely stumped, it would not update the xml file using constant, I re-spring, reboot, removed the xml file, reinstalled the tweak... nothing, now it wouldn't create a new xml file while in constant mode.

    So I just see your post and try manual, thank god, all back to normal now. so thanks for that M8.

    Conclusion: Constant has issues, tomorrow I try semi.

    Thanks to all again for this fab tweak, lovin it.

    "If it's not broken, I'll fix it till it is"

  24. The Following 9 Users Say Thank You to Ian Nicoll For This Useful Post:

    Alfroggy (08-23-2013), Dacal (08-23-2013), King_O_Hill (08-23-2013), lostinthemes (08-23-2013), mentop (08-23-2013), NewdestinyX (08-23-2013), RKO1195 (08-23-2013), The.Drifter (08-23-2013), The_Durben (08-23-2013)

  25. #733
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,900
    Thanks
    4,227
    Thanked 9,034 Times in 4,536 Posts

    Quote Originally Posted by King_O_Hill View Post
    Thanks for fielding all these questions D!

    Grant,

    Let me see if I can help you to understand this.

    Comparing the MyLocation app to this tweak is like saying that you orange juice doesn't have enough apple taste in it. Now before you start disagreeing with me hear me out.


    <big snip>
    So your point doesn't really help us. We are telling you what we need, but you are insistent on telling us what we need. This is the reason that you weren't included in the beta. Simple answer is your unwilling to do what is asked.

    Sorry bud. We have been living this for weeks and want to get it working for most. All would be great, but it is a rather in depth tweak and we are not expecting miracles when running it on a hacked OS!

    Thanks for your help.
    You came a little late to the party on this one King. As I told D I will give you what you ask. But I disagree with why you say myLoc comparison for loc change interval is useless. We'll just have to agree to disagree. You're just not understanding why it's a useful comparison base. That's okay. I will do what you ask.. I can't explain it any better than I already have and people are getting personally offended that I don't want to offend. My only goal is to provide the best info I can (from more than 20 years beta testing experience with Apple, MOTU, Avid, Samsung about the functionality of a tweak). That is what I consistently try to do.. If that's not welcome I can stop.

    More.. in.. The Great Debate...,

    Don't want to pull this off topic again.

    Quote Originally Posted by Ian Nicoll View Post
    Hey Grant, you just saved me M8, I was completely stumped, it would not update the xml file using constant, I re-spring, reboot, removed the xml file, reinstalled the tweak... nothing, now it wouldn't create a new xml file while in constant mode.

    So I just see your post and try manual, thank god, all back to normal now. so thanks for that M8.

    Conclusion: Constant has issues, tomorrow I try semi.

    Thanks to all again for this fab tweak, lovin it.
    My pleasure, Ian. Glad to be seen as "helpful".. by someone..

    Yeah.. I stumbled on it by accident - wondered if it might just be a "mode" based thing. Using Manual consistently gets it functioning for me again. On several tests I can reproduce this on two different phones. I wonder how many others are also testing on multiple phones with different tweak sets to rule out individual phone issues..
    Last edited by NewdestinyX; 08-23-2013 at 07:13 AM.
    Here to help if I can. If I can't I know someone who can!

  26. #734
    widget modder RKO1195's Avatar
    Join Date
    Aug 2010
    Location
    Alabama
    Posts
    2,328
    Thanks
    10,680
    Thanked 5,378 Times in 1,811 Posts

    Grant I mean in WW and on sig change in the MyLocation I always leave location on...

    And Ian if it want make your xml file ever put in Semi and open weather app and it should then, this is how we had to do it but in the last few versions he's got it to make it in constant.

  27. The Following 4 Users Say Thank You to RKO1195 For This Useful Post:

    Alfroggy (08-23-2013), Ian Nicoll (08-23-2013), King_O_Hill (08-23-2013), The_Durben (08-23-2013)

  28. #735
    My iPhone is a Part of Me
    Join Date
    Feb 2008
    Posts
    730
    Thanks
    452
    Thanked 243 Times in 172 Posts

    Quote Originally Posted by mentop View Post
    I have never used LockInfo, but I'm constantly having the same issue.

    I have tried 5,10 and 15 min. update intervals, but unfortunately it updates whenever it wants (always after 25 minutes MINIMUM...).

    The log file keeps saying "not updating because time limit". It's a shame that's not working for me, I was pretty excited about this tweak

    Any ideas from the experts??

    @Ian,

    I used "SEMI" all the time, and with semi i have the issues described above.

  29. The Following 4 Users Say Thank You to j0k3r For This Useful Post:

    Ian Nicoll (08-23-2013), King_O_Hill (08-23-2013), NewdestinyX (08-23-2013), The_Durben (08-23-2013)

  30. #736
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in the Philippines.
    Posts
    4,957
    Thanks
    7,613
    Thanked 19,244 Times in 3,922 Posts

    Quote Originally Posted by j0k3r View Post
    @Ian,

    I used "SEMI" all the time, and with semi i have the issues described above.
    Don't worry pal, I'm sure the guys will get it sorted.

    Thanks for the info.

    "If it's not broken, I'll fix it till it is"

  31. The Following 5 Users Say Thank You to Ian Nicoll For This Useful Post:

    Alfroggy (08-23-2013), j0k3r (08-23-2013), King_O_Hill (08-23-2013), NewdestinyX (08-23-2013), The_Durben (08-23-2013)

  32. #737
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,900
    Thanks
    4,227
    Thanked 9,034 Times in 4,536 Posts

    Quote Originally Posted by RKO1195 View Post
    Grant I mean in WW and on sig change in the MyLocation I always leave location on...

    And Ian if it want make your xml file ever put in Semi and open weather app and it should then, this is how we had to do it but in the last few versions he's got it to make it in constant.
    Yes. It just seems like there's something in Constant Mode that's a little broken. It doesn't consistently auto-update as designed. And the non-update period seems early in its use after the antenna first turns off (after Location Services have been off, etc).
    Here to help if I can. If I can't I know someone who can!

  33. #738
    widget modder RKO1195's Avatar
    Join Date
    Aug 2010
    Location
    Alabama
    Posts
    2,328
    Thanks
    10,680
    Thanked 5,378 Times in 1,811 Posts

    Mine updates great on Constant but I leave location on always though

  34. The Following 2 Users Say Thank You to RKO1195 For This Useful Post:

    Alfroggy (08-23-2013), King_O_Hill (08-23-2013)

  35. #739
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in the Philippines.
    Posts
    4,957
    Thanks
    7,613
    Thanked 19,244 Times in 3,922 Posts

    @ Dacal,

    Hi bud,

    Is it possible to make obj.updatetimestring into a string and separate all the info it gives so we can loose the seconds but keep the AM/PM?
    Or some other way?

    Thanks David.

    @ RKO1195,

    I never switch off the location services, everything on my phone is always on and I get the issues, funny how it's ok for some and not for others, these issues are a pain to pinpoint especially if it's all working for Stephen.
    Last edited by Ian Nicoll; 08-23-2013 at 07:43 AM.

    "If it's not broken, I'll fix it till it is"

  36. The Following 3 Users Say Thank You to Ian Nicoll For This Useful Post:

    King_O_Hill (08-23-2013), RKO1195 (08-23-2013), The_Durben (08-23-2013)

  37. #740
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    9,349
    Thanks
    41,426
    Thanked 17,520 Times in 6,401 Posts

    Ian, you said that you use airplane mode, correct? This will turn off the radio in essence disabling loc srvs.
    Widget-Weather App Now Available! Also with MyLocation Support!
    Check out the thread here - Widget-Weather
    To install the Widget-Weather app, just go to Cydia and install. This will also remove MyLocation, as it is built in!
    Want to protect your JailBreak! Add this repo http://cydia.myrepospace.com/iLEXiNFO/ & Install "iLEX R.A.T."
    It will allow you to bring your phone back to a fresh jailbroken state!

  38. The Following 5 Users Say Thank You to King_O_Hill For This Useful Post:

    Alfroggy (08-23-2013), Heine (08-23-2013), Ian Nicoll (08-23-2013), RKO1195 (08-23-2013), The_Durben (08-23-2013)

LinkBacks (?)

  1. 08-08-2013, 04:14 PM

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts