Whenever I try to use the command "apt-get autoremove" in MT, it tells me something about "Whoops, AutoRemove broke something. Apt depends on apt7, which is not going to be installed."

I tried reinstalling all the apt packages in Cydia, but I get an error message for that, too. Everything works fine on my iPod, I just want to use AutoRemove to clean up crap left over from iCleaner (oh, the irony).