Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [GUIDE] How to get Free Unlimited Native SMS with only a Data Plan or WiFi

  1. #1
    Post [GUIDE] How to get Free Unlimited Native SMS with only a Data Plan or WiFi
    This is a tutorial showing how to set up unlimited free texting through the native iPhone messaging app without having to pay for a monthly SMS plan, or using those cheap 3rd party 'free' texting applications. The only thing it costs is $3 for the program that enables this to happen (There is a 4 day free trial as well).

    Here is a video demo showing the tweak in use. The iPhone is set in airplane mode to show that it is sending the messages over the web and not the phones GSM network.

    [ame=http://www.youtube.com/watch?v=i4PcwcewIck]YouTube - SMS GV Extension demo video #01[/ame]

    NOTE: You must have a jailbroken iPhone for this to work.

    Step 1
    You must set up a Google Voice acount. go to http://www.google.com/voice to set one up. You will then be prompted to choose a phone number during setup. This number will forward phone calls to your iPhone # as well as SMS to an email account. First you must setup Google Voice to forward to an email account. To do this go to Settings>Voice Settings then click the Voicemail & Text tab. Under text forwarding check to have the SMS messages forwarded to your Gmail account. Save your changes and now click the Gmail tab at the top of the screen. Once you are under Gmail click on Settings and then the Filters tab. Create a new filter and in the From box enter this: @txt.voice.google.com. Then click Next Step and check mark as read then save changes.

    Step 2
    Now you must set up your Gmail account on the iPhone. On the iPhone go to the Settings.app>Mail, Contacts, Calendars> Add Account. Then select Microsoft Exchange. In the Email box enter your full Gmail account address (ex. [email protected]). Leave Domain blank, and in the Username box again enter your full Gmail account address, then enter your Password in the Password box. Select Next and a box should appear called Server. In this box enter the following: m.google.com and select done. One more step to go.

    Step 3
    Now launch Cydia and search for this: SMS GV Extension; install the application and restart springboard.

    NOTE: If you plan on using this on 3G, then make sure WiFi is turned off when you install the SMS GV Extension program.

    Now go to Settings.app>SMS GV Extension. Enter just your Gmail username in the Username field and the password in the Password field. Then select Monitored Accounts and under that select Specify Below. In the Or Specify field enter your full Gmail email address. That's it! You're finished. If anyone needs help or has any questions feel free to email me at [email protected] , or post below. Thanks all.

  2. #2
    Nice guide. Thanks

  3. #3
    Does mail need to be running to receive messages? If I didn't check for messages in my inbox they wouldn't show up in my texts.. Did I do something wrong?
    iPhone 3G 4.2.1 - iPod touch 3G 5.0 Beta 1
    Windows 7 - OS X 10.5.6

  4. #4
    Quote Originally Posted by xXrkidXx View Post
    Does mail need to be running to receive messages? If I didn't check for messages in my inbox they wouldn't show up in my texts.. Did I do something wrong?
    Like the phone app, the mail app is always running. No, you don't have to check your mail for the messages to show up in your texts. Try rebooting and then go to SMS GV Extension under settings and check for license. See if that helps.

  5. #5
    No, the mail app is not always running. I end the process because it is a ram whore. It doesn't start up for awhile after that however. I have tried rebooting, and I have contacted the developer.
    iPhone 3G 4.2.1 - iPod touch 3G 5.0 Beta 1
    Windows 7 - OS X 10.5.6

  6. #6
    Quote Originally Posted by xXrkidXx View Post
    No, the mail app is not always running. I end the process because it is a ram whore. It doesn't start up for awhile after that however. I have tried rebooting, and I have contacted the developer.
    It would be always running if you hadn't ended it...

  7. #7
    I followed this guide to the letter and when I receive texts they don't come from the number I sent them to, but from some other random number. I can't figure out how to get them to receive from the same number I send them to, so that the SMS feature works exactly like with my carrier SMS plan. It looks like it works in the video so I've obviously done something wrong. Please help?

  8. #8
    I just realized it was because 1, I didn't have a push supported e-mail working and 2, yea because I always ended the mail process.. Thanks for the help
    iPhone 3G 4.2.1 - iPod touch 3G 5.0 Beta 1
    Windows 7 - OS X 10.5.6

  9. #9
    Default Can receive but can't send
    I already had a Google Voice and Gmail accounts with filters. I am able to receive texts through SMS GV Extension with no trouble. (I'm sending it through email with a filter.) However, I have been unable to SEND texts. I thought this was strange, since most posts I found were about people having trouble receiving texts. That works great for me. The thing that stuck out in your post was the line about Wifi vs 3G. I did install the app while on wifi and am trying to send text via 3G.

    I tried rebooting, respringing, reinstalling, uninstalling, installing, etc. I keep having the same problem. When I try to send a text through GV, the SMS starts to send, the progress bar goes about a third of the way, then fails. If I turn off sending in the settings, I am able to text through the carrier, but this defeats the purpose.

    Do you have any suggestions or solutions? I've tweeted the developer but haven't heard anything back yet.

    I do have a licensed copy.

    Thanks!

  10. #10
    What I found works is install the Google Voice app then in the settings for the GV SMS Extension turn on "Official GV app" in Receive Settings and make sure "Local Mail" is turned off. Then make sure Push Notifications are on for the Google Voice app. I have had no problems with it since.

  11. #11
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,097
    Thanks
    333
    Thanked 603 Times in 506 Posts

    I might have to try this.

  12. #12
    @iamjamieq - There are 3 different settings you can change in the Receive Settings: Official GV app, Local Mail, and Refresh Cash. Additionally, in the Official GV App, you can turn text forwarding on or off in the app. I tried every combination of those 4 toggles and under none of the circumstances was I able to send. Though I don't understand why changing the Receive Settings would affect my ability to Send, since the app states clearly that you can send under the trial version but have to have the paid version to receive. Those are clearly separate functions. But, if it was working for you, I thought I'd try it. I've tried everything I can think of except one thing.

    My next step will be to roll my phone back and install again that way. Uninstalling and reinstalling isn't working. There seem to be a lot of people using this app that aren't having the problem that I'm having. And the developer has responded to several people on Twitter and has completely ignored my 4 messages.

    And yes, I HAVE made sure my username and password are correct. I even went as far as copy/pasting the username and password from the official GV app to make sure there were no mistakes. I even tried using @gmail.com to see if that helped. Nothing. The only way I can send is through AT&T and that defeats the purpose of buying this app to begin with.

    Isn't there ANYBODY out there who has had a problem sending using this extension that has fixed the problem?

  13. #13
    Sorry I totally misread your post to see issues with receiving. If you're having trouble sending I don't know how to help. After all, the only setting for sending is "Enable Send" either on or off. I don't even use this setting, and instead use the SBSettings toggle whenever I need to send a text via GV. I don't know if installing while on Wifi vs 3G makes a real difference, as I don't remember what I did, but it is worth uninstalling and trying to install while on 3G.

  14. #14
    No prob! Thanks for trying to help. I'll post if I'm able to solve the problem with a rollback and reinstall.

  15. #15
    Default Can finally send, with no help from the developer
    I completely restored my phone, turned off Wifi and installed SMS GV Extension on 3G. It still didn't work. Then the problem finally occurred to me. I was walking in my mind through the only things that can be changed. There's a username, a password, and a toggle switch. Those are the ONLY things that affect the sending process.

    After 20+ hours of my time and absolutely no response from the developer over about 3 days (though he responded to several other people in that time about licenses), I figured out the problem.

    I had a symbol in my password. You can't have a symbol in your password. It's that simple. We had a similar problem with someone at work trying to access some internal software. Fortunately, that's what made me think of it. Silly ampersand.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •