+ Reply
Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPod music stops playing when apps are loaded

is a discussion within the

File Mods

forums, a part of the

iPhone Modding

section;
Hi guys, this is my first post on the forums so don't murder me. As the title says, on certain apps the iPod stops playing and the apps default music
...
  1. #1
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iPod music stops playing when apps are loaded
    Hi guys, this is my first post on the forums so don't murder me.

    As the title says, on certain apps the iPod stops playing and the apps default music kicks in, one app that comes to mind at the moment is Osmos, my new favourite. Unfortunately I cannot listen to my favourite bands while playing my favourite app so it kind of sullies the experience. So, to sum it up, I am pretty much asking people if they have any solution. I would prefer not to get into the heavy programming side of things as the most I have done is basic edits.

    I did do a search previously and came up with nothing so my apologies if I am asking a well known question, I know its a bit annoying as I am a regular goer on other forums.

    Thanks a heap in advance

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,368
    Thanks
    6,736
    Thanked 15,090 Times in 6,938 Posts

    See if there is an option in Osmos for turning their music off and enabling ipod music. Some apps have this feature. If there isn't then I don't think there is any way around this unfortunately.

  3. #3
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unfortunately there is no option to turn the default music off and the iPod music on.

    No-one else?

  4. #4
    iPhone? More like MyPhone
    Join Date
    Jan 2010
    Posts
    297
    Thanks
    2
    Thanked 19 Times in 14 Posts

    Either we're using different version of the app, or you haven't looked at the options screen, because there definitely IS a volume control for the default music, which you can just turn all the way down.

    But anyway, turning the music off is only half-solving the issue. To actually get your iPod playlist to resume, there's one more step; if you're on iOS 4.0.x, double-tap home and swipe right on the multitasking bar to bring up the music controls, and simply tap play; if you're on iOS 3.x, you'll need to go into Activator settings and set the "double-tap home" in-app event to "iPod controls", then restart Osmos, double-tap home, and tap play.

  5. #5
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,368
    Thanks
    6,736
    Thanked 15,090 Times in 6,938 Posts

    That method doesn't work on 4.0, while in osmos you cannot press play again and when multitasking back and forward the music stops playing right away when osmos is selected. I cant say whether your 3.1.3 method will as I haven't tried that. Maybe if backgrounder was installed the music would keep playing then but not sure.

  6. #6
    iPhone? More like MyPhone
    Join Date
    Jan 2010
    Posts
    297
    Thanks
    2
    Thanked 19 Times in 14 Posts

    Try this hack: go into Activator settings and set the in-app "short hold home" gesture to "iPod controls". That SHOULD allow you to bring up your iPod controls from any application by holding the home button, much as you would to activate backgrounder in previous iOS versions.

    If not, try the old workaround from iOS 2.x - start Osmos, press the sleep button, then double-tap home to bring up the lockscreen music controls. Press play then unlock your phone, you should be returned to the app at the same place you were, only with the music now playing in the background. It's doubtful this still works, but I haven't tested it so there's a slim chance it could.

  7. #7
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cypherpunk, on the first count, which was doing the double tap on home (The play button is greyed out) and turning down the volume, you were in a way wrong - that wasn't what I was asking for but the second post by you helped. Funnily enough, for some reason Osmos started playing my music but there was also another one of my favourites that didn't - Robot Unicorn Attack. I have now made it that a short hold of the home button pause/plays music and that seems to have solved the problem.
    Thanks all of you guys for the help

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts