+ Reply
Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Serious MobileSubstrate Error

is a discussion within the

File Mods

forums, a part of the

iPhone Modding

section;
ugh... life has been good on 3.1.3 ever since the PwnageTool became available, and I've been relying on Five Icon Dock to put the five apps i use most in
...
  1. #1
    What's Jailbreak?
    Join Date
    May 2010
    Location
    Missouri, USA
    Posts
    10
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Exclamation Serious MobileSubstrate Error
    ugh... life has been good on 3.1.3 ever since the PwnageTool became available, and I've been relying on Five Icon Dock to put the five apps i use most in my dock. A few days ago I realized that whenever I respring (and sometimes when I just turn it on) the SpringBoard crashes when I launch any 3rd party (appstore) app.

    After crashing multiple times in a row, the Possible Conflict box pops up at my lockscreen (this is a feature that Rock gives you) and it always says the same problem with MobileSafety.dylib

    [/Library/MobileSubstrate/MobileSafety.dylib] calling __ZZL27$SBButtonBar$maxIconColumnsP11SBButtonBarP1 3objc_selector

    I sadly uninstalled Five Icon Dock since i thought having five icons instead of four might cause the SBButtonBar portion of the error, but I was wrong. This error keeps happening whenever Cydia or Rock resprings, or when I do it myself. All 3rd party apps then crash until i reboot manually, but then artifacts in my statusbar appear until I reboot again.

    If anyone experiences this as well, or if anyone has any idea how to disable MobileSafety.dylib or how to otherwise fix this issue, please reply ASAP! Thanks for your time guys

  2. #2
    Green Apple black_orchid's Avatar
    Join Date
    Aug 2009
    Location
    Wetumka, Oklahoma, United States
    Posts
    55
    Thanks
    38
    Thanked 2 Times in 2 Posts

    I have a very similar prob;em. I JB with Spirit same device as yours, I jailbroke & then 2 days later my phone started acting nuts. The springboard would not load apps fully, only about 2 seconds then it would stop. Kind of like a "splash" lol Then then sleep button will take random screen shots. My Springboard would lock up and Resping. I get a similar error message. I uninstalled Mobile Substrate & my phone was "normal" acting. WTF
    LIVE FOR TODAY,
    BECAUSE TOMORROW
    IS NEVER PROMISED"

  3. #3
    What's Jailbreak?
    Join Date
    May 2010
    Location
    Missouri, USA
    Posts
    10
    Thanks
    1
    Thanked 2 Times in 2 Posts

    I have fixed this issue! What I did was look for any MobileSubstrate extensions that may have caused the crash. I uninstalled FiveIconDock but nothing was fixed, so I looked for any installed applications from Cydia that may have caused the problem. I eventually found that an application called Orbit was causing the crashes. Also, any "cracked" apps from Cydia can cause this issue (I don't have any myself, but I know that they can from a friend who writes code for the iPhone).

    black orchid, do you have Orbit installed? If you don't, do you have Activator installed? The second cause for the problem turned out to be a conflict I had with Activator, but lets start with Orbit.

  4. The Following User Says Thank You to Mindwaave For This Useful Post:

    black_orchid (05-24-2010)

  5. #4
    Green Apple black_orchid's Avatar
    Join Date
    Aug 2009
    Location
    Wetumka, Oklahoma, United States
    Posts
    55
    Thanks
    38
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by Mindwaave View Post
    I have fixed this issue! What I did was look for any MobileSubstrate extensions that may have caused the crash. I uninstalled FiveIconDock but nothing was fixed, so I looked for any installed applications from Cydia that may have caused the problem. I eventually found that an application called Orbit was causing the crashes. Also, any "cracked" apps from Cydia can cause this issue (I don't have any myself, but I know that they can from a friend who writes code for the iPhone).

    black orchid, do you have Orbit installed? If you don't, do you have Activator installed? The second cause for the problem turned out to be a conflict I had with Activator, but lets start with Orbit.
    I don't have Orbit installed, but I do have Activator. I have been exploring possible conflicts with it. I feel deep down that that is the root of my problems. If I uninstall it, I get rid of my prob;ems, but It also uninstalls needed pkgs. Like backgrounder, ect. Any help would be awesome. Thank you for your reply.
    LIVE FOR TODAY,
    BECAUSE TOMORROW
    IS NEVER PROMISED"

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts