Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: This missing "Cellular Data Network" tab and APN settings...

  1. #1
    Default This missing "Cellular Data Network" tab and APN settings...
    I've been googling and searching and youtubing all evening without much luck. I have an iPhone 3g with 3.1 firmware and the 5.11.07 baseband. Under Settings > General > Network , I don't have the Cellular Data Network tab and can therefore not change APN settings.

    I've tried editing the plist file with the line to allow EDGE editing, but it didn't work. I've also seen posted in multiple places that the old APN Editor from Cydia no longer works (it crashed while downloading). So, is there a way for me to make this tab appear? I have a jailbroken phone on AT&T. Thanks all!

  2. #2
    iPhoneaholic REAPERDAGREAT13's Avatar
    Join Date
    Nov 2008
    Location
    N.E.L.A.S & Barcelona
    Posts
    343
    Thanks
    2
    Thanked 75 Times in 49 Posts

    U have to download a carrier settings
    5.0, 5.1 or 5.2 to have it appear
    If My Replys Helped You Out In Any Way
    Dont Forget To Hit The "THANKS" Button

  3. #3
    I downloaded the latest carrier settings, that now allows MMS...

  4. #4
    did it appear after the carrier settings?
    White 3GS 16GB 3.1.2 Unlocked Currently using
    Black 3G 8GB Backup phone
    White BNIB 3GS 32GB "dust collector"

  5. #5
    Nope. I ended up installing the stealth 6.0 IPCC and it appeared. I still, however, don't have the visual voicemail tab. Oigh...

  6. #6
    hmmmm i guess another option is to install apn editing via cydia.
    White 3GS 16GB 3.1.2 Unlocked Currently using
    Black 3G 8GB Backup phone
    White BNIB 3GS 32GB "dust collector"

  7. The Following User Says Thank You to 08lexus250 For This Useful Post:

    hank197857 (06-13-2010)

  8. #7
    Not on the 3.1 firmware. APN Editing hasn't worked since 2.x.

  9. #8
    6.0 ipcc let you edit APN settings.

    I am using that right now.

  10. #9
    interesting so apn editing doesn't work with 3.XX. Where can I get 6.0 ipcc?
    White 3GS 16GB 3.1.2 Unlocked Currently using
    Black 3G 8GB Backup phone
    White BNIB 3GS 32GB "dust collector"

  11. #10
    I have the same issue. 3g 16g jailbroke with 3.1.2. Any help would be greatly appreciated. Everything works except VVM.

  12. #11
    What's Jailbreak?
    Join Date
    Nov 2008
    Location
    Orlando, FL
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I've tried everything and searched everywhere and cannot get the settings to reappear. For me it started when I enabled teathering a while ago. But since then I've done two upgrades (3.1 & 3.1.2) and still no sign of the cellular data settings. I've removed the profile and tried to install a new one. Tried updating all the carrier settings, 5.0, 5.6, don't know where to find 6.0. My visual voice mail has been gone since my cellular data network settings disappeared and the way to get it back seems to be through those settings ugh help!!!!

  13. #12
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,477
    Thanks
    44
    Thanked 5,328 Times in 3,113 Posts

    6.0 is in the MMS thread in my signature

  14. #13
    Default what about non US/AT&T people?
    I am in Panama, with a MoviStar cell.
    If I put my AT&T chip in the phone, I get Cellular Data Network and can change the APN to whatever.
    However, when I put my Movistar chip in, no Cellular Data Network and my Carrier is MoviStar 5.0, not the Stealth 6.0 for AT&T.

    I've gone back and forth a couple of times and it's the same. AT&T chip, got it working find, shows AT&T 6.0.
    Movistar chip - no dice.
    So, how can I get an IPCC for Movistar that gives me Cellular Data Network?

    many thanks!
    Last edited by socoast; 11-28-2009 at 10:24 AM. Reason: more troubleshooting, more accurate info

  15. #14
    Tried to find it in your signature but no luck. I have the same issue... no cellular network settings to enter an apn in. I am on 3.1.2 3g jailbroken and unlocked. This happened when I went to 3.1.2 from 3.1

    UPDATE
    SO GET THIS I tried installing the apn editing thing in cydia... didnt load, crashed, I deleted.... tried a couple more times.... restart... and boom... my cellular data network setting magically appeared... WTF! lol
    Last edited by capttanhowdy; 12-03-2009 at 07:47 PM. Reason: UPDATE

  16. #15
    check your firmware. Did your carrier get upgraded to 5.11?

    Maybe you could do a complete restore to virgin (after doing a Backup, of course), then use Pwnage 3.1.4 to create the IPCC and BlackRain to jailbrake and Cydia to unlock. Then restore from Backup
    That worked for me on two iPhones that got upgraded to 3.1.2 via iTunes.
    Both now see Cellular Data Network (except of course when I have the MoviStar chip in - they are the official iPhone carrier in Panama, but they don't have an APN released yet. It's been 6 months!)

    Since you are using T-Mobile, did you turn off 3G? That's supposed to be an issue.

  17. #16
    Green Apple jcarroll's Avatar
    Join Date
    Nov 2007
    Location
    Bel Air, MD USA
    Posts
    77
    Thanks
    21
    Thanked 8 Times in 7 Posts

    I enabled the Cellular Data Network option by editing my carrier.plist file as outlined in this post.

    Just add the AllowEDGEEditing tag with value "true", respring, and it will appear.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •