Page 19 of 50 FirstFirst ... 91718192021 29 ... LastLast
Results 361 to 380 of 983

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: MMS on iPhone 2g with OS 3.0

  1. #361
    For people who require different APNs for their mobile data and their MMS, there may be a fix for you. I am on a Polish network which requires different APNs and I am able to send MMS and browse the internet. This is what I did:

    1. Install the Cydia package "ActivateMMS2G" and reboot
    2. Go to help.BenM.at on your iPhone
    3. Go to the second Mobileconfigs link, the one that allows you to create a custom Mobileconfig
    4. Enter your MMS APN (i.e. mms.plusgsm.pl) for both of the APN fields (Mobile Internet and Visual Voicemail) and enable tether. My network requires no username or password, if yours does, you may need to enter those as well.
    5. Press generate, install it, press OK, then reboot RIGHT AWAY. Do not check the settings!!!
    6. Go to settings > General and scroll down to profile. If it says 2 (or more) profiles, delete/uninstall the one(s) that are not called "help.benm.at" (i.e. delete all but the one you just installed). If it only says help.benm.at, skip to step 8.
    7. After deleting the other profiles, go back to help.BenM.at and repeat steps 3-5. The first time you try to install it, it may fail or hang while installing (it did for me anyway) if this happens, press the home button, then try again, it should work.
    8. Once your iPhone has rebooted, go to Settings > General > Network > Cellular Data Network. Your MMS APN should be present in every APN field.
    9. Fill in your MMSC and MMS Proxy. Once again, my network has no username or password, so I am not sure if you should add this here or during step 4... Experiment!!
    10. Reboot your iPhone.
    11. Open Messages and try to send an MMS. If it fails, check your settings are correct.
    12. If it is successful, go back to Cellular Data Network and change your Cellular Data APN to the one appropriate for your network.
    13. Test your data connection.
    14. Re-Test your MMS.

    This fixed it for me. It seems the MMS APN must be the one in the Mobileconfig file, or else it won't stick, whereas the Cellular Data APN can be anything. Let me know how it goes.
    Last edited by craig_16; 06-29-2009 at 04:38 AM. Reason: Edited step 4 to include enabling tether

  2. #362
    iPhone? More like MyPhone diggie2002's Avatar
    Join Date
    Mar 2008
    Location
    Deltona, FL
    Posts
    133
    Thanks
    46
    Thanked 12 Times in 11 Posts

    Quote Originally Posted by tekwiz View Post
    Reset Settings under General-->Network-->Cellular Data Network?

    I forsee issues anyways because ATT seems to be blocking
    I agree about ATT. Wouldn't this hack be necessary for us 2g owners to have this hack since supposedly the 2g can't MMS? I still would like to get the options "working" though just in case MMS is enabled for everyone.
    Under settings-->General-->network, I have only the option for data roaming, VPN and wi-fi, nothing else...Am I doing something wrong??
    Last edited by diggie2002; 06-28-2009 at 02:52 PM.
    Thank me if I helped you out!

  3. #363
    I've been sitting on this for a while trying different settings.

    List of available UAProf profiles

    Maybe some of you will have better luck. These URLs are supposed to go into the MMS UA Prof URL field.

    I know the W800i profile worked fine with SwirlyMMS as did the N95.

    I've also been toying with the max message size. I believe the most I've got out of it was 600kb (614400 in the settings pane).

    However I'm pretty sure T-Mobile sets a 300kb (307200 in the settings pane) limit.

    But since the pictures keep on coming in small, those limits don't seem to really apply (well they do since the pics are small).

    So I'll be leaving mine at 307200 (bytes).

    So how I think we may need to speak with T-Mobile or hack one of the plists.

    Btw, there is no need to reboot or respring after making any changes to any of those settings (as far as I can tell).

  4. #364
    Quote Originally Posted by tekwiz View Post
    Uh ya, I did jailbreak.
    Did you JB with resn0w or Pwnage?

    [quote=tekwiz;4614481The ipcc is a carrier settings file. It's supposed to put the settings in for you. [/QUOTE]

    did you install that before you installed ActivateMMS2G or after?


    [QUOTE=tekwiz;4614481If you have the settings in and they stick and it's still failing, try the alternate address for the proxy or MMSC...if that fails, AND you have MMS on your plan, then I'm stumped.[/quote]

    After I've gotten an answer to these questions I'll try again, and report back. You never know the little things that matter...

    J.D.
    Last edited by phreakwenci; 06-28-2009 at 02:55 PM.

  5. #365
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    hey guys i tried both MMSC settings for t-mobile and they both have the same resolution, both work just as good

  6. #366
    Quote Originally Posted by reznor9 View Post
    is there any way you can change the device profile so that Tmobile thinks its a Motorola or nokia like swirlymms does?
    Cause the picture quality of incoming mms is HORRIBLE?
    What we need is a User Agent Profile URL

  7. #367
    AFTER i done the instructions for Tmo do i need like Edge to recive MMS?or do i just need a MMS plan?

  8. #368
    Quote Originally Posted by phreakwenci View Post
    Did you JB with resn0w or Pwnage?



    did you install that before you installed ActivateMMS2G or after?




    After I've gotten an answer to these questions I'll try again, and report back. You never know the little things that matter...

    J.D.
    Pwnage, Installed it before patch

  9. #369
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    Apparently other people are working on the User agent url too

    MMS User Agent Prof in 3.0 -- Anyone Successful yet? - Hackint0sh

  10. #370
    Quote Originally Posted by diggie2002 View Post
    I agree about ATT. Wouldn't this hack be necessary for us 2g owners to have this hack since supposedly the 2g can't MMS? I still would like to get the options "working" though just in case MMS is enabled for everyone.
    Under settings-->General-->network, I have only the option for data roaming, VPN and wi-fi, nothing else...Am I doing something wrong??
    You have installed ActivateMMS2g from Cydia?
    Installed a MobileConfig from help.benm.at?

    What have you tried?

    Quote Originally Posted by craig_16 View Post
    For people who require different APNs for their mobile data and their MMS, there may be a fix for you. I am on a Polish network which requires different APNs and I am able to send MMS and browse the internet. This is what I did:

    1. Install the Cydia package "ActivateMMS2G" and reboot
    2. Go to help.BenM.at on your iPhone
    3. Go to the second Mobileconfigs link, the one that allows you to create a custom Mobileconfig
    4. Enter your MMS APN (i.e. mms.plusgsm.pl) for both of the APN fields (Mobile Internet and Visual Voicemail). My network requires no username or password, if yours does, you may need to enter those as well.
    5. Press generate, install it, press OK, then reboot RIGHT AWAY. Do not check the settings!!!
    6. Go to settings > General and scroll down to profile. If it says 2 (or more) profiles, delete/uninstall the one(s) that are not called "help.benm.at" (i.e. delete all but the one you just installed). If it only says help.benm.at, skip to step 8.
    7. After deleting the other profiles, go back to help.BenM.at and repeat steps 3-5. The first time you try to install it, it may fail or hang while installing (it did for me anyway) if this happens, press the home button, then try again, it should work.
    8. Once your iPhone has rebooted, go to Settings > General > Network > Cellular Data Network. Your MMS APN should be present in every APN field.
    9. Fill in your MMSC and MMS Proxy. Once again, my network has no username or password, so I am not sure if you should add this here or during step 4... Experiment!!
    10. Reboot your iPhone.
    11. Open Messages and try to send an MMS. If it fails, check your settings are correct.
    12. If it is successful, go back to Cellular Data Network and change your Cellular Data APN to the one appropriate for your network.
    13. Test your data connection.
    14. Re-Test your MMS.

    This fixed it for me. It seems the MMS APN must be the one in the Mobileconfig file, or else it won't stick, whereas the Cellular Data APN can be anything. Let me know how it goes.
    Awesome Work!!!
    Last edited by tekwiz; 06-28-2009 at 03:03 PM. Reason: Automerged Doublepost

  11. #371
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    heres the user agent urls guys to get bigger picture messages

    Here are the "User-Agent" and "Profile" strings used by a few current day devices ...

    Motorola KRZR:

    User-Agent:MOT-K1/08.22.07R MIB/BER2.2 Profile/MIDP-2.0 Configuration/CLDC-1.1 EGE/1.0
    Profile: "http://motorola.handango.com/phoneco...Profile/k1.rdf"


    Blackberry 8800:

    User-Agent: BlackBerry8800/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100
    Profile: http://www.blackberry.net/go/mobile/...8800/4.2.1.rdf

    Nokia N95:

    User-Agent: NokiaN95/11.0.026; Series60/3.1 Profile/MIDP-2.0 Configuration/CLDC-1.1
    Profile: "http://nds1.nds.nokia.com/uaprof/NN95-1r100.xml"

    So how do you convince your mobile operator that your modem is some other type of device?

    In a default configuration, NowSMS does not send either of these headers when connecting to an operator MMSC to send or receive MMS messages.

    However, in the MMSC.INI file, under the [MMSC] header, you can add the following settings:

    HeaderUserAgent=
    HeaderProfile=

    For example, to pretend that you're an N95:

    HeaderUserAgent=NokiaN95/11.0.026; Series60/3.1 Profile/MIDP-2.0 Configuration/CLDC-1.1
    HeaderProfile="http://nds1.nds.nokia.com/uaprof/NN95-1r100.xml"

    TAKEN FROM HERE - http://www.nowsms.com/discus/messages/485/21779.html

  12. #372
    iPhoneaholic westc0ast's Avatar
    Join Date
    Aug 2008
    Location
    Los Angeles, California
    Posts
    347
    Thanks
    29
    Thanked 44 Times in 36 Posts

    Quote Originally Posted by Lecram25 View Post
    I just changed my APN to wap.voicestream.com, it's interesting to see that T-Mobile seems to have opened all port via that APN (before they blocked the hell out of everything, hence the reason for the proxy hack).

    Anyway, I sent an MMS to myself and it sent fine (without the 5 minute lag some are reporting) and promptly received it (of course, the image was scaled down).

    Working Steps (T-Mobile USA):

    1) Install the hack via Cydia (Reboot)
    2) Settings -> General -> Network -> Cellular Data Network and tap Reset Settings
    3) Reboot
    4) Settings -> General -> Network -> Cellular Data Network and input wap.voicestream.com for both APNs and use these settings:

    MMS APN: wap.voicestream.com
    Username: [Leave blank]
    Password: [Leave blank]
    MMSC: 216.155.174.84/servlets/mms
    Proxy: 216.155.165.050:8080
    MMS Max Message Size: 307200 (300kb limit)
    MMS UA Prof URL: wap.sonyericsson.com/UAprof/W800iR101.xml (meant to fix the small image size issue but doesn't seem to be working)

    5) Reboot
    6) Settings -> Messages and check that MMS Messaging is on.

    You should now be able to send picture messages. No need for the carrier update.

    Here is another T-Mobile USA MMS setting:

    [MMS] APN: wap.voicestream.com
    Username: [Leave blank]
    Password: [Leave blank]
    MMSC: mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080

    Side note: Does anyone know if this guy has PayPal? I am definitely donating!

    EDIT: List of more profiles: List of available UAProf profiles
    thanks you made it so simple it worked perfectly
    All information contained in my post came to me in a dream. I don't even own an iphone.
    Don't forget to hit the thanks button

  13. The Following User Says Thank You to westc0ast For This Useful Post:

    ddfilms (06-28-2009)

  14. #373
    This is awesome, thanks for the great work, everyone

    I have a quick question: I'm not on T-Mo, as I'm in Chile (using Movistar, which is an official iPhone carrier). Do I have to do the Cellular Data Network reset steps as well while using this method? Because when I go to "Settings > General > Network > " I see no "Cellular Data Network" options. Only Data Roaming on-off switch, VPN and Wi-Fi.

    Any help will be appreciated

    Follow me on Twitter!

  15. #374
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    The user agent url seems to do nothing......... i tried the Nokia N95 URL didnt help

  16. #375
    Quote Originally Posted by instinct818 View Post
    Can anyone tell me why cellullar data network is not showing up in my settings?I installed ActivateMMS2G but can't send any pics because i can't configure my MMS SETTINGS...
    Quote Originally Posted by diggie2002 View Post
    Same here. I installed the ActivateMMS2G hack but to no avail. I still have no option i cellular network to configure nor a mms option in messages. I've uninstalled, rebooted, re-installed, done everything but restore the darn thing. BTW, Im on ATT, 3.0FW and obviously a 2g.
    look at my post on page 19. you can try that and it will probably work for you, it worked for me and i was having the same issue.

  17. #376
    Quote Originally Posted by Lecram25 View Post
    I've been sitting on this for a while trying different settings.

    List of available UAProf profiles

    Maybe some of you will have better luck. These URLs are supposed to go into the MMS UA Prof URL field.

    I know the W800i profile worked fine with SwirlyMMS as did the N95.

    I've also been toying with the max message size. I believe the most I've got out of it was 600kb (614400 in the settings pane).

    However I'm pretty sure T-Mobile sets a 300kb (307200 in the settings pane) limit.

    But since the pictures keep on coming in small, those limits don't seem to really apply (well they do since the pics are small).

    So I'll be leaving mine at 307200 (bytes).

    So how I think we may need to speak with T-Mobile or hack one of the plists.

    Btw, there is no need to reboot or respring after making any changes to any of those settings (as far as I can tell).
    I have this working using epc.tmobile.com as the APN and I and the size you listed above. I tried sending an MMS from the iPhone to my email and the resolution is fine, however anything coming into the iPhone looks like crap, I wonder if maybe there is another setting that needs to be adjusted on the phone itself.

    APN: epc.tmobile.com
    Username:
    Password:
    MMSC: http://mms.msg.eng.t-mobile,com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080
    MMS Max Message Size: 307200
    MMS UA Prof URL: http://wap.sonyericsson.com/UAprof/K700iR201.xml

  18. #377
    Quote Originally Posted by craig_16 View Post
    For people who require different APNs for their mobile data and their MMS, there may be a fix for you. I am on a Polish network which requires different APNs and I am able to send MMS and browse the internet. This is what I did:

    1. Install the Cydia package "ActivateMMS2G" and reboot
    2. Go to help.BenM.at on your iPhone
    3. Go to the second Mobileconfigs link, the one that allows you to create a custom Mobileconfig
    4. Enter your MMS APN (i.e. mms.plusgsm.pl) for both of the APN fields (Mobile Internet and Visual Voicemail). My network requires no username or password, if yours does, you may need to enter those as well.
    5. Press generate, install it, press OK, then reboot RIGHT AWAY. Do not check the settings!!!
    6. Go to settings > General and scroll down to profile. If it says 2 (or more) profiles, delete/uninstall the one(s) that are not called "help.benm.at" (i.e. delete all but the one you just installed). If it only says help.benm.at, skip to step 8.
    7. After deleting the other profiles, go back to help.BenM.at and repeat steps 3-5. The first time you try to install it, it may fail or hang while installing (it did for me anyway) if this happens, press the home button, then try again, it should work.
    8. Once your iPhone has rebooted, go to Settings > General > Network > Cellular Data Network. Your MMS APN should be present in every APN field.
    9. Fill in your MMSC and MMS Proxy. Once again, my network has no username or password, so I am not sure if you should add this here or during step 4... Experiment!!
    10. Reboot your iPhone.
    11. Open Messages and try to send an MMS. If it fails, check your settings are correct.
    12. If it is successful, go back to Cellular Data Network and change your Cellular Data APN to the one appropriate for your network.
    13. Test your data connection.
    14. Re-Test your MMS.

    This fixed it for me. It seems the MMS APN must be the one in the Mobileconfig file, or else it won't stick, whereas the Cellular Data APN can be anything. Let me know how it goes.
    EXACTLY what I did and was going to post but you were quicker - nice and clear description.

  19. #378
    My MMS still takes about 5 full minutes to send, real quick to receive though. why!!!?? lol.

  20. #379
    Once again, has anyone managed to get mms working on at&t WITHOUT changing the imei number?

  21. #380
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    i left the prof url blank, i noticed if you send to anyone but a iphone the resolution is perfectly clear, as soon as it hits a iphone it resizes it when it comes in

Page 19 of 50 FirstFirst ... 91718192021 29 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •