+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Changing boot logo in 3.0

is a discussion within the

File Mods

forums, a part of the

iPhone Modding

section;
Has anyone tried Logo Me under 3.0? I installed it via apt-get and got an error where it looked like it was trying to download some firmware. It did appear
...
  1. #1
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    18
    Thanks
    0
    Thanked 1 Time in 1 Post
    Question Changing boot logo in 3.0
    Has anyone tried Logo Me under 3.0? I installed it via apt-get and got an error where it looked like it was trying to download some firmware. It did appear on the springboard though. I did not try to use it due to the error. So, 1) Has anyone else attempted to use it on 3.0? 2) Results? 3) Any other way to change the boot logo without re-flashing?

    Thanks!

  2. #2
    Green Apple
    Join Date
    Apr 2008
    Location
    Belgium
    Posts
    33
    Thanks
    220
    Thanked 3 Times in 3 Posts

    i also got the error abouth it partially installing and could cause errors so i removed it.

    i think it is not ready for 3.0 just jet, it seems they moved around some files in the new firmware.

  3. #3
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    18
    Thanks
    0
    Thanked 1 Time in 1 Post
    The actual error if anyone is interested. I may try and put this together by hand as I really want to change the logo If I do I'll post the results here.


    Vaeleks-iPhone:/var/log root# apt-get install com.complicatedstuff.logome
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    com.complicatedstuff.logome
    0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
    Need to get 0B/331kB of archives.
    After this operation, 0B of additional disk space will be used.
    Selecting previously deselected package com.complicatedstuff.logome.
    (Reading database ... 2470 files and directories currently installed.)
    Unpacking com.complicatedstuff.logome (from .../com.complicatedstuff.logome_2.2-1_iphoneos-arm.deb) ...
    Setting up com.complicatedstuff.logome (2.2-1) ...
    Caching firmware files...
    rm: cannot remove `/var/mobile/Library/LogoMe': No such file or directory
    /home/planetbeing/xpwn-back/partial/logome.c:CacheFirmware:219: url: http://appldnld.apple.com.edgesuite....1_Restore.ipsw
    /home/planetbeing/xpwn-back/partial/logome.c:GetInfo:143: opening plist at: /var/mobile/Library/LogoMe/iPhone1,2_3.0/Info.plist
    /var/lib/dpkg/info/com.complicatedstuff.logome.postinst: line 7: 560 Bus error /Applications/LogoMe.app/_logome /Applications/LogoMe.app/PwnmetheusBundles -CacheFirmware
    dpkg: error processing com.complicatedstuff.logome (--configure):
    subprocess post-installation script returned error exit status 138
    Errors were encountered while processing:
    com.complicatedstuff.logome
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Alright, so I tried manually placing the ipsw in the correct path and removed the postinst and postrm scripts for Logo Me. Everything seems to work until you try to flash, then nothing much happens. Based on the following output, I'm not sure if the issue lies with Logo Me, or with MobileHook.

    Jun 20 19:35:29 Vaeleks-iPhone UIKitApplication:com.complicatedstuff.LogoMe[0xb9bc][754]: MobileHook: Look Up for libraries in [/Library/MobileHook/]
    Jun 20 19:35:29 Vaeleks-iPhone UIKitApplication:com.complicatedstuff.LogoMe[0xb9bc][754]: MobileHook: Error read folder: [/Library/MobileHook/]
    Jun 20 19:35:29 Vaeleks-iPhone UIKitApplication:com.complicatedstuff.LogoMe[0xb9bc][754]: MobileHook: Done
    Last edited by Vaelek; 06-20-2009 at 06:46 PM. Reason: Automerged Doublepost

  4. #4
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts

    how do you correct that error anyone

    the boot log wont flash after downloading
    Last edited by Jad_eds; 06-25-2009 at 12:31 PM. Reason: Automerged Doublepost

  5. #5
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    18
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Jad_eds View Post
    how do you correct that error anyone

    the boot log wont flash after downloading
    Logo Me does not currently work on 3.0. As I said above, I even tried manually adding the ipsw and it did nothing when I tried to flash a logo. We'll just have to wait for it to get updated. Since it's by the Dev Team, I would say you shouldn't expect anything until they're finished working out the ultrasn0w issues and such.

  6. #6
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    anyone got there boot logo changed yet?

  7. #7
    What's Jailbreak? jeskie's Avatar
    Join Date
    Mar 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    nope

  8. #8
    What's Jailbreak?
    Join Date
    Dec 2008
    Location
    San Antonio, TX
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    The masterlist for for cydia apps that are compatible with 3.0 shows logome as not working, but also says that the "dev team is too busy" to work on fixing it, so i guess we're all out of luck :/

  9. #9
    iPhone? More like MyPhone Doorstopdima's Avatar
    Join Date
    Jul 2009
    Posts
    216
    Thanks
    44
    Thanked 15 Times in 14 Posts

    yah dis freakin sux cus i downloaded a ton of cool boot logos... ):

  10. #10
    What's Jailbreak? Hammy's Avatar
    Join Date
    May 2009
    Location
    In a House...
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    i downloaded it and when i opened it it just closes again so it doesnt work

  11. #11
    What's Jailbreak?
    Join Date
    Mar 2009
    Location
    Southampton, Uk.
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Surely someone has fixed this error now???

  12. #12
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    18
    Thanks
    2
    Thanked 0 Times in 0 Posts

    mmmmm i tried too but same error, mmmm could be posible change it using winscp ???

  13. #13
    MMI's Official Devil Dog santacruzlocal's Avatar
    Join Date
    Mar 2009
    Location
    SC California
    Posts
    620
    Thanks
    5
    Thanked 45 Times in 37 Posts

    No fix for it yet ... I think there to busy working on 3.1 crack for windows

  14. #14
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    8
    Thanks
    2
    Thanked 1 Time in 1 Post
    im working on it... nothing working yet...

  15. #15
    Green Apple
    Join Date
    Sep 2008
    Posts
    41
    Thanks
    13
    Thanked 2 Times in 2 Posts

    Do it the old way, NOR restore your iPhone/iPod, and in that IPSW, insert your custom bootlogo img3 file. There was a tool out that inserted the logos in the img3 file. It was command line though. I used to use this method on 2.2.1, but method should still work for 3.0. If you need the decryption keys for the img3 file, download PwnageTool (Mac or win people) and view it's contents. go to firmwarebundles folder and go to the bundle for your device. open info.plist and look for the bootlogo key. This method was used to get custom logos on the iPod Touch 2G along with upgrading the iPod from tethered to semi-tethered for the run_rs commands. just look back a bit and look through old guides for those times.
    Last edited by gamer765; 11-05-2009 at 02:30 PM.

  16. #16

  17. #17
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    [ame]http://www.ipodtouchfans.com/forums/showthread.php?t=237533[/ame]

    or

    [ame=http://www.youtube.com/watch?v=D2Qxs_-RX4A]YouTube - HOW TO RUN PWNAGE TOOL ON WINDOWS AND BUILD YOUR OWN CUSTOM FIRMWARE!!!!!![/ame]
    Last edited by The Jake Bush; 11-25-2009 at 01:37 AM.

  18. #18
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I read somewhere that you can change the boot logo using winterboard, "....simply add the boot logo into the theme folder and call it boot.png Winterboard then automatically replaces the .png that needs replacing." Anyone knows if this works?

  19. #19
    perma-banned for life
    Join Date
    Mar 2009
    Location
    Photoshop CS5
    Posts
    8,424
    Thanks
    10,454
    Thanked 7,050 Times in 3,590 Posts

    sn0wbreeze

  20. #20
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by ArDottCeeDuble View Post
    sn0wbreeze
    Yes, thats great, but i dont want to loose all my data and start all over again.
    so can it work with winterboard like i said before?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts