Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SSH No Longer Working

  1. #1
    Default SSH No Longer Working
    For some reason I am not longer able to SSH with my iPhone 2.2. Using cyberduck I get an I/O Connection Error and using terminal I get a connection refused error. Ive look at some previous posts but couldnt find any solutions there. Any body have an idea

  2. #2
    I've had that problem too.

    I just quit Cyber duck, turned Wifi off on my phone.
    Start Cyber Duck back up (make sure it is set to Sfpt) then turn wifi back on and login again. That usually works for me.

  3. #3
    Quote Originally Posted by justflikwalk View Post
    I've had that problem too.

    I just quit Cyber duck, turned Wifi off on my phone.
    Start Cyber Duck back up (make sure it is set to Sfpt) then turn wifi back on and login again. That usually works for me.
    Did not change anything.

  4. #4
    Try going to Cydia and uninstall openssh and then reinstall and see if that helps.

  5. #5
    Quote Originally Posted by hiflyer View Post
    Try going to Cydia and uninstall openssh and then reinstall and see if that helps.
    Still getting the same error messages. Completely lost on how to fix this.

  6. #6
    same problem for me...though it works sometimes its extremely slow. i think this started when i upgraded to 2.2, cant be too sure if its the reason though

  7. #7
    Quote Originally Posted by iPh0wned View Post
    same problem for me...though it works sometimes its extremely slow. i think this started when i upgraded to 2.2, cant be too sure if its the reason though
    I agree the problem didn't start until after I upgraded but I have seen previous posts about this before 2.2 was out.

  8. #8
    i would use diskaid, you dont need to ssh in, it uses the usb for connection

  9. #9
    Try using winscp.....

  10. #10
    Try installing Bossprefs from Cydia and check that SSH is turned on.
    Last edited by zendj; 01-02-2009 at 02:41 PM.

  11. #11
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,533
    Thanks
    93
    Thanked 363 Times in 273 Posts

    I have intermittently had this issue with one of my computers. I think it may have to do with dynamic IP assignments. I need to go into my router settings (a Verizon Fios Actiontec POS router) and make sure that that one PC has an appropriate IP and that SSH is enabled in port forwarding to port 22. Also make sure that your AV is not blocking SSH. In Kaspersky Internet Security, you can check application and firewall application filtering settings.

    It is very odd as this never happens on any of my other PC's or my Macbook.


    If I've helped you, you can help me by clicking on that Thanks button.
    iPhone, the Swiss Army knife of the 21st Century.

  12. #12
    iPhone? More like MyPhone
    Join Date
    Apr 2008
    Location
    Nottingham, UK
    Posts
    117
    Thanks
    3
    Thanked 13 Times in 4 Posts

    if it's your router tat is doing tat, reset factory settings... or maybe update the firmware of it... or just use adhoc if you wanna save the hassle...

    or use filezilla or winscp...

    if not, backup ur data and restore ur iphone, install fresh openssh...

    or

    uninstall openssh, reset network settings, reinstall openssh, reboot...
    Last edited by squaresoft; 01-05-2009 at 08:12 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •