+ Reply
Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: ARG - can't ssh or login

is a discussion within the

File Mods

forums, a part of the

iPhone Modding

section;
I even went as far as restoring my iPhone and reloading just the few things I wanted and I still can't login under Terminal or through SSH. Some app or
...
  1. #1
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Default ARG - can't ssh or login
    I even went as far as restoring my iPhone and reloading just the few things I wanted and I still can't login under Terminal or through SSH. Some app or program has mucked me up. Anyone have any ideas about this problem?

    The error in the image says "Segmentation fault and immediately logs me out. The same thing happens with SSH, I can login in but then a second or two later it closes the connection.

    Apps I have installed:
    Installer (1.8)
    Mobilefinder
    Terminal
    BSD Utilities 1.4
    Launcher
    Books
    NES
    Lights Off
    VNotes

    Edit: I was able to SSH even after the 1.01 update, so I don't believe the iPhone update is the cause.
    Last edited by CyberGreg; 07-25-2008 at 03:06 PM.

  2. #2
    iPhoneaholic XFaega's Avatar
    Join Date
    Jul 2007
    Location
    SomeWhereHere
    Posts
    452
    Thanks
    8
    Thanked 29 Times in 23 Posts

    What are you trying to login to?

  3. #3
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Quote Originally Posted by XFaega View Post
    What are you trying to login to?
    If you 'login' in Terminal, it is the same as when you login through ssh. I also had a problem where I could only type three characters and the fourth would become a carriage return. So ls would work but chmod would display as chm command not found or whatever. That error was fixed by doing the restore and I could see that either through ssh or when I ran login in terminal.

    Quite odd... sux 'cause I can't grab screenshots until I can ssh into my phone.

    Well everything is working and about the only thing I haven't installed is the BSD Utilities which is now up to 1.5 (hmmm how can unix utlities get updated ???? )

    ssh, screenshot and terminal are all functioning properly.
    Last edited by CyberGreg; 08-22-2007 at 11:29 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts