Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Volume Won't Stick!! File Location 2.0.1?

  1. #1
    Livin the iPhone Life nickh's Avatar
    Join Date
    Sep 2007
    Location
    Melbourne, Australia
    Posts
    1,216
    Thanks
    66
    Thanked 148 Times in 118 Posts

    Default Volume Won't Stick!! File Location 2.0.1?
    Am having major issues with with volume not sticking when set to high, (settings/sounds) after I exit settings always reverts back to just under half. Tried a restore with no success. Anyone know the whereabouts of the file string I can change, so it is permanently set to high?

    Any help very much appreciated.

    Cheers,

  2. #2
    should be
    /private/var/mobile/Library/Preferences/com.apple.celestial.plist
    mine says:
    <key>volumeMultiplier</key>
    <dict>
    <key>global</key>
    <real>1.5</real>
    </dict>
    and
    <key>broadcast</key>
    <dict>
    <key>Ringtone</key>
    <real>1</real>
    </dict>
    I guess those are the important parts considering ringtone volume

    regards

  3. The Following User Says Thank You to BlackWolf For This Useful Post:

    nickh (08-15-2008)

  4. #3
    Livin the iPhone Life nickh's Avatar
    Join Date
    Sep 2007
    Location
    Melbourne, Australia
    Posts
    1,216
    Thanks
    66
    Thanked 148 Times in 118 Posts

    Thanks given BW, will take a look see what the story is.

    How did you open the com.apple.celestial.plist file?, I just get bounced back to the log in box.

    Edit: opened file, exactly same as you posted. Wonder why it will not stick, any thoughts?
    Last edited by nickh; 08-15-2008 at 10:23 AM. Reason: Automerged Doublepost

  5. #4
    did you install any modifications for the settings.app? seems to me like the volume is set to high, but your settings.app is somehow screwed and doesn't read the values properly?

    because if your celestial.plist says 1.5 for the global multiplier and 1 for ringtone volume you definetly HAVE maximum volume.
    try pressing the volume buttons on the side of your iphone when you are on your homescreen. see what the "ringer" volume indicator says that pops up. it should indicate full volume.

    also note that you have different volumes for your headphones plugged in and not plugged in. so if you plug in your headphones your volume may change!

    regards

  6. #5
    Livin the iPhone Life nickh's Avatar
    Join Date
    Sep 2007
    Location
    Melbourne, Australia
    Posts
    1,216
    Thanks
    66
    Thanked 148 Times in 118 Posts

    Cheers for the feedback, I have no mods in the settings.app

    tried what you suggested and pressed volume buttons on side of phone whilst on home screen, ringer indicator pop up goes to full, when settings app opened ringer indicator at half. Just will not stay at full for some unknown reason.

    Also i rarely use the headphones, only sometimes whilst driving if i get a call.

    Cheers for the feedback, I have no mods in the settings.app

    tried what you suggested and pressed volume buttons on side of phone whilst on home screen, ringer indicator pop up goes to full, when settings app opened ringer indicator at half. Just will not stay at full for some unknown reason.

    Also i rarely use the headphones, only sometimes whilst driving if i get a call.

    Any other thoughts BW?
    Last edited by nickh; 08-16-2008 at 07:44 AM. Reason: Automerged Doublepost

  7. #6
    mh ... very strange. seems like for some reason your settings.app resets the volume.
    But normally a restore should get rid of any software problems and that didn't help ... do you have an ATT contract? because I would advise you to go to an apple store and have your iphone checked out / replaced. otherwise try another restore, maybe it helps. make sure you use 2.0.1.

  8. The Following User Says Thank You to BlackWolf For This Useful Post:

    nickh (08-16-2008)

  9. #7
    Livin the iPhone Life nickh's Avatar
    Join Date
    Sep 2007
    Location
    Melbourne, Australia
    Posts
    1,216
    Thanks
    66
    Thanked 148 Times in 118 Posts

    Nope the restore didnt work what so ever, I have the problem on mine as well as my wife's phone which is not even modded, No ATT contact, am in Australia on the Optus Network & only Apple store is in Sydney 1000 kms away.

    Will wait to see if a hack (volume boost) comes out for it, seen a few other posts on the same subject on this board, or for the new update due out at the end of the month (3G fix) see if that does the trick. If not will take it back to the telco.

    Thanks given & cheers for your help and input, Much Appreciated.
    Nick.

    Nope the restore didnt work what so ever, I have the problem on mine as well as my wife's phone which is not even modded, No ATT contact, am in Australia on the Optus Network & only Apple store is in Sydney 1000 kms away.

    Will wait to see if a hack (volume boost) comes out for it, seen a few other posts on the same subject on this board, or for the new update due out at the end of the month (3G fix) see if that does the trick. If not will take it back to the telco.

    Thanks given & cheers for your help and input, Much Appreciated.
    Nick.
    Last edited by nickh; 08-16-2008 at 08:14 AM. Reason: Automerged Doublepost

  10. #8
    you have that problem on two iphones and a restore doesn't help?
    I would guess you are somehow using it wrong, because it definetly should work - but admittingly I have a 2G iphone, not a 3G, but I guess if it was a general problem with the 3G firmware it would be known by now.

    what I noticed is that the ringer indicator (buttons on your iphone) is not related to the ringtone volume. it seems to be the "global multiplier" mentioned in the celestial.plist. so even if your ringer indicator shows full volume it is still possible that the volume indicator in the settings doesn't.

    but in the end, if you go to your settings->sounds and set the volume to maximum, then leave the settings then re-enter them it should still be at full volume.

  11. #9
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    Montgomery Village, MD
    Posts
    202
    Thanks
    84
    Thanked 12 Times in 12 Posts

    I have the same problem, when I go into settings it shows it's at half volume, but when I get a call or press the buttons on the side it shows it's at max volume and when I respring/reboot it shows it's at half again. Btw I'm on 2.0.1 pwned. And it's the first generation.

  12. #10
    Livin the iPhone Life nickh's Avatar
    Join Date
    Sep 2007
    Location
    Melbourne, Australia
    Posts
    1,216
    Thanks
    66
    Thanked 148 Times in 118 Posts

    Problem fixed, iClarified has come up with the goods again, installed the 2.0.1 Volume Boost from there repo, Volume always on high now.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •