Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone Stuck at apple logo

  1. #1
    Exclamation iPhone Stuck at apple logo
    I followed the instruction on how to stop the Scrolling on the carrier name from the website i.unlock.no
    This requred me to hex edit a file called Springboard found in /System/Library/CoreServices/Springboard.app/

    It was only to change the font size of the file but now the iphone just stays in the apple logo screen. Does anyone have a solution to this problem? Or can anyone send me the Springboard file from their phone? I would lreally appreciate the help. Thanks.
    If someone decides to send the file please send it to [email protected], and no, restoring is not an option.

  2. #2
    sorry dude, no way out of this one except a full restore. if you want to stop the scroll just copy the files here and replace yours rather than editing it yourself with hexeditor. becareful that you choose the correct file for your firmware version or youll end back where you started.

  3. #3
    Same problem here... i did the same thing. i backed up my original springboard file but replacing the new modded one with the original didnt do anything. still stuck at Boot screen.. but the phone is booting up.. because i can access things via ibrickr etc.. it just not loading the springboard. so maybe there is a solution to fix this. ill see what i can find before restoring.

  4. #4
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by forsyt View Post
    sorry dude, no way out of this one except a full restore. if you want to stop the scroll just copy the files here and replace yours rather than editing it yourself with hexeditor. becareful that you choose the correct file for your firmware version or youll end back where you started.
    You don't need to do a full restore, you simply have to copy your original springboard binary back to your Springboard.app

    The reason you're stuck at the Apple icon is because springboard can't run, and if it can't run, nothing else can occur. You will note that even though you're stuck at the apple icon, you can still SSH into your phone or iBrickr into it to correct the problem.
    Get "iPod & iTunes for Dummies", it'll change your life.

  5. The Following 2 Users Say Thank You to Eurisko For This Useful Post:

    aaliyahdani2005 (12-02-2007), uvbisani (07-11-2008)

  6. #5
    iPhoneaholic theone77's Avatar
    Join Date
    Oct 2007
    Location
    PlaNeT Earth in the Middle Part
    Posts
    442
    Thanks
    47
    Thanked 276 Times in 112 Posts

    ---it mentioned for those who touched springboard, edit it---
    Warning: Don't patch springboard with iBrickr or iPhoneBrowser or anything else that can't make sure its permissions are set to 0755. This has been locking people out of their springboard. Use an SSH client instead and insure that the new springboard file has 0755 permissions before disconnecting.



    NO NEED TO RESTORE if u stuck on apple logo (coz u hexedit/patched ur SPRINGBOARD file here ---> System/Library/CoreServices/SpringBoard.app/SpringBoard)

    what i did:
    i use winscp and make sure that the springboard file i put has 0755 permission. in ur winscp rightclick the springboard file and make sure it has 0755 permissions...thats it ! REBOOT and welcomeback springboard
    Last edited by theone77; 11-27-2007 at 04:40 PM.

  7. The Following 2 Users Say Thank You to theone77 For This Useful Post:

    cruel0r (04-06-2008), HUMVEE (11-28-2007)

  8. #6
    too bad i didn't see this topic a couple of days ago

    i restored back to 1.1.1 and unlocked it all by myself again.
    it went perfectly smooth but of course it would have been better if
    i just had done what's described here

  9. #7
    @theone77 : Nice Method theone77 ......Very Good...

  10. #8
    iPhoneaholic theone77's Avatar
    Join Date
    Oct 2007
    Location
    PlaNeT Earth in the Middle Part
    Posts
    442
    Thanks
    47
    Thanked 276 Times in 112 Posts

    Quote Originally Posted by HUMVEE View Post
    @theone77 : Nice Method theone77 ......Very Good...
    dont forget the thanks button

  11. The Following User Says Thank You to theone77 For This Useful Post:

    HUMVEE (11-29-2007)

  12. #9
    I am having the same problem with being stuck at the apple logo, but it started all on its own when I rebooted because of a program locking up. I have winscp, but I cant access what the hostname would be for the phone because its stuck on the logo, and I dont even know if im connected to a wifi network. Ive tried to enter restore mode and that doesnt even work, the only thing that works is turning it off by holding both the power and home buttons. Does anyone have any help? This is my only phone so its quite important I get it at least functional soon.
    Thanks in advance.

    EDIT: I got restore mode working, and I'm restoring down to 1.1.1 and jailbreaking all over again. From what I have read on these forums, I believe it may have been an issue with 3rd party sources, but I'm not sure. Thanks anyway!
    Last edited by Zachs23; 11-28-2007 at 12:55 PM.

  13. #10
    Quote Originally Posted by theone77 View Post
    dont forget the thanks button
    Thanks Button it's done for You Brother......

    Quote Originally Posted by theone77 View Post
    ---it mentioned for those who touched springboard, edit it---
    Warning: Don't patch springboard with iBrickr or iPhoneBrowser or anything else that can't make sure its permissions are set to 0755. This has been locking people out of their springboard. Use an SSH client instead and insure that the new springboard file has 0755 permissions before disconnecting.



    NO NEED TO RESTORE if u stuck on apple logo (coz u hexedit/patched ur SPRINGBOARD file here ---> System/Library/CoreServices/SpringBoard.app/SpringBoard)

    what i did:
    i use winscp and make sure that the springboard file i put has 0755 permission. in ur winscp rightclick the springboard file and make sure it has 0755 permissions...thats it ! REBOOT and welcomeback springboard
    Mods Must be sticky this method is easy to use for everyone iPhone-ers user...
    Last edited by HUMVEE; 11-29-2007 at 09:29 AM. Reason: Automerged Doublepost

  14. The Following User Says Thank You to HUMVEE For This Useful Post:

    theone77 (11-30-2007)

  15. #11
    iPhoneaholic theone77's Avatar
    Join Date
    Oct 2007
    Location
    PlaNeT Earth in the Middle Part
    Posts
    442
    Thanks
    47
    Thanked 276 Times in 112 Posts

    Quote Originally Posted by HUMVEE View Post
    Thanks Button it's done for You Brother......



    Mods Must be sticky this method is easy to use for everyone iPhone-ers user...
    no need but THANKS for this
    DoNt ForGeT to Say "THanK You" using tHe THANKS ButToN if you found my post helpful

    Apple iPhoNe 3GS Factory Unlocked 3.1.2 All working flawlessly!!
    .

  16. #12
    Hey how did you reach restore mode. I am having the same problem when i try to hold the home and power button all it does it keep popping up the apple logo screen. I have held the buttons down for a while and my computer does not recognize the iphone even being connected. Please advise me, I am sooooo lost.

  17. #13
    my problem is now that it wont boot past apple screen, itunes and pc detect it and thats fine but my springboard is already set to 755 and it still doesnt boot past. Iphone is unlocked so I don't want to take it to a restore because I fear it could make things worse.
    any ideas?

  18. #14
    me too, unlocked 1.1.1 phone stuck on logo and springboard is already set to 0755. I was trying to install summerboard manually and this happened does it have anything to do with the springboard.plist

    ** hmm nevermind, restoring back to 1.1.1 and then activating it fixed the problem
    Last edited by invu; 02-07-2008 at 10:22 PM. Reason: problem resolved

  19. #15
    What's Jailbreak? xiethan's Avatar
    Join Date
    Jan 2008
    Posts
    17
    Thanks
    1
    Thanked 2 Times in 1 Post
    Smile what works:
    Here's a little trick when you're stuck on the Apple Logo:

    1. Turn your computer volume up.
    2. Open iTunes.
    3. Hold down power/home until the Apple Logo disappears and then reappears (restarts iPhone).
    4. Keep holding the home button until you hear the noise telling you its connected. It might immediately play the noise that says its disconnected, if it does, wait until the connected noise plays: the let the home button go.
    5. iTunes will say it's in restore mode.

    - Now you can split two ways -

    6a. I rebooted from recovery mode with iBrickr. This may not work for you, as I wasn't modding anything at the time of the 'brick'.
    6b. You can restore with iTunes to 1.1.1 or 1.1.3 (I recommend 1.1.3 then use ziPhone).


    Good luck!

  20. The Following 2 Users Say Thank You to xiethan For This Useful Post:

    cruel0r (04-06-2008), rey_piloto (03-14-2008)

  21. #16
    Hello, I have the same problem. Black screen. Apple Logo and the iphone no longer connects to windows nor Itunes.. the only thing I can do is reboot the IPHONE... can somebody help me please?

  22. #17
    Im having the same issue as everyone...

    but my happens after I install something from installer and for some reason, it gets stuck in the soft-reset and I have to hard-reset to be stuck at the apple. I used to SSH into it and delete the newly downloaded application manually, but for some reason, my old Wifi IP address isnt confirming anymore, and I have no way of figuring it out.

    Im seriously going insane. If I install one more thing in Installer and end up at a stuck soft-reset im going to kick my router in half.

  23. #18
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,533
    Thanks
    93
    Thanked 363 Times in 273 Posts

    Just went through 4 restores last night because of this problem.. The easiset upgrade and jaoibreak but I kept bricking the phone trying to get Customize to work in 1.1.4. In teh past when I would get stuck at the apple logo I could not access SSH but I was able to get recovery mode. What I ultimately figured out was that unlike in 1.1.3 where I just did a global 0777 permissions on teh System/Library folder. This was the problem in 1.1.4. No shortcuts setting the permissions so Customize would work. I had to change permissions individually on every file I wanted to change and its parent folder. Evidentally setting the permssions ot 0777 on presumably springboard.plist (?) will cause the phone to not boot.

    Was really wishing for a USB connection that did not require itunes recognition to go in and fix the file. Thankfully the restore and upgrade with Ziphone is fast. Just a bit disconcerting after spending all that time getting the summerboard and customize to work, then rebooting and getting stuck.

    I have everything all working again but and very afraid to reboot the phone. I had thought I had it all working but I got the frozen apple after installing Cydia. No vibrates and no SSH-that may have done something to the phone as well. Think this time I'm making a full backup so I dont have to re-mod everything should I freeze again.

  24. The Following User Says Thank You to bhz1 For This Useful Post:

    zerosimms (03-15-2009)

  25. #19
    try to send the original Springboard.app with the plugin function of ZiPhone to the iPhone.
    Original Springboar.app: http://modmyi.com/forums/downloads.php?do=file&id=131
    ZiPhone: www.ziphone.org

  26. #20
    I've tried that and itunes still will not detect iphone. I cannot put it into restore mode, infact cannot get anything to see it, how do I kick it's ***???? I also can't ssh it as i don't know it's ip address...PPPlease Help

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •