Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Downloading package error! help!

  1. #1
    Default Downloading package error! help!
    Cant download any apps and also getting half installed package error also, the error has two parts and one says subprocess post-removal script returned error. can anyone help?

  2. #2
    Retired Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,023
    Thanks
    1,815
    Thanked 7,065 Times in 4,206 Posts

    Can ya post pics of them please.

  3. #3
    Livin a dream. H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    Michigan
    Posts
    5,856
    Thanks
    63
    Thanked 273 Times in 259 Posts

    Half installed packages have to be removed ASAP. They're basically corrupted. Remove it and try installing another package. It was most likely caused by the repo timing out, or your device not being compatible with it.

  4. #4

  5. #5
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,171
    Thanks
    5,561
    Thanked 12,524 Times in 7,588 Posts

    Quote Originally Posted by nissan4x4 View Post
    Img_0011.png
    You have to either use Photobucket or a photo sharing site, or when posting, go "Advanced" in post reply and use the "attachment" feature.

  6. #6

  7. #7

  8. #8
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,171
    Thanks
    5,561
    Thanked 12,524 Times in 7,588 Posts

    Are you certain this package has been ported to the OS you are on?

    Or, you have restored from a backup and Cydia packages are attaching themselves.
    Sure fix, restore your phone, set up as new, re-jailbreak and start with a fresh OS.

  9. #9
    I'm on whitedoor it's a custom firmware. I installed it because I can download way more stuff because some cydia and app store apps aren't supported for IOS three

  10. #10
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,171
    Thanks
    5,561
    Thanked 12,524 Times in 7,588 Posts

    3? Goodness, why not move up to 5.1.1? So many more features and fixes.

  11. #11
    its the first gen iphone, 2g

  12. #12
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,171
    Thanks
    5,561
    Thanked 12,524 Times in 7,588 Posts

    Oh wow, I still have mine also. Haven't used it in years. You haz a relic my friend. Nice.

  13. #13
    Livin a dream. H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    Michigan
    Posts
    5,856
    Thanks
    63
    Thanked 273 Times in 259 Posts

    I've seen this error before, but never had this myself. Hopefully this guide can help you out: Debian / Ubuntu Package Troubleshooting: subprocess post-removal script returned error exit status xx

  14. #14
    Okay that helps a lot thanks but i dont get this part: In short shell scripts will abort with an error if something fails. To fix this problem visit /var/lib/dpkg/info directory.

    How do i do that?

  15. #15
    Livin a dream. H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    Michigan
    Posts
    5,856
    Thanks
    63
    Thanked 273 Times in 259 Posts

    You must use iFile or another file viewer.

  16. #16
    will terminal work?

  17. #17
    Livin a dream. H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    Michigan
    Posts
    5,856
    Thanks
    63
    Thanked 273 Times in 259 Posts

    Not really as they don't have the shells or scripts for it in Cydia....

    There's other free ones like WinSCP (done from your computer) or if you're on OS X, iFinder.

  18. #18
    I cant download SB Settings or Ifile or ifinder, it wont let me.

  19. #19
    Retired Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,023
    Thanks
    1,815
    Thanked 7,065 Times in 4,206 Posts

    I guess ya firmware may be to old
    It's not letting you do this?

  20. #20
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,171
    Thanks
    5,561
    Thanked 12,524 Times in 7,588 Posts

    ^yup

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •