+ Reply
Page 3 of 3 FirstFirst 123
Results 41 to 59 of 59

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: CydiaStore 'link to my device' won't work

is a discussion within the

Cydia Support

forums, a part of the

Native iPhone / iPod Touch App Discussion

section;
Originally Posted by BlackG35 Ive paid for these apps and I cant even download them. I found another repo on Google that has most of the Cydia store apps for
...
  1. #41
    What's Jailbreak?
    Join Date
    Aug 2008
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by BlackG35 View Post
    Ive paid for these apps and I cant even download them. I found another repo on Google that has most of the Cydia store apps for free.

    It sucks that I had to resort to this, but I had no choice. Hope this all gets sorted out soon.
    I bought them... but this time since I can't link my device, I got the cracked versions. :/

  2. #42
    What's Jailbreak?
    Join Date
    Sep 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I am quite surprised that it has been almost a week now with not so much as even a "hey guys, I'm aware of the problem and working on a fix" from saurik. The fact that we are totally left in the dark here almost makes it seem as though no one really cares nor is anyone even looking into a fix. I'm hopeful this is not the case and we will see a fix soon. I've always supported Cydia and even purchased multiple apps through it. I'd hate to have to turn to alternative methods just to get access to the apps I've already paid for...

  3. #43
    My iPhone is a Part of Me politicalslug's Avatar
    Join Date
    Sep 2007
    Location
    Woodland Hills, CA + Santa Cruz, CA
    Posts
    579
    Thanks
    13
    Thanked 109 Times in 73 Posts

    Thumbs down Saurik speaks... indirectly
    I have been exchanging emails with Phoenix3200 (developer of Music Controls from the cydia store) and he tells me he has spoken to Saurik and that the problem comes from Saurik "adjusting the system that handles multiple devices on a given account", but apparently it still isn't working yet. Still, I haven't had any direct response from saurik, and still I can't link my device with either facebook or google. It looks like I'll have to start a five day trial for the time being. Anyone else having any luck???
    Last edited by politicalslug; 12-02-2009 at 12:09 PM. Reason: email from developer requesting I remove part of my post

  4. The Following User Says Thank You to politicalslug For This Useful Post:

    hobo (12-02-2009)

  5. #44
    What's Jailbreak?
    Join Date
    Aug 2008
    Posts
    5
    Thanks
    3
    Thanked 1 Time in 1 Post
    Just throwing in another "me too", broke my 3G and got a 3GS refurb that came with 3.0.1, upgraded to 3.1.2 & blackra1ned. Thanks posting that update on this situation, politicalslug, hope it is fixed soon.

  6. #45
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Cannot Link Device
    I have 2 3G phones. 1 worked the other did not. It will not link to my account or my wife's account. Need help!

  7. #46
    Developer
    Join Date
    Sep 2007
    Posts
    109
    Thanks
    0
    Thanked 323 Times in 67 Posts

    Default I think this issue is finally fixed! ;P
    Quote Originally Posted by politicalslug View Post
    I have been exchanging emails with Phoenix3200 (developer of Music Controls from the cydia store) and he tells me he has spoken to Saurik and that the problem comes from Saurik "adjusting the system that handles multiple devices on a given account", but apparently it still isn't working yet. Still, I haven't had any direct response from saurik, and still I can't link my device with either facebook or google. It looks like I'll have to start a five day trial for the time being. Anyone else having any luck???
    Actually, either you or Phoenix3200 has a drastic misunderstanding of that exchange. :( The device link mechanism works like iTunes / App Store: you have a limited number of devices that you can link to an account before you need some manual intervention. The only change that has been made to this mechanism was this morning, and it has nothing to do with any of the issues in this thread.

    When I spoke with Phoenix3200, I gave him a decision tree of issues, and the core of the tree was a "too many devices" error. If you are having that, you normally send me an e-mail, and I get around to increasing your limit. Now, I have an automated dampening mechanism that will increase your limit over time in a manner that should keep people from cheating the system /and/ mean I need to process many fewer of these e-mails.

    Therefore, he told you to retry because the issue should have been fixed (I also manually increased your limit to be extra safe while that discussion was going on, as Phoenix wasn't indicating to me that this had nothing to do with having too many devices linked to your account). Obviously, this didn't work, as this simply wasn't your problem. (Thankfully, he then pointed me here, and I was able to read a further description of the issue ;P.)

    I think I /have/ found the core issue behind this, though: over the last week I have been reorganizing the Cydia backend databases, using newer technologies like MongoDB in order to scale to the load/demand: Cydia has millions of active users, and so I run into all kinds of scaling problems that I didn't have to deal with when I had orders of magnitudes fewer requests coming in. Hopefully, these changes /aren't/ being noticed, but if you pay attention you should note that the Cydia home page now never times out, even during the midweekday rush, the little payment related iframes always come in stable-y, etc..

    Unfortunately, this has apparently caused some connections between different tables to break in a way that I wasn't expecting (and wasn't noticing in tests, as all the devices I was testing were "old"). In specific, when I link your device, I normally connect it up with a table that has information on what kind of device it is, and that information is no longer even stored in the same type of database technology, much less on the same server... or even in the same area of the country. ;P

    (I was finally able to notice this because Phoenix gave me your UDID to analyze, and I noticed I couldn't even manually link it.) So, I have modified the link mechanism to, like the TSS scanner, force an old-style device record for the device so it can cause the link. Can you try again?

  8. The Following 4 Users Say Thank You to saurik For This Useful Post:

    jcarroll (12-03-2009), kcinci (12-02-2009), malibubrad (12-03-2009), Philaretus (12-03-2009)

  9. #47
    My iPhone is a Part of Me politicalslug's Avatar
    Join Date
    Sep 2007
    Location
    Woodland Hills, CA + Santa Cruz, CA
    Posts
    579
    Thanks
    13
    Thanked 109 Times in 73 Posts

    Default Fixed!
    I just tried again and it worked!
    Last edited by politicalslug; 12-02-2009 at 09:12 PM.

  10. #48
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default It works
    I have now been able to link and complete my purchase.

  11. #49
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I finally got mine to Link after trying various things over the past couple days. I followed step 2 in the attached URL and copied my ECID to cydia using the Umbrella tool. After that I was able to Link my iPhone.
    [Howto] Setup local 3GS restore verification server (ECID SHSH)

    Hope this helps!!

  12. #50
    iPhone? More like MyPhone
    Join Date
    Jul 2008
    Posts
    220
    Thanks
    6
    Thanked 60 Times in 51 Posts

    Glad to see Saurik's fixed things, and my guess regarding the database changes he's been running in the background caused the problem.

  13. #51
    What's Jailbreak?
    Join Date
    Aug 2008
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by saurik View Post
    Actually, either you or Phoenix3200 has a drastic misunderstanding of that exchange. The device link mechanism works like iTunes / App Store: you have a limited number of devices that you can link to an account before you need some manual intervention. The only change that has been made to this mechanism was this morning, and it has nothing to do with any of the issues in this thread.

    When I spoke with Phoenix3200, I gave him a decision tree of issues, and the core of the tree was a "too many devices" error. If you are having that, you normally send me an e-mail, and I get around to increasing your limit. Now, I have an automated dampening mechanism that will increase your limit over time in a manner that should keep people from cheating the system /and/ mean I need to process many fewer of these e-mails.

    Therefore, he told you to retry because the issue should have been fixed (I also manually increased your limit to be extra safe while that discussion was going on, as Phoenix wasn't indicating to me that this had nothing to do with having too many devices linked to your account). Obviously, this didn't work, as this simply wasn't your problem. (Thankfully, he then pointed me here, and I was able to read a further description of the issue ;P.)

    I think I /have/ found the core issue behind this, though: over the last week I have been reorganizing the Cydia backend databases, using newer technologies like MongoDB in order to scale to the load/demand: Cydia has millions of active users, and so I run into all kinds of scaling problems that I didn't have to deal with when I had orders of magnitudes fewer requests coming in. Hopefully, these changes /aren't/ being noticed, but if you pay attention you should note that the Cydia home page now never times out, even during the midweekday rush, the little payment related iframes always come in stable-y, etc..

    Unfortunately, this has apparently caused some connections between different tables to break in a way that I wasn't expecting (and wasn't noticing in tests, as all the devices I was testing were "old"). In specific, when I link your device, I normally connect it up with a table that has information on what kind of device it is, and that information is no longer even stored in the same type of database technology, much less on the same server... or even in the same area of the country. ;P

    (I was finally able to notice this because Phoenix gave me your UDID to analyze, and I noticed I couldn't even manually link it.) So, I have modified the link mechanism to, like the TSS scanner, force an old-style device record for the device so it can cause the link. Can you try again?
    Thank you Saurik! :-D

  14. #52
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thank you!!!

  15. #53
    What's Jailbreak?
    Join Date
    Sep 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Works now! Thanks for the fix Saurik!

  16. #54
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    4
    Thanks
    0
    Thanked 1 Time in 1 Post
    it's working now. thanks saurik

  17. #55
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    3
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Hey All, I'm new to this. I downloaded the SCREENDIMER app (well tried) and got 2 confirmations back from Amazon saying there was payment to SaurikLLC. I didn't get the app and want to know if the "LINK DEVICE" shows up every time you buy an app! Thanks for any help.
    JmarG

  18. #56
    My iPhone is a Part of Me area51crypto's Avatar
    Join Date
    Sep 2009
    Location
    Heartland of America
    Posts
    953
    Thanks
    464
    Thanked 68 Times in 66 Posts

    Been there tried everything and still nothing!

    I logged in and tried to download the first app, the repo was Big Boss and a window popped up and said I would have to email Saurik to resolve this issue, I did and its been over two weeks and no return email nothing!

    I have had to purchase all may apps again which in my opinion really sucks!

    I hope everybody else has better success but with me it was a total failure!

    On another note it took me less than a minute to transfer my Rock purchases!
    Last edited by area51crypto; 08-13-2010 at 03:51 PM.

  19. #57
    What's Jailbreak?
    Join Date
    Dec 2011
    Location
    hong kong
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Cydia crash - Unable to link my device to Cydia Store, Facebook, Google, or search...
    Quote Originally Posted by saurik View Post
    Actually, either you or Phoenix3200 has a drastic misunderstanding of that exchange. The device link mechanism works like iTunes / App Store: you have a limited number of devices that you can link to an account before you need some manual intervention. The only change that has been made to this mechanism was this morning, and it has nothing to do with any of the issues in this thread.

    When I spoke with Phoenix3200, I gave him a decision tree of issues, and the core of the tree was a "too many devices" error. If you are having that, you normally send me an e-mail, and I get around to increasing your limit. Now, I have an automated dampening mechanism that will increase your limit over time in a manner that should keep people from cheating the system /and/ mean I need to process many fewer of these e-mails.

    Therefore, he told you to retry because the issue should have been fixed (I also manually increased your limit to be extra safe while that discussion was going on, as Phoenix wasn't indicating to me that this had nothing to do with having too many devices linked to your account). Obviously, this didn't work, as this simply wasn't your problem. (Thankfully, he then pointed me here, and I was able to read a further description of the issue ;P.)

    I think I /have/ found the core issue behind this, though: over the last week I have been reorganizing the Cydia backend databases, using newer technologies like MongoDB in order to scale to the load/demand: Cydia has millions of active users, and so I run into all kinds of scaling problems that I didn't have to deal with when I had orders of magnitudes fewer requests coming in. Hopefully, these changes /aren't/ being noticed, but if you pay attention you should note that the Cydia home page now never times out, even during the midweekday rush, the little payment related iframes always come in stable-y, etc..

    Unfortunately, this has apparently caused some connections between different tables to break in a way that I wasn't expecting (and wasn't noticing in tests, as all the devices I was testing were "old"). In specific, when I link your device, I normally connect it up with a table that has information on what kind of device it is, and that information is no longer even stored in the same type of database technology, much less on the same server... or even in the same area of the country. ;P

    (I was finally able to notice this because Phoenix gave me your UDID to analyze, and I noticed I couldn't even manually link it.) So, I have modified the link mechanism to, like the TSS scanner, force an old-style device record for the device so it can cause the link. Can you try again?
    Hi Saurik, I am new to this forum, and am relatively new jb user ( 3GS old bootrom, BB 6.15.0, just upgraded to 5.0.1 , ECID - 3733031764942).
    I experience similar "unable to link to Cydia store, FaceBook, Google, Search link" issue, please help.
    everything else seem to work normal and great.
    thanks.

  20. #58

  21. #59
    Official SaurikIT Support
    Join Date
    Mar 2011
    Location
    Santa Barbara, CA
    Posts
    332
    Thanks
    1
    Thanked 66 Times in 45 Posts

    It's best to email saurik directly ([email protected]) if you have Cydia account problems. Make sure to clearly state the exact problem and include your account ID number.

+ Reply
Page 3 of 3 FirstFirst 123
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts