+ Reply
Page 1 of 4 123 ... LastLast
Results 1 to 20 of 68

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cydia wont launch anymore?

is a discussion within the

Cydia Support

forums, a part of the

Native iPhone / iPod Touch App Discussion

section;
Hi guys, I usually dont ask for help, but I have an odd problem... I jailbroke my 3G yesterday with redsn0w and it worked without a hitch. I spent 3
...
  1. #1
    iPhoneaholic TheOnlyest's Avatar
    Join Date
    Aug 2008
    Location
    Las Vegas
    Posts
    399
    Thanks
    18
    Thanked 96 Times in 55 Posts

    Default Cydia wont launch anymore?
    Hi guys, I usually dont ask for help, but I have an odd problem...
    I jailbroke my 3G yesterday with redsn0w and it worked without a hitch. I spent 3 hours getting my theme back, and ran Cydia about 40 times reinstalling all my Cydia apps.

    Last night I wanted to check into Cydia to see if any 3.0 app updates came through, and Cydia wont launch anymore, I have tapped the icon about 300 times for the last 14 hours, the default screen comes up for about 2 seconds, then crashes back to springboard.

    All the other apps and functions of my phone work fine, but Cydia will not run! I tried disabling all my MobileSubstrate apps using SBSSettings, and every other trick that I know of.

    I really dont want to restore and start all over again, because everything else is working!! Any suggestions?



    UPDATE: (3 hours later)
    Well thanks for all the input guys... If I asked if there was a jailbreak for the 3GS, this would be the most popular thread today.

    I just finished a full restore and jailbreak, tried to launch Cydia, same *&^$##@^@ thing, I have never had these types of issues before.

    I guess i'm stuck with a *#%%$@* stock iPhone from now on...
    Last edited by TheOnlyest; 06-21-2009 at 03:30 PM. Reason: Automerged Doublepost
    Praise the Devs! To each and every one of you who spend your time writing code and making apps for little or no profit... Its YOU that makes the iPhone great, NOT Apple!! From me to you, a million thanks!!

  2. #2
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    17
    Thanks
    5
    Thanked 0 Times in 0 Posts

    I'm pretty sure the same thing is happening to me... last night I updated the MobilSubstrate, Categories, and SBSettings (pretty sure it was those 3) and since then I've not been able to load Cydia....


    anyone have a fix? or maybe a way to manually install icy (via SSH maybe)

  3. #3
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    I found that Cydia opened but froze on the default png (The Sceen that has the gray background with the black buttons but no text and your cannot select anything.) I rebooted and it worked fine. If you are tapping Cydia and it opens then crashes there is 2 possiblities I know of. 1. Back on 2.2.1 about 3 weeks ago I filled my iPod to full no space left. Cydia constantly crashed so I assumed that was the issue. I remove all my videos and sure enough Cydia opened. The other solution is you can apt-remove cydia followed by apt-get cydia that is if you can still SSH. This will remove Cydia and install the latest Cydia that got released sometime today (I just woke up and Cydia Loads Faster than in 2.x.x).

    Hope this helped in some way shape or form. There is always the restore route but for most people they are not a fan of hearing that.

    ~K

    P.S.
    Also since you restored to stock you can still re-jailbreak so I do not understand your Update..... And anyways this place is mad busy. 3.0 came out 5 days ago the jailbreak is out its noobfest and alot of things are happening at once. You are one person in this mix. So thinking you deserve attention immediatly is wasting your breath. Cydia not working is not a super killer. You could have waited for an answer and you could have always installed packages by hand.
    Last edited by kwall; 06-22-2009 at 09:31 AM.

  4. #4
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Cydia
    Well after looking around the forums, its obvious that redsn0w is causing all this mess.

    I had originally jailbroke my iPhone when PwnageTool came out, PwnageTool worked fine but me being a noob decided to restore and jailbreak with redsn0w. A few hours later cydia kept on exiting. So today I restored my phone and Jailbroke with Pwnagetool. It fixed the problem. If you don't have a mac I could get you a custom firmware.

  5. #5
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    ^That is incorrect. I have went a full day with my jailbreak and Cydia only hung once (I ran out a ram). redsn0w is fine I think its the users that use the iPhone or iPod that are at fault.

  6. #6
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by kwall View Post
    ^That is incorrect. I have went a full day with my jailbreak and Cydia only hung once (I ran out a ram). redsn0w is fine I think its the users that use the iPhone or iPod that are at fault.
    Why are we at fault? Do you understand that once we open Cydia, it automatically crashes and exits? I even restored it twice and jailbroke my phone twice using RedSn0w and it still crashed, then I switched to PwnageTool and it worked well.

  7. #7
    What's Jailbreak?
    Join Date
    Jun 2009
    Location
    I'm from Puerto
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts

    ok i think i'm having the same problem. i jailbreak my iphone 3g 3.0 about 5 hours ago. it worked fine, i even downloaded some stuff.
    But now out of no where, when i tap the cydia button or app or whatever you call it, it just get the screen black and does't do anything else. i just hit the home button and it goes back to the home screen. so to the point, everything works except for the cydia button.

    what should i do?? ohh and by the way my english isn't very good since i'm puertorrican. so please be gentle, ahaha

    any help would be welcome.

  8. #8
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by iphone.3333 View Post
    ok i think i'm having the same problem. i jailbreak my iphone 3g 3.0 about 5 hours ago. it worked fine, i even downloaded some stuff.
    But now out of no where, when i tap the cydia button or app or whatever you call it, it just get the screen black and does't do anything else. i just hit the home button and it goes back to the home screen. so to the point, everything works except for the cydia button.

    what should i do?? ohh and by the way my english isn't very good since i'm puertorrican. so please be gentle, ahaha

    any help would be welcome.
    did you use redsn0w?

  9. #9
    Green Apple Bears_Fan's Avatar
    Join Date
    Sep 2008
    Location
    Chicago
    Posts
    65
    Thanks
    12
    Thanked 3 Times in 3 Posts

    I'm having the same problem. I used redsn0w and Cydia wont launch. Like an idiot I never installed SSH. So now I'm SOL and need to re-jailbreak. Thank goodness I didn't modify my phone too much these past couple of days.

  10. #10
    What's Jailbreak?
    Join Date
    Jan 2009
    Location
    Kent
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by Bears_Fan View Post
    I'm having the same problem. I used redsn0w and Cydia wont launch. Like an idiot I never installed SSH. So now I'm SOL and need to re-jailbreak. Thank goodness I didn't modify my phone too much these past couple of days.
    Same here... anyway it's early days so I will restore to stock and wait patiently for the dev team to sort it out... nobody said it would be easy

  11. #11
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    It has been 3 days no problems here. Which redsn0w are you using I am on Windows and have no problems.

  12. #12
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    redsn0w mac

  13. #13
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    It might be a Mac thing, I dunno I have a Mac but all my music is on my PC (too lazy to move it)

  14. #14
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Same-ish issue here. Cydia worked to install about two or three apps and one theme (thank God I can still use Monochrome Agua throughout this :P), and now it crashes before it even gets to the UI. Just loading screen and then nothing. And I'm running Windows, so it's not just a Mac thing.

    I've checked the Cydia.log file for a description of the problem, and here's what it says:


    2009-06-23 22:49:06.708 Cydia_[81:613] WB:Notice: WinterBoard
    cache_.Open():[dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. ]
    2009-06-23 22:49:07.976 Cydia_[81:5503] void WebThreadLockFromAnyThread(), 0x3e6800: Obtaining the web lock from a thread other than the main thread or the web thread. UIKit should not be called from a secondary thread.
    2009-06-23 22:49:08.158 Cydia_[81:5503] bool _WebTryThreadLock(bool), 0x3e6800: Tried to obtain the web lock from a thread other than the main thread or the web thread. This may be a result of calling to UIKit from a secondary thread. Crashing now...

    What does it mean? How do I run 'dpkg--configure -a'? Do I have to have mobileterminal, because I never got around to installing it...And Icy didn't get installed because redsn0w crashed every time I tried jailbreaking with that box checked.

    I just don't want to do a restore if you think it's going to do the same thing next time...

    Thanks in advance!

  15. #15
    iPhoneaholic kwall's Avatar
    Join Date
    May 2008
    Location
    New York
    Posts
    308
    Thanks
    7
    Thanked 40 Times in 32 Posts

    I looks like you had an error while downloading Winterboard. To be perfectly honest I am not informed on dpkg errors. My best guess is the deb Cydia had to download for Winterboard got downloaded corrupted. and in regards to Icy on 3.0 you are not missing anything it only opens fast when you shut updates off, it installs packages with dependencies wrong its all around a terrible app.

  16. #16
    What's Jailbreak?
    Join Date
    Jan 2008
    Posts
    2
    Thanks
    0
    Thanked 10 Times in 1 Post
    I had the exact same problem same log file. I was able to use iphone browser and go to var/lib/dpkg/updates and delete all files in the update folder. Cydia has worked fine since

  17. The Following 10 Users Say Thank You to leroy67 For This Useful Post:

    alyelsherbiny (11-09-2009), exsequor (10-01-2009), Gugmi01 (06-26-2009), imsuperjp (01-29-2010), ItsCyrious (07-31-2009), jjwiz (09-10-2009), Julcabalu (07-18-2009), MB-SL600 (06-28-2009), Sniper366 (06-26-2009), Threatz (12-22-2009)

  18. #17
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Posts
    217
    Thanks
    10
    Thanked 26 Times in 14 Posts

    I didn't know iPhone browser worked on 3.0 yet?

  19. #18
    What's Jailbreak?
    Join Date
    Jan 2008
    Posts
    2
    Thanks
    0
    Thanked 10 Times in 1 Post
    i USED VERSION 1.9.1

  20. #19
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    17
    Thanks
    2
    Thanked 0 Times in 0 Posts

    its not just iphones. i have a 2g touch and i loaded cydia earlier today, it updated something but crashed my ipod halfway through. once it rebooted i tried launchin cydia again up the blank screen appears like you said and it exits. whats goin on?? how do i fix it?

  21. #20
    Green Apple Sniper366's Avatar
    Join Date
    Dec 2007
    Location
    Denver
    Posts
    78
    Thanks
    8
    Thanked 7 Times in 5 Posts

    Quote Originally Posted by leroy67 View Post
    I had the exact same problem same log file. I was able to use iphone browser and go to var/lib/dpkg/updates and delete all files in the update folder. Cydia has worked fine since
    +1 Thank you! This worked!

    I updated to Backgrounder 3.0, and installed BiteSMS and I couldn't launch Cydia anymore. this worked perfectly. Thanks!

  22. The Following User Says Thank You to Sniper366 For This Useful Post:

    Gugmi01 (06-26-2009)

+ Reply
Page 1 of 4 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts