+ Reply
Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Two icons off center

is a discussion within the

Chit Chat

forums, a part of the

ModMyi

section;
Here's my problem: If I use any SummerBoard theme, if it's got square icons it messes up two of them (Currently Mail and YouTube). But if it's got irregular icons,
...
  1. #1
    Retired Moderator Dash-2's Avatar
    Join Date
    Jul 2007
    Location
    Oregon
    Posts
    2,080
    Thanks
    79
    Thanked 222 Times in 184 Posts

    Default Two icons off center
    Here's my problem:
    If I use any SummerBoard theme, if it's got square icons it messes up two of them (Currently Mail and YouTube). But if it's got irregular icons, they are all centered. I've tried moving around still have the problem. Could it be the app?
    Any one know how to fix it?

    Messed up:


    Normal:

  2. #2
    iPhone? More like MyPhone Kitsune's Avatar
    Join Date
    Sep 2007
    Location
    33.57, -86.75
    Posts
    265
    Thanks
    2
    Thanked 30 Times in 30 Posts

    Are you using the newest SummerBoard update? One was released a couple of days ago I think.

  3. #3
    My iPhone is a Part of Me Trent J.'s Avatar
    Join Date
    Sep 2007
    Posts
    955
    Thanks
    15
    Thanked 75 Times in 68 Posts

    Two days ago I believe..

  4. #4
    Retired Moderator Dash-2's Avatar
    Join Date
    Jul 2007
    Location
    Oregon
    Posts
    2,080
    Thanks
    79
    Thanked 222 Times in 184 Posts

    Yep, SummerBoard 2.11

  5. #5
    iPhone? More like MyPhone Kitsune's Avatar
    Join Date
    Sep 2007
    Location
    33.57, -86.75
    Posts
    265
    Thanks
    2
    Thanked 30 Times in 30 Posts

    Honestly, and I may be way off, all I can think of is the image itself has an issue. Maybe with an alpha layer. Sorry I can't be much help.

  6. #6
    iPhone? More like MyPhone
    Join Date
    Jul 2007
    Posts
    132
    Thanks
    6
    Thanked 7 Times in 7 Posts

    Can you post the two images here so I can look at them.

  7. #7
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    upload the .png's manually to the Application folder and rename it to icon.png (replace the old one) ...I think (think) that might fix it.

    It's annoying, but a work around until they patch SummerBoard again... I think the current version bases alignment off the actual icon.png in each App directory even though the file it displays might not necessarily be the same icon.png. for themes in /var/root/Library/SB/Themes i think it might display the actual png located in the /Themes/Icons directory... I've also seen l_icon.png in some App folders, dunno if thats like a temp icon SB places in there, but either way I think the alignment is based off each actual icon.png in the individual App directories, which, if my theory is correct, is obviously a different file. Bug.

    Did anyone actually follow that?

  8. #8
    Green Apple spliket's Avatar
    Join Date
    Aug 2007
    Posts
    81
    Thanks
    5
    Thanked 11 Times in 10 Posts

    there is something weird in summerboard goin on. i think they'll fix it in an update. there have been other threads on it before...and the dev(s) are here on the forums. so, i'm sure they're aware of the issue.
    "Beware the voice without a face."

  9. #9
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I had the same problem, and my guess was something to do with icon sizes. I looked at how they were placed on Spring/Summerboard, and it looked like Summerboard thought the images should've been larger.

    I re-copied the Displayorder plist and that seemed to clear my offset icons (I had about 12 of them, very ugly).

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts