Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: iPhone 3GS 4.2.1 5.13.04: Intermittent "Could not connect to cellular data"

  1. #1
    Default iPhone 3GS 4.2.1 5.13.04: Intermittent "Could not connect to cellular data"
    Hello all,

    I have a minor issue with my 3GS. I occasionally receive a "Could not connect to cellular data network" pop up message in geographical locations where I never had this issue with the older FW 4.0 BB 5.13.04. I do have an unlimited data plan with ATT.

    I restored my phone to jailbroken 4.2.1 using a custom IPSW that preserved the 5.13.04 BB. I setup the phone as new, and even before I installed any apps, I would on occasionally get this notice. I've tried resetting my network settings, and installing/uninstalling ultrasn0w (just in case, even though I'm on ATT) and am still seeing the issue.

    Is that normal? I know that 4.0 reported signal strength differently than the later FWs, so I expected a few drop in bars when I upgraded, but I lose my 3G data connection entirely at least 3-4 times a day and that's in downtown and in my home where I used to get persistent 4-5 bars and 3G on the old firmware. Is it possible the old 5.13.04 baseband and newer 4.2.1 don't play nicely?

    Last edited by Zaied; 2011-03-15 at 11:20 PM.

  2. #2
    My iPhone is a Part of Me
    Join Date
    Dec 2007
    Thanked 77 Times in 74 Posts

    It could be a few other possibilities:
    1) it may be something that the jailbreak did (or didn't do). You might retry the jailbreak or use a different method (preferably after using a stock firmware restore if unlocking isn't absolutely necessary).
    2) Your SIM may not be seated properly or its gold contacts are becoming worn down. This can happen a lot if you swap SIMs and/or phones, but it can happen even with normal wear-and-tear. The 3G & 3GS's SIM slot tends to wear down contacts in a weird way. You might consider getting a replacement SIM if the contacts look bad.
    3) it may be the local network being tinkered with or worked on. Does other at&t iPhones or other at&t devices in that area have similar issues?

    Just some more suggestions to look into.
    Member of the hackint0sh forums.
    HowardForums Member: Haas_Dave

  3. The Following User Says Thank You to GenesisDH For This Useful Post:

    Zaied (2011-03-17)

  4. #3
    Hey thanks for the response

    1) I'm suspecting it's this. Custom FW bundles via Pwnage Tool caused a similar problem back when I had a 3G. Spirit and Jailbreakme never caused this issue on the same 3GS. I unfortunately had to go with custom FW JB this time because I'm travelling overseas next month and also plan to sell the 3GS unlocked when the iPhone 5 comes out.

    2) Good suggestion, all though I've only reseated the SIM card on this phone maybe under 10 times in its entire lifetime. But then again I use my phone for cycling sometimes (inside of a jacket pocket) and what not. Sweat might have gotten into the SIM tray release hole and corroding the contacts. But I should emphasize that I lose 3G/data but not cell signal. ie I'm not getting the "No SIM" or "Searching..." messages in the status bar. So I'm guessing the SIM contacts are fine.

    3) Definitely not seeing it on other iPhones.

    I guess all in all, I usually try my best to avoid Custom FWs. The phone is still very usable, and I can make do for another 3 months until the new iPhone.

    Appreciate the help!
    Last edited by Zaied; 2011-03-17 at 05:40 AM.

  5. #4
    I had this problem a few months ago on my 3GS but it turned out to be a problem with my linkage router actually and not my iPhone.

    Just seen you said in certain geo locations you never had problems so in other words not one specific location. Sorry
    Last edited by Ddevil54r; 2011-05-02 at 04:53 AM. Reason: My bad :\

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts