Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Apple TV 2 iTunes Error While Jailbreaking (Error 1604)

  1. #1
    While jailbreaking my Apple TV 2 while it had firmware 4.4.4, using Seas0nPass; it all went smoothly up until iTunes was about to begin, that is where it gave me the error "Preparing to Update: Could not be restored. Error 1604". I then unplugged it, plugged it back again and held the Menu + Pause/Play buttons and it seemed to be detected by iTunes after that. At this point the light was still blinking. I then unplugged it again and plugged it back in to verify everything is still working. The light was not blinking this time, although iTunes detected the device and is willing to restore the firmware. I did NOT hold Menu + Pause/Play these times though, I thought it would be better to get some advice before I made matters worse. Any suggestions how I can complete this jailbreak? I have the custom firmware file just sitting in My Documents.

    I also noticed this! Which possessively is bypasses the error and continues on with the write, should I be doing this or no? Some help to get myself back on track would be great, thanks.

    Got it working, the device was stuck in DFU mode. I was able to get it working by restarting the device, using iREB (Revision 4) to get the device into a proper fixed DFU mode which wouldn't give me errors. The flashing of the custom firmware worked perfectly from there. My Apple TV is now jailbroken using Seas0nPass. I hope this helps others out there. If anyone is receiving 6xxx errors while the device is in DFU mode and the light is flashing, use iREB.
    Last edited by LegendaryFire; 01-07-2012 at 12:41 AM.

  2. #2
    This worked perfectly thank you.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •