Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: *Help Needed* Apple TV 2 iOS 4.3 Jailbreak

  1. #1
    Default *Help Needed* Apple TV 2 iOS 4.3 Jailbreak
    Alright well here we go. I just purchased an Apple TV 2 last night. The iOS version, as stated in the About section, is 4.3 (8F455). Now here is where it gets interesting. I could not restore the stock firmware because it appears that Apple has stopped signing it (correct me if I am wrong here). So what I did was put the device in DFU mode and used USBVIEWER to find my ECID. I created a custom device and was able to save my SHSH Blobs to Cydia using Tiny Umbrella. The SHSH Blobs saved were 4.3.0 and 4.4.2. Ok so in theory I should be able to set the hosts file and restore the 4.3 firmware, in theory.

    So the next thing I tried to do was use Seas0nPass to flash the custom IPSW file. (I was getting the Device not authorized until I figured a way of saving the SHSH blobs). In conjunction with TinyUmbrella and iTunes when I attempt to restore the Seas0nPass IPSW it sits at Preparing to Restore Apple TV and just sits... and sits... and sits some more until it times out and throws an error, usually -21. People claim it is a bad USB cable. The cable is from my Blackberry Torch and has been used in a total of 3 different outlets and rarely leaves its outlet in my kitchen.

    Next I tried greenpois0n (rc6 and rc6.1). I put the device into DFU mode... click Jailbreak... waited 2+minutes after the jailbreak was "complete" but to no avail. No jailbreak, no greenpois0n. I have tried multiple methods to jailbreak the device using greenpois0n. With the Power Plugged in after being in DFU, no power at all just USB, Power connected after the jailbreak was completed before unplugging the USB. All to no avail.

    My last ditch effort was going to be Sn0wBreeze but it as well uses iTunes for the restore.

    The PC is a Windows 7 32Bit Netbook (Works fine for all my JB needs with my iPad). Something to note that when using iTunes to restore while in DFU mode Windows pops up and says the device will respond faster on a Hi-Speed Port. Oddly enough they are all Hi-Speed ports without any other devices connected.

    I am at a complete loss at what to do and hopefully someone here may have some ideas. I do have an alternate PC that I am going to try tonight my only question is will I need to capture the SHSH blobs again from the device when using TinyUmbrella and iTunes to restore (I don't think I would as it would go to the Cydia server to get them).

    Thanks,
    Matty
    Last edited by mattygdot; 12-06-2011 at 07:41 AM.

  2. #2
    So I hate to bump a thread but I am really at a loss. I tried a different computer with a different USB cable and still nothing. I am able to restore the stock 4.3 iOS but not the custom IPSW.

  3. #3
    I had issues to myself. How do you have it hooked up? Just the usb cable or usb and power cable?

  4. #4
    Quote Originally Posted by Cer0 View Post
    I had issues to myself. How do you have it hooked up? Just the usb cable or usb and power cable?
    Majority of the time I am just using USB (have tried different cables and different computers and also reformatted one from Windows 7 to Windows XP SP3 and still it will not flash the custom IPSW). I have tried hooking the Power up then hooking the USB, holding Menu+Down for 6 seconds till the unit reboots then release and hold Menu+Play/Pause to get into DFU and attempt it that way. Regardless of what I do iTunes simply says Preparing Apple TV for restore and it just sits there.

    I am 100% at a loss now.

  5. #5
    I had similar issue. I bought 3 different USB cables but none worked.. finally ended up needing to use a different computer. The problem came down to something with the USB ports on my iMac. Also I'm pretty sure it's necessary to use the power cable as well for the jb. I know I had it in when I did mine.

  6. #6
    I used Jailbreaking 101 - Seas0nPass : FireCore Support to jailbreak both of my ATV2s. It seems like Seas0npass will automatically restore you to 4.3 for an untethered jailbreak, at least it did for me last night. The hardest part is actually getting your ATV2 into DFU mode. Some have said to use the power cable and the USB, then unplug the power. Although I did do one of mine that way a few months ago, I was able to do both of these by simply holding the Menu&Play/Pause buttons, although I had to hold them for more like 20 seconds before releasing.

    Edit - Seas0npass updated for 4.4.4: http://blog.firecore.com/6434
    Last edited by sprung; 12-30-2011 at 11:38 PM.

  7. #7
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,955
    Thanks
    76
    Thanked 2,758 Times in 2,647 Posts

    To restore to custom fw created by Seas0nPass ,your S0P must be in waiting for dfu mode status

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •