+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Any sucsess jailbreaking you Apple TV 2G?

is a discussion within the

AppleTV

forums, a part of the

Mac Hardware

section;
Has any one got Pwnage Tool to jailbreak your new Apple TV yet? I keep getting error 1600 or 21 everytime I try to restore. I can't seem to get
...
  1. #1
    iPhoneaholic kmmxracer's Avatar
    Join Date
    May 2008
    Location
    Phoenix, AZ
    Posts
    386
    Thanks
    26
    Thanked 39 Times in 34 Posts

    Default Any sucsess jailbreaking you Apple TV 2G?
    Has any one got Pwnage Tool to jailbreak your new Apple TV yet? I keep getting error 1600 or 21 everytime I try to restore.

    I can't seem to get it, and I'm not new to Pwnage Tool by any means. Maybe it's because I'm on an old G4 Quicksilver but who knows???

    Any one have any luck yet?

  2. #2
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    NE Mississippi
    Posts
    381
    Thanks
    7
    Thanked 40 Times in 37 Posts

    Yes, I jb mine yesterday. Got error 21 the first time, but I was running in recovery mode on my Dell 10v. Fixed 10.6.4 and restarted and had 0 problems.

    Logged in via SSH and changed my root and mobile passwords just to check and see that it took.

  3. #3
    iPhone? More like MyPhone
    Join Date
    Dec 2007
    Posts
    137
    Thanks
    4
    Thanked 11 Times in 11 Posts

    I was getting error 1602 until a removed the host file block on Apples signing server. Now I get error 21. I've tried restoring several times with the same results.

  4. #4
    What's Jailbreak?
    Join Date
    Mar 2009
    Location
    Maricopa, AZ
    Posts
    21
    Thanks
    0
    Thanked 25 Times in 6 Posts

    I also kept getting error 21 on my ATV2. So I removed the edit to the /etc/hosts file and did a normal restore to the stock 4.1 ipsw. Since that was successful I put the ATV back into dfu mode and was successful using the ipsw made in PwnageTools. SSH works fine, apt-get install vsftpd installs the sftp server just like on an iphone. Doesn't seem to be much else to do with it right now. I tried editing some files to remove MobileMe and Flikr since I dont use them, but I seem to have just renamed them. Cant wait for a nice UPNP client app for this thing I hate having to keep itunes up on my computer.

  5. #5
    iPhone? More like MyPhone
    Join Date
    Dec 2007
    Posts
    137
    Thanks
    4
    Thanked 11 Times in 11 Posts

    Quote Originally Posted by alertrenegade View Post
    I also kept getting error 21 on my ATV2. So I removed the edit to the /etc/hosts file and did a normal restore to the stock 4.1 ipsw. Since that was successful I put the ATV back into dfu mode and was successful using the ipsw made in PwnageTools. SSH works fine, apt-get install vsftpd installs the sftp server just like on an iphone. Doesn't seem to be much else to do with it right now. I tried editing some files to remove MobileMe and Flikr since I dont use them, but I seem to have just renamed them. Cant wait for a nice UPNP client app for this thing I hate having to keep itunes up on my computer.
    Removing the host file entries gives me error 1600.

  6. #6
    iPhoneaholic kmmxracer's Avatar
    Join Date
    May 2008
    Location
    Phoenix, AZ
    Posts
    386
    Thanks
    26
    Thanked 39 Times in 34 Posts

    Quote Originally Posted by alertrenegade View Post
    I also kept getting error 21 on my ATV2. So I removed the edit to the /etc/hosts file and did a normal restore to the stock 4.1 ipsw. Since that was successful I put the ATV back into dfu mode and was successful using the ipsw made in PwnageTools. SSH works fine, apt-get install vsftpd installs the sftp server just like on an iphone. Doesn't seem to be much else to do with it right now. I tried editing some files to remove MobileMe and Flikr since I dont use them, but I seem to have just renamed them. Cant wait for a nice UPNP client app for this thing I hate having to keep itunes up on my computer.
    What is you Mac set up

    I'm on an old G4 10.5.8
    iTunes 10.0.1

  7. #7
    iPhone? More like MyPhone
    Join Date
    Dec 2007
    Posts
    137
    Thanks
    4
    Thanked 11 Times in 11 Posts

    I'm doing it on a MBP running 10.6.4. I'll try it on my Mac mini running 10.6.4.

  8. #8
    What's Jailbreak?
    Join Date
    Mar 2009
    Location
    Maricopa, AZ
    Posts
    21
    Thanks
    0
    Thanked 25 Times in 6 Posts

    I had success restoring the ATV2 using both my MacBookPro4,1 10.6.4 and my desktop running Windows 7 64 bit. Oddly on the Windows machine iTunes kept giving me error 1600 until I completely removed and reinstalled iTunes. I just reinstalled my OS on the mbp so maybe reinstalling iTunes could be a solution to these error problems.

  9. #9
    iPhone? More like MyPhone
    Join Date
    Dec 2007
    Posts
    137
    Thanks
    4
    Thanked 11 Times in 11 Posts

    Just tried on my Mac mini and it worked just fine. Most likely because it's connected through a USB hub. Forgot that there are issues with it if you don't have a USB hub connected on later versions of OS X 10.6.

  10. #10
    iPhoneaholic kmmxracer's Avatar
    Join Date
    May 2008
    Location
    Phoenix, AZ
    Posts
    386
    Thanks
    26
    Thanked 39 Times in 34 Posts

    Do you have the power cord hooked up to your ATV2 during this whole process?

  11. #11
    iPhone? More like MyPhone
    Join Date
    Dec 2007
    Posts
    137
    Thanks
    4
    Thanked 11 Times in 11 Posts

    Quote Originally Posted by kmmxracer View Post
    Do you have the power cord hooked up to your ATV2 during this whole process?
    No, I had just the USB cable connected to the ATV2 while restoring the jailbroken firmware.

  12. #12
    iPhoneaholic kmmxracer's Avatar
    Join Date
    May 2008
    Location
    Phoenix, AZ
    Posts
    386
    Thanks
    26
    Thanked 39 Times in 34 Posts

    I can not get this thing to Jailbreak for the life of me. I really wish I knew what I am doing wrong? I have tried Pwnage Tool 4.1, 4.1.1 and 4.1.2!!!!

    It has to be my old PowerMac G4

    Has anyone bin able to restore the costume firmware in windows yet??

  13. #13
    What's Jailbreak?
    Join Date
    Jan 2010
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    guys i need to know how to connect my apple tv to my macbook to JB it with pwnage tool

  14. #14
    iPhoneaholic kmmxracer's Avatar
    Join Date
    May 2008
    Location
    Phoenix, AZ
    Posts
    386
    Thanks
    26
    Thanked 39 Times in 34 Posts

    Quote Originally Posted by Yomny View Post
    guys i need to know how to connect my apple tv to my macbook to JB it with pwnage tool
    You need a micro USB cable.

  15. #15
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    2
    Thanks
    1
    Thanked 1 Time in 1 Post
    I have trouble getting my Apple TV recognized by my macbook pro (os x 10.6.4) using a microUSB cable from my WD Passport (the microusb end seems to have 5 pins if thats helpful). It wont show up in either iTunes(10.0.1), pwnage tool(4.1.2)(stuck on "connect device to USB"-DFU-part) or even in System Profiler.

    I have tried lots for different things, for instance both with and without the powercable connected, reboot of my macbook and so on. I also tried to see if my my VM in parallells would recognize that there was anything connected via USB.

    So, Im led to believe that its the microUSB cable I use thats the problem in my case, even though it seems to draw power from my USB just fine if the powercable isnt connected. What do you guys think?

    Another quick question: Do you guys get your Apple TV up as a device in iTunes without it being in DFU (just connected normally), or is it just when it is in DFU?

    Hope you guys can shed some light into what Im doing wrong
    Last edited by zelc0m; 10-23-2010 at 09:24 AM. Reason: Editing in pwnage tool version

  16. The Following User Says Thank You to zelc0m For This Useful Post:

    49ersadong (10-27-2010)

  17. #16
    iPhoneaholic kmmxracer's Avatar
    Join Date
    May 2008
    Location
    Phoenix, AZ
    Posts
    386
    Thanks
    26
    Thanked 39 Times in 34 Posts

    I wonder if the number of pins in the micro USB cords matter?

  18. The Following User Says Thank You to kmmxracer For This Useful Post:

    zelc0m (10-23-2010)

  19. #17
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    NE Mississippi
    Posts
    381
    Thanks
    7
    Thanked 40 Times in 37 Posts

    Previously mentioned on twitter that it's a 4 pin. I counted 5 in a blackberry cable that I used. I tried to get clarification on the technical differences in a previous thread but it was mostly unhelpful.

  20. #18
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    NE Mississippi
    Posts
    381
    Thanks
    7
    Thanked 40 Times in 37 Posts

    Zelc0m, does tinyumbrella see it? Try hooking up power and hdmi, let it boot, then remove hdmi and attach microUSB.

    I ran Pwnage with microUSB only I think.

  21. #19
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    2
    Thanks
    1
    Thanked 1 Time in 1 Post
    Quote Originally Posted by z6joker9 View Post
    Zelc0m, does tinyumbrella see it? Try hooking up power and hdmi, let it boot, then remove hdmi and attach microUSB.

    I ran Pwnage with microUSB only I think.
    Thanks for the tip, but sadly it didn't work (tinyumbrella didn't see it either, and the with-hdmi-boot didn't make any difference) :-/

    Well, I think I just have to get hold of another microusb (4 pin) to test out. - But if anyone have some other ideas I'm still interested!

    Update: Tried it on my girlfriends Windowsmachine as well, and no luck on recognizing the device in iTunes (nothing in devicemanager either), so a new cable seems like the only option.

    Arh, almost forgot; do you guys get your aTV up in iTunes no matter what state it is in? (DFU, recovery, normal?) Or only in DFU?
    Last edited by zelc0m; 10-23-2010 at 11:57 AM. Reason: DFU-part + update

  22. #20
    iPhone? More like MyPhone
    Join Date
    Dec 2007
    Posts
    137
    Thanks
    4
    Thanked 11 Times in 11 Posts

    Quote Originally Posted by z6joker9 View Post
    Previously mentioned on twitter that it's a 4 pin. I counted 5 in a blackberry cable that I used. I tried to get clarification on the technical differences in a previous thread but it was mostly unhelpful.
    The cable I used appears to have 5 pins also and it worked fine. I believe what MuscleNerd was refering to in his post was that it requires Micro USB, not Mini USB.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts