+ Reply
Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Stock Mail.app DELETE button not working

is a discussion within the

Apple AppStore App Discussion

forums, a part of the

3rd Party Apps For iPhone | iPod Touch

section;
This is crazy I know. Today I woke up and found the delete button (trash icon) available when viewing an email message no longer works!! The other buttons (refresh, move
...
  1. #1
    Mes
    Mes is offline
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,025
    Thanks
    102
    Thanked 788 Times in 731 Posts

    Default Stock Mail.app DELETE button not working
    This is crazy I know. Today I woke up and found the delete button (trash icon) available when viewing an email message no longer works!! The other buttons (refresh, move to folder, reply/forward, write) function like expected --- it's just the trash icon (delete button) that stopped working. I checked my other accounts (3 others 2ea POP, 2ea IMAP) and sure enough, delete doesn't work either. I can 'delete all' from the trash folder and delete individual selected messages. So everything isn't broken Reboot/respring doesn't help. I haven't added or upgraded anything in about a week or so. It definitely worked yesterday!!

    If I must, I'll delete all the mail accounts and re-enter again --- and then take the final restore plunge. But all-this seems like a huge overkill.

    Any suggestions?

    3G, FW3.1.2, 4.26.xxBB + ultrasn0w T-Mobile USA

  2. #2
    Super Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    13,999
    Thanks
    388
    Thanked 1,141 Times in 891 Posts

    And it isn't a dead spot in the touch screen? Just asking.

  3. #3
    Mes
    Mes is offline
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,025
    Thanks
    102
    Thanked 788 Times in 731 Posts

    Quote Originally Posted by cerote View Post
    And it isn't a dead spot in the touch screen? Just asking.
    Didn't think about that . (Boy I must getting old (aka younger)

    But no, it's not a dead spot. The Photo and Calendar app have buttons in exactly the same place. Not sure if it matters, but the Trash icon is 'highlighted' when I press it, but nothing else happens.

    SOLUTION: I used WinSCP to check /private/var/mobile/library/Mail permissions and ownership. Ownership was set correctly (mobile:mobile) and all of the file permissions were set to 744. The directories were set to 740 (no read access for others). So I recursively set everything to 744 and it worked. Granting read access to others fixed it? Crazy Mail.app I know but it's working now.
    Last edited by Mes; 07-07-2010 at 09:27 PM. Reason: Solution (I hope)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts