Hi, running 4.2.1 on a 3G. I had Google+ until I recently had to restore and found out that the newer version I had in iTunes was no longer compatible. Anyone still got an .ipa that works with 4.2.1? Thanks! If not, oh well. Come on September 12th!