+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3GS Downgrade iOS 6.0 to iOS 4.1

is a discussion within the

3G[S] Downgrading

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
Hey there guys. I wanted to downgrade my tethered jailbroken iPhone 3GS to iOS 5.1.1. As I had the saved SHSH blobs for 4.1 i decide to first downgrade to
...
  1. #1
    What's Jailbreak?
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question 3GS Downgrade iOS 6.0 to iOS 4.1
    Hey there guys. I wanted to downgrade my tethered jailbroken iPhone 3GS to iOS 5.1.1. As I had the saved SHSH blobs for 4.1 i decide to first downgrade to 4.1 then go to 5.1.1. I tried downgrading to 4.1 using this link: iOS 6 Jailbreak: How To Downgrade iOS 6.0.1 To iOS 5.1.1 Using Redsn0w On A4 Devices [Tutorial].
    I tried it he first time and i go a message saying expolit failed. Then i tried i numerous times, downloaded tiny umbrella. Finally it started to begin the process. It contacted apple's servers, then said please wait. Just as the progress bar came on my iPhone it gave an error message saying itunes error 28 and my phone is in an infinite restart loop. Now, I have found out that his error 28 happen's when either your usb cables are damaged or you have to try different USB ports. I tried everyhing, I even tried on a different computer, but it kept giving me the same error message. Now, I know this error mainly happens when there is a problem in the motherboard and that happens when there is physical damage to the iPhone but I have never once dropped he phone into water or caused any physical damage to i. Please give me a solution to his problem.

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Well you won't be able to go to 5.1.1 unless you have 5.1.1 SHSH. Your error 28 might be related to your battery. You should be able to use redsnow's fix recovery option to boot the phone up after getting that error.

  3. #3
    What's Jailbreak?
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thanks for replying Simon. So i went to restore and i upgraded to ios 6.0.1. Now the phone boots up but still when i go to itunes and select my custom firmware, it does some stuff then it comes to please wait and says error 28. How do I fix error 28. Note: I run Tiny umbrella 6.01.01 side by side as well.

  4. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    What custom firmware?

  5. #5
    What's Jailbreak?
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    4.1_8B117_Restore.ipsw

  6. #6
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Why are you trying to go to 4.1?

  7. #7
    What's Jailbreak?
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I plan on going to 4.1 then restoring to 5.1. After reading a few forums I found out I would have to remove my battery from the iphone or drain the battery. I am going to completely drain my battery and leave the phone for 10 hours and try again. Shall report back about success or failure.

  8. #8
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Restoring to 4.1 will not help you get to 5.1.1.
    You have two ways to get to 5.1.1.
    1: you have 5.1.1 shsh
    Or
    2: you have an old bootrom 3GS

    If you don't meet 1 of those two requirements you can't go to 5.1.1.

  9. #9
    What's Jailbreak?
    Join Date
    Jan 2013
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    how do i check if i have an old or new bootrom 3gs?
    EDIT: Damn, just checked out I have the newer version of bootrom Must be the reason.
    Last edited by jdgreat4; 01-11-2013 at 07:41 PM.

  10. #10
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    idetector can tell you. Or you can manually check depending if you are on windows or Mac.

  11. #11
    ihf
    ihf is offline
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Downgrading from 6.15 and ios 6.1
    I have a jailbroken 3GS with baseband 6.15 that I made the mistake of upgrading to 6.1. Now I am stuck at the activation stage. From what I have read, I need to downgrade the baseband to 5.13.04. However, when I tried to use the latest version of Redsn0w using the .ipsw for 6.1, it says that 6.1 .ipsw is not supported. My first question is whether I am following the right path in using Redsn0w to downgrade the baseband in order to get the phone to be usable again? If yes, then do I just have to be patient until Redsn0w is upgraded to accept a 6.1 ipsw? If the answer to Q1 is no, then is there a way to restore my phone to a state that will permit activation?

    Thanks in advance.
    Last edited by ihf; 02-05-2013 at 07:45 AM. Reason: typo

  12. #12
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Quote Originally Posted by ihf View Post
    I have a jailbroken 3GS with baseband 6.15 that I made the mistake of upgrading to 6.1. Now I am stuck at the activation stage. From what I have read, I need to downgrade the baseband to 5.13.04. However, when I tried to use the latest version of Redsn0w using the .ipsw for 6.1, it says that 6.1 .ipsw is not supported. My first question is whether I am following the right path in using Redsn0w to downgrade the baseband in order to get the phone to be usable again? If yes, then do I just have to be patient until Redsn0w is upgraded to accept a 6.1 ipsw? If the answer to Q1 is no, then is there a way to restore my phone to a state that will permit activation?

    Thanks in advance.
    You have to point redsnow to a 6.0 firwmare for it to work.

  13. #13
    ihf
    ihf is offline
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by Simon View Post
    You have to point redsnow to a 6.0 firwmare for it to work.
    I mistyped the subject in my post (it is correct in the body). I upgraded to 6.1 (not 6.0) so I assume that means I need the 6.1 ipsw which does not seem to be supported by Redsn0w.

    I tried using the 6.0 ipsw and it worked. Yay...back to a usable phone 6.1 and 05.13.04
    Last edited by ihf; 02-05-2013 at 09:18 AM.

  14. #14
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Yup, even on 6.1 you have to use 6.0 firmware with redsnow. At least until redsnow is updated to recognize 6.1 firmware.

  15. #15
    ihf
    ihf is offline
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Evasi0n says the phone is jailbroken but no Cydia
    After getting the 3GS back to 6.1 and BB 5.13.04, I tried to use Evasi0n but it says the phone is already JB; however there is no Cydia on there. What to do?

  16. #16
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Have you tried installing cydia with redsnow?

  17. #17
    ihf
    ihf is offline
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Reinstalling Cydia
    Yes, I just tried running Redsn0w and only checking Install Cydia. It ran but there is still no Cydia. Evasi0n says it is JB and does not recommend running it again. So I theoretically have the 3GS JB with 6.1 but can't get to Cydia.

  18. #18
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Easiest thing to do would be to use snowbreeze to make a custom 6.1: iH8sn0w.com

    Restore to that custom firmware in itunes and you should be fine. it will preserve your 5.13.04 baseband as well.

  19. #19
    What's Jailbreak?
    Join Date
    Apr 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by ihf View Post
    I mistyped the subject in my post (it is correct in the body). I upgraded to 6.1 (not 6.0) so I assume that means I need the 6.1 ipsw which does not seem to be supported by Redsn0w.

    I tried using the 6.0 ipsw and it worked. Yay...back to a usable phone 6.1 and 05.13.04
    Hello. I have the same problem. I had bought a used ipHone 3GS with 4.1 which i bought from a local shop. The shop guy said that it is factory unlocked and i can upgrade to any OS version without any problem. So since it was a used phone i restored it using iTunes and it automatically upgrading me to 6.1. Now when i am trying to activate the phone using Wifi I am getting error saying that the phone cannot be activated as the activation server cannot be accessed. Any ideas what should i do?

    Also could you please explain what do you mean downgrading the baseband? Will appreciate any kind of help as I am stuck with an unusable phone now.

  20. #20
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,343
    Thanks
    6,715
    Thanked 15,020 Times in 6,926 Posts

    Quote Originally Posted by rnathbatra View Post
    Hello. I have the same problem. I had bought a used ipHone 3GS with 4.1 which i bought from a local shop. The shop guy said that it is factory unlocked and i can upgrade to any OS version without any problem. So since it was a used phone i restored it using iTunes and it automatically upgrading me to 6.1. Now when i am trying to activate the phone using Wifi I am getting error saying that the phone cannot be activated as the activation server cannot be accessed. Any ideas what should i do?

    Also could you please explain what do you mean downgrading the baseband? Will appreciate any kind of help as I am stuck with an unusable phone now.
    First use f0recast to find out what your baseband/modem firmware is.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts