+ Reply
Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3G jailbreak and carrier unlock help please.

is a discussion within the

3G[S] Downgrading

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
Hi all, I have a jailbroken 3G on version 3.1.3 Baseband version 05.12.01 Most of the apps coming out now require 4.0 or 4.2.1 as a minimum so I would
...
  1. #1
    What's Jailbreak?
    Join Date
    Jan 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default 3G jailbreak and carrier unlock help please.
    Hi all,

    I have a jailbroken 3G on version 3.1.3 Baseband version 05.12.01
    Most of the apps coming out now require 4.0 or 4.2.1 as a minimum so I would like to update to 4.2.1.

    Can anyone tell me if I will be able to unlock my phone to any sim if I do indeed upgrade to 4.2.1 and jail break it.

    Would I need the carrier sim to unlock my 3G to any sim?

    Many thanks,

    -Paul


    Apologies, I just realised where I posted this. In the wrong section.

    Could a mod please move this topic to the correct section?

    Sorry :/
    Last edited by sheffieldlad; 01-17-2012 at 01:39 PM. Reason: I'm dumb...

  2. #2
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,921
    Thanks
    76
    Thanked 2,751 Times in 2,641 Posts

    Download snowbreeze 2.9 and build your custom firmware of 4.2.1 , when finished you will be ask to put iphone into pwned dfu . Once you in dfu mode, run iTunes , shift + restore to this cfw of 4.2.1. Search for Ultrasnow , install it to unlock.

  3. #3
    Green Apple
    Join Date
    Jan 2012
    Posts
    55
    Thanks
    3
    Thanked 8 Times in 8 Posts

    3.1.3 is the best and most stable firmware for iPhone 3G.

    If you still going to update to 4.2.1 make sure you preserved Baseband either with sn0wbreeze or reds0w.
    Last edited by tacoma96; 01-18-2012 at 01:59 AM.

  4. #4
    What's Jailbreak?
    Join Date
    Jan 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by tacoma96 View Post
    3.1.3 is the best and most stable firmware for iPhone 3G.

    If you still going to update to 4.2.1 make sure you preserved Baseband either with sn0wbreeze or reds0w.
    Thanks for the replies, appreciate it.

    As I explained, I want to upgrade cos most of the apps I want to run are 4.0 or above only. Some are 4.2.1 I can't even install Twitter....

    Will preserving my baseband allow me to downgrade back to my current firmware or enable me to unlock after I jailbreak 4.2.1?

    Will I need the carrier aim to unlock to all sims?

    Many thanks

  5. #5
    My iPhone is a Part of Me Susty's Avatar
    Join Date
    Sep 2011
    Location
    Europe
    Posts
    785
    Thanks
    9
    Thanked 100 Times in 99 Posts

    Preserving your baseband will mean that you can unlock it to any carrier using Ultrasn0w (which is in the Cydia install).

  6. #6
    Green Apple
    Join Date
    Jan 2012
    Posts
    55
    Thanks
    3
    Thanked 8 Times in 8 Posts

    Quote Originally Posted by sheffieldlad View Post
    Thanks for the replies, appreciate it.

    As I explained, I want to upgrade cos most of the apps I want to run are 4.0 or above only. Some are 4.2.1 I can't even install Twitter....

    Will preserving my baseband allow me to downgrade back to my current firmware or enable me to unlock after I jailbreak 4.2.1?

    Will I need the carrier aim to unlock to all sims?

    Many thanks
    Preserving your baseband for ultras0w to works. Work on all sims, but you can always go back to to 3.1.3 if your have SHSH saved. I presume your SHSH saved cause your device is jailbroken.

    Use sn0wbreeze to make BB preserve custom firmware if you have Windows.

    If you need any help of jailbreak or unlock go to iClarified for tutorial.

  7. #7
    Livin the iPhone Life xboxbml's Avatar
    Join Date
    Apr 2011
    Location
    US-MI
    Posts
    1,271
    Thanks
    0
    Thanked 64 Times in 61 Posts

    Don't need shsh for 3G fir 3.x...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts