Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Trying to restore 3GS back to it's original baseband and firmware

  1. #1
    Unhappy Trying to restore 3GS back to it's original baseband and firmware
    Hi guys,

    Here's a little back story for this phone. My brother got given this phone to him but because it was locked to o2 only, I had to jailbreak it, change the baseband to 6.15 and use UltraSn0w to allow him to use his Orange sim.
    Now he's got the 4S and we want to give this phone to our mother, where she's on o2. So I figured I'd restore it fresh but totally forgot about the baseband problems etc.

    Now I've been trying lots of different techniques to get it to restore.
    I tried restoring using custom ipsw created with sn0wbreeze
    I tried modifying the hosts file
    I tried to use tinyumbrella (Error 2005 when TSS Server is on & error 3194 when its off and made sure the Set Hosts to Cydia on Exit is unticked)

    I'd love it if you guys could take me through fixing it step by step. I would be very appreciative if you could help me.

  2. #2
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Here's the basics you need to know:

    1) 4.1 is still being signed by Apple for the 3GS (meaning no SHSHs are needed to do this restore) and it just so happens that's the firmware cutoff where you can still use a stock firmware with the 6.15.00 baseband, so restoring to a clean 4.1 is possible.
    2) That baseband isn't going to change, once you go up to 6.15.00 it stays that way.

    Here's what you do if you're wanting an original unjailbroken restore:

    1) Download stock 4.1 ipsw
    2) Open iTunes, hold shift click restore, select 4.1 ipsw
    3) Get error 1013
    4) Get TinyUmbrella, open it and click "exit recovery"
    5) Device will reboot and show the emergency call screen
    6) Activate in iTunes with official SIM card the phone is locked to.

  3. #3
    I've tried restoring to v4.x without tiny umbrella but I get device not eligible messages, and using tiny Umbrella to try a restore to a version (4.3.3) I *do* have SHSHs for has failed magnificently. So I'm still stuck.

    Would this work for me to restore to 4.1 on mine, which is updated to iOS5, BB 5.16.05?

  4. #4
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Can't just be 4.x without TU. Can only be 4.1.

  5. #5
    Quote Originally Posted by i.Annie View Post
    Can't just be 4.x without TU. Can only be 4.1.
    Yes I understand that, but what I'd like to know is, do you think it will work to get my phone to 4.1, when i have the 5.16.05 baseband? I dont need unlocks or jailbreaks. I'm doing this only because there is one app I want and need that doesnt look like its going to be updated to work with iOS5.

    [Edit] Never mind. Tried it, got error 20 and the connect to itunes logo. Kicked out of recovery and am almost resigned to remaining on iOS5 for the forseeable future.
    Last edited by kyteflyer; 10-22-2011 at 08:31 PM.

  6. #6
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    It should work fine to restore to 4.1.

    If you have used TU before, you want to ensure that you have unchecked the box under Advanced options to point to Cydia on exit. Close TU, then open iTunes and do the shift+restore to a stock firmware.

    Error 20 I think generally can be fixed if you try to restore in DFU mode. So try setting into DFU mode first then attempt the restore to stock 4.1 with the above instructions I outlined.

  7. The Following User Says Thank You to i.Annie For This Useful Post:

    kyteflyer (10-23-2011)

  8. #7
    Quote Originally Posted by i.Annie View Post

    Error 20 I think generally can be fixed if you try to restore in DFU mode. So try setting into DFU mode first then attempt the restore to stock 4.1 with the above instructions I outlined.
    Thank you, I'll give that a try now

    [edit #1] Nope. Got the connect to itunes screen straight after the restore (almost) finished then Error 1015. No error 1013 at all. Followed your instructions to the letter. Tiny Umbrella unable to kick out of recovery, and itunes autostarts (even though I have itunes helper disabled) and finds it in recovery again. I can't seem to get it into DFU mode whilst connected to the computer. I'm sure I saw someone else in the forum with error 1015 so will look for that post to see if there was a solution that doesnt (yet) involve a restore to iOS5... again. Sighh.

    [edit #2] CRIKEY! I just nearly gave up but looked at some of the error message meanings at Apple. Anyway, I figured, since I was stuck in recovery, there was absolutely no harm in trying to restore with the one and only custom firmware that I have (4.3.3)... that failed with an error 21, but it booted me back to the connect to itunes screen, but *this* time I also got the emergency call only screen *and* was able to activate. I'm on 4.1, and unlocked. Amazing. a roundabout way of getting there, but its done. I think I'll sit tight on 4.1 for a while, I've been doing this for days and the rest of the world is passing me by

    Thanks again, i.Annie
    Last edited by kyteflyer; 10-22-2011 at 11:58 PM. Reason: numbering the edits.

  9. #8
    4.1 went on properly but I think I'm screwed because I don't have the original sim for this phone so I can't get through activation.

    Thanks for the help anyway.



    Edit: I have iOS 5 snowbreeze on now and trying to bypass activation (not sure how so far).

    Edit 2: Managed to bypass activation. Unfortunately no service found even with UltraSn0w.
    Last edited by michaelkc86; 10-23-2011 at 09:01 AM.

  10. #9
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Quote Originally Posted by kyteflyer View Post
    Thanks again, i.Annie
    No problem!

    Quote Originally Posted by michaelkc86 View Post
    4.1 went on properly but I think I'm screwed because I don't have the original sim for this phone so I can't get through activation.

    Thanks for the help anyway.



    Edit: I have iOS 5 snowbreeze on now and trying to bypass activation (not sure how so far).

    Edit 2: Managed to bypass activation. Unfortunately no service found even with UltraSn0w.
    What's the baseband
    Last edited by i.Annie; 10-23-2011 at 10:24 AM.

  11. #10
    6.15, I've just managed to sort it out using Redsn0w. Apparently because we tried restoring it to ios5 before, it 'corrupted' the baseband. So I had to use Redsn0w to create the ipsw and flash the baseband again. It went through perfectly and my mam's sim is showing up without using ultrasn0w.

    Thanks for any help given before guys.

  12. #11
    Quote Originally Posted by michaelkc86 View Post
    6.15, I've just managed to sort it out using Redsn0w. Apparently because we tried restoring it to ios5 before, it 'corrupted' the baseband. So I had to use Redsn0w to create the ipsw and flash the baseband again. It went through perfectly and my mam's sim is showing up without using ultrasn0w.

    Thanks for any help given before guys.
    dude, I'm stuck in a similar situation, can you help me out? Which version of Redsn0w did you use to reflash the baseband? Could you please give me short directions how you did it?

    Thanks in advance!

  13. #12
    Sure wajezus. I did a bunch of things but in the end this is what worked for me.

    - I downloaded the ipsw for iPhone ios
    - Download Redsn0w 0.9.9b6 - https://sites.google.com/a/iphone-de...edirects=0&d=1
    - Open Redsn0w, click extras and select IPSW, browse for that ipsw you just downloaded.
    - Click back then click Jailbreak
    - Follow instructions and then on Redsn0w it'll have a tickbox for iPad Baseband.
    - Then I let the phone do it's thing and when it finished I was able to get through with no problem.

    I might've effected some things previously cause I've tried A LOT of techniques, I've probably done more damage than good

  14. #13
    Thanks, Michael,

    everything worked like charm until I got this message on the phone:

    "AppleBaseband: Could not find mux function"

    And then it keeps complaining how it failed to get AppleSL8920XARM7M.. Any idea what that means?

  15. #14
    Hi, here is a workaround for your situation... unfortunately it involves upgrading the BB to 06.15.00, which means the GPS functionality will be lost. IMHO, despite this limitation, the phone falls back on the cell signal triangulation method which is pretty accurate for most trivial applications.

    Situation A: If you must have untethered Jailbreak, your only hope is to go to iOS 4.1
    Step 1: Download and install stock 4.1 IPSW
    Step 2: Install the Jailbreak and 06.15.00 Baseband (BB) by using Redsn0w 0.9.9b5
    redsn0w_win_0.9.6b5.zip

    Situation B: If you can live with a tethered Jailbreak, you can go up to iOS 5. After all the above steps, use sn0wbreeze, and install Ultrasn0w (via Cydia) as outlined here:
    Preserve iPhone 4, 3GS Baseband on iOS 5 Sn0wBreeze [Windows] | iJailbreak.com
    Last edited by suhail911; 10-31-2011 at 01:07 AM. Reason: Additional information

  16. #15
    Default Can't factory restore
    I have an iphone 3gs 4.3.5 on 05.16.02

    I jailbroke the device. Realized it was tethered, and I wanted to just go back to square 1. I want it to be factory completely clean wipe.

    I tried it from the phone, general>reset>erase all content and settings.
    It stayed on the screen with the little white circle going around in circles for about 3 hours.

    I tried it from itunes. I tried just clicking restore. It tells me I am ineligible.

    I tried downloading the 4.3.5 ipsw and restoring it by option clicking on restore and selecting it.

    I just want to go back to out of box state. Any ideas why I am ineligible?

  17. #16
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,955
    Thanks
    76
    Thanked 2,758 Times in 2,647 Posts

    You can go back by restoring to custom firmware of 4.1 without any known blob.

  18. #17
    I get error 20 when I do that.

  19. #18
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,955
    Thanks
    76
    Thanked 2,758 Times in 2,647 Posts

    Have you put your iphone into pwned dfu mode first b4 restoring to cfw

  20. #19
    now i'm getting error 1015 stuck on the connect to itunes screen. i have tiny umbrella. when i click... exit recovery, it kicks out, and goes back.

    thank you for the advice. it worked! i am back to 4.1!!!!
    Last edited by mikbsirhc; 11-12-2011 at 01:30 PM.

  21. #20
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,955
    Thanks
    76
    Thanked 2,758 Times in 2,647 Posts

    Are you getting any signal ?

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •