+ Reply
Results 1 to 20 of 20

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgrading to 3.1.3

is a discussion within the

3G[S] Downgrading

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I need help on upgrading to 3.1.3, i have iphone 3gs and firmware 3.0.1, it is already jailbroken but i need the firmware to be higher to download **********, with
...
  1. #1
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Upgrading to 3.1.3
    I need help on upgrading to 3.1.3, i have iphone 3gs and firmware 3.0.1, it is already jailbroken but i need the firmware to be higher to download **********, with itunes error i cant upgrade or restore it. even if the firmware is 3.1.2, i just need help with installing those firmware with one of those 2

  2. #2
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,940
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    No piracy talk is allowed, you will not get any help from here.

    You should buy your apps, not steal it from the net.

    If you just want to upgrade, I can help you
    Last edited by iYeow; 10-15-2010 at 03:07 PM.

  3. #3
    Developing Developer moon#pie's Avatar
    Join Date
    Jan 2010
    Posts
    5,215
    Thanks
    781
    Thanked 372 Times in 307 Posts

    no cracked apps talk. Pirate one more app and I'll sink your mother firggin' ship!


    Twitter: @tshoults

  4. #4
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    sure thanks

  5. #5
    Livin the i raduga's Avatar
    Join Date
    May 2009
    Posts
    1,631
    Thanks
    228
    Thanked 94 Times in 85 Posts

    Quote Originally Posted by vietanime View Post
    I need help on upgrading to 3.1.3, i have iphone 3gs and firmware 3.0.1, it is already jailbroken but i need the firmware to be higher to download **********, with itunes error i cant upgrade or restore it. even if the firmware is 3.1.2, i just need help with installing those firmware with one of those 2
    haiku:

    you have new boot-rom?
    and have no SHSH?
    let me shed a tear

  6. #6
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    unless u know how to jailbreak 4.1

  7. #7
    Livin the i raduga's Avatar
    Join Date
    May 2009
    Posts
    1,631
    Thanks
    228
    Thanked 94 Times in 85 Posts

    Quote Originally Posted by vietanime View Post
    unless u know how to jailbreak 4.1
    hard to say for sure
    pick your pois0n carefully
    maybe it will ra1n?

  8. #8
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by raduga View Post
    haiku:

    you have new boot-rom?
    and have no SHSH?
    let me shed a tear
    i just had an iphone 2 days ago, how m i suppose to know all this stuff

  9. #9
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,940
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    Give me your first 5 serial number starting from the left.

  10. #10
    Developing Developer moon#pie's Avatar
    Join Date
    Jan 2010
    Posts
    5,215
    Thanks
    781
    Thanked 372 Times in 307 Posts

    Quote Originally Posted by vietanime View Post
    i just had an iphone 2 days ago, how m i suppose to know all this stuff
    don't use cracked apps. it is illegal. buy your mother figgin' apps!


    Twitter: @tshoults

  11. #11
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    85936

  12. #12
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,940
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    Good, that is the oldbootrom

    I want you to restore to 3.1.2 and then jailbreak with Redsn0w 0.9.4 first.
    Run Notepad as Admin , open up hosts file and add this line :
    C windows\system32\drivers\etc\hosts
    74.208.10.249 gs.apple.com
    save it and reboots your pc
    Now do the Shift + Restore 3.1.2
    Once restored, run redsn0w 0.9.4

    Edit if 3.1.2, doesn't let you restore, restore to 3.1.3
    The later part, I can get you to jailbroken 4.1

    Edit : If you can shift + Restore to 4.0.1, then acivate it with your valid sim and use jailbreakme.com to jailrbeak.
    After which install jbme2pwn from Cydia , it is an added repo.
    Ony then you can restore to custom firmware of 4.1
    Last edited by iYeow; 10-15-2010 at 06:46 PM. Reason: Automerged Doublepost

  13. The Following User Says Thank You to iYeow For This Useful Post:

    raduga (10-15-2010)

  14. #13
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    i couldnt do it, it said error

  15. #14
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,940
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    What error ?

  16. #15
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    the 3194 error

  17. #16
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,940
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    Ir means that you don't have shsh blogs.

  18. #17
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    how do i get it

  19. #18
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,940
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    Use Tiny Umbrella to get it from Cydia, only if it is in Cydia.

  20. #19
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    how do i use tiny umbrella

  21. #20
    Livin the i raduga's Avatar
    Join Date
    May 2009
    Posts
    1,631
    Thanks
    228
    Thanked 94 Times in 85 Posts

    Quote Originally Posted by vietanime View Post
    how do i use tiny umbrella
    You can't.
    At least, not for what you want.

    Apple uses a hashing / signature to block you from installing old (exploitable) firmware. TinyUmbrella gets around that, by letting you save personalized SHSH blobs but only during the time when Apple is still signing a given firmware revision.

    You can get the umbrella here - using it should be clear enough.
    http://thefirmwareumbrella.blogspot.com/

    If you saved 3.1.2 blobs, way back when, THEN you could restore to 3.1.2 today, using your blobs. Since you probably didn't, the only blobs you can actually get are 4.1 (which is current). It wouldn't be a bad idea to save your 4.1 SHSH blobs, but that isn't necessary for you just yet.

    _________

    Fortunately, there is a jailbreak for 4.1 already.
    Thanks to GeoHot - limera1n

    How to Jailbreak Firmware 4.1 iPhone 3GS/4, iPad, iPod Touch 3G/4G with limera1n

    There are a few caveats you ought to be aware of:
    it gets trickier on an iPhone, because you also need to preserve a h4xable baseband. If you're not using AT&T, you may also need an unlock. Installing 4.1 might screw these up if you don't know what you're doing. (I don't have a 3GS, I couldn't tell you specifically what you need to watch out for).
    ________
    Bottom line:
    unless you have SHSH blobs for 3.1.2 / 3.1.3 you will only be able to upgrade to 4.1 right now.

    FIRST upgrade to 4.1, then use limera1n (as per the howto).
    Instead of limera1n you may prefer greenpois0n (a different jailbreak tool, but which should work comparably well).
    Last edited by raduga; 10-18-2010 at 08:31 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts