+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Update from 3.1.2 to 4.0.1 ?

is a discussion within the

3G[S] Downgrading

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
Hello dear fellows. I got a 3GS on 3.1.2 (was bought on this version), jailbroken with blackra1n and unlocked with ultrasn0w, and I wanna update to IOS4. As I use
...
  1. #1
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Update from 3.1.2 to 4.0.1 ?
    Hello dear fellows.

    I got a 3GS on 3.1.2 (was bought on this version), jailbroken with blackra1n and unlocked with ultrasn0w, and I wanna update to IOS4. As I use a unlock utility, I can't update to 4.1 just yet, so I would like to know if is it possible to go from 3.1.2 to 4.0.1 ? If so, how does one do it?

    iTunes won't let me do it with restore/update with shift+click (I'm on Windows XP), so i'm kinda stuck as I have never used tinyumbrella or ever played with SHSH (barely know what they are).


    Thanks in advance.

    Have a nice day or night or afternoon or prevening or whatever it is where you currently live.

  2. #2
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,921
    Thanks
    76
    Thanked 2,751 Times in 2,641 Posts

    You should have the shsh blogs since you were jailbroken awhile ago.
    Make sure you have atleast Itunes 9.2
    Run Notepad as Admin , open up hosts file and add this line :
    C windows\system32\drivers\etc\hosts
    74.208.10.249 gs.apple.com
    save it and reboots your pc
    Now do the Shift + Restore 4.0.1 ipsw
    Do jailbreakme 2.0 from Safari on your iphone.
    Unlock with Ultrasn0w

  3. #3
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by yeow202 View Post
    You should have the shsh blogs since you were jailbroken awhile ago.
    Make sure you have atleast Itunes 9.2
    Run Notepad as Admin , open up hosts file and add this line :
    C :windowssystem32driversetchosts
    74.208.10.249 gs.apple.com
    save it and reboots your pc
    Now do the Shift + Restore 4.0.1 ipsw
    Do jailbreakme 2.0 from Safari on your iphone.
    Unlock with Ultrasn0w

    I just installed itunes 9.2 and restarted

    the computer wont recognize my iphone anymore.

    I've had this happen once on my other computer, I belive it was also 9.2 and I did edit the hosts file, just not sure its the same ip you told me.

    now what?


    the phone just won't show up on windows or itunes, and it keeps doing the "connected/disconnected" sound, sometimes a different one thats a loop where the same sound is played 3 times very quickly, and its different from those.

    on my other computer it did show up on windows at least, even when disconnected. it used to show up as my phone's name but with a weird icon, and just didn't work.

    I don't remember what I did to fix that...

  4. #4
    AKA westonben
    Join Date
    Apr 2010
    Location
    Qatar
    Posts
    1,149
    Thanks
    15
    Thanked 191 Times in 185 Posts

    Follow instructions here to check bootrom:

    How to Check iPhone 3GS New Bootrom / Old Bootrom (iBoot) Version | Redmond Pie

    If you are on old bootrom you can get to 4.1 unlocked using snowbreeze.

  5. #5
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    turns out the problem with recognition was caused by itunes 9.2 bug, updating it to 9.2.1 did the trick.

    just doing the restore right now.


    and thanks for the info on the snowbreeze, but I'm not gonna trust it just yet. I'll just wait for geohot/devteam to release theirs.


    thanks guys!

  6. #6
    AKA westonben
    Join Date
    Apr 2010
    Location
    Qatar
    Posts
    1,149
    Thanks
    15
    Thanked 191 Times in 185 Posts

    I'm JB with snowbreeze on 4.1, it's working fine, but I'm stuck with the crappy snowflake on boot. I'll be changing to the pwnagetool version when it's released.

    Rather than restoring to 4.0.1 you could have used the existing pwnagetool to go to 4.0 which is no different to 4.0.1 anyway (except for the way the signal bars are displayed).

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts