• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • New iMacs Still in Critical Short Supply


    With Apple products likely selling in record numbers over the holidays, it shouldn't come as a surprise that a number of hugely popular new Apple creations are going fast.

    According to published reports Monday, Apple's new iMacs remain embroiled in a supply crunch that has worsened with each passing day through growing demand for the revamped super-slim Apple machine.

    Apple indirectly admitted to the supply inadequacies by revising its shipping times Monday to reflect the enormous demand that is putting so much pressure on the still-limited inventories. Despite having been released well over a month ago, shipping times for new iMac orders have ballooned to as much as four weeks.

    Although we won't get any concrete sales data before Apple's January 23rd earnings call, some are naturally seeing these supply issues as a tell-tale sign of strong sales for Apple's increasingly popular iMac line.

    Source: Apple Store
    This article was originally published in forum thread: New iMacs Still in Critical Short Supply started by Michael Essany View original post
    Comments 8 Comments
    1. Venom1234's Avatar
      Venom1234 -
      Mr. Essany you make me horny baby yeah!
    1. mlevine54's Avatar
      mlevine54 -
      I need help. I'm on iPhone 5 6.0 and I'm trying to update to 6.0.2 but I keep getting iTunes error 3194 and it won't update?? OTA won't work either. please help!!
    1. luvmytj's Avatar
      luvmytj -
      Quote Originally Posted by mlevine54 View Post
      I need help. I'm on iPhone 5 6.0 and I'm trying to update to 6.0.2 but I keep getting iTunes error 3194 and it won't update?? OTA won't work either. please help!!
      Restore it and then try this on a help forum instead of here.

      I am waiting for a new custom built iMac 27" since my new one was broken out of the box. I waited over a year to order it, I waited for 2 weeks for them to OK a replacement, and now I have to wait a month for the new one to arrive. You make me sad Apple. What have you become...
    1. mustard05's Avatar
      mustard05 -
      Quote Originally Posted by luvmytj View Post
      Restore it and then try this on a help forum instead of here.

      I am waiting for a new custom built iMac 27" since my new one was broken out of the box. I waited over a year to order it, I waited for 2 weeks for them to OK a replacement, and now I have to wait a month for the new one to arrive. You make me sad Apple. What have you become...
      So UPS or FedEx gets no blame? Troll!
    1. luvmytj's Avatar
      luvmytj -
      Quote Originally Posted by mustard05 View Post
      So UPS or FedEx gets no blame? Troll!
      Apple uses FedEx, but why would they be to blame? This has nothing to do with shipping times or damage. And do you even know what a troll is?
    1. fanboyfanboy's Avatar
      fanboyfanboy -
      Quote Originally Posted by mlevine54 View Post
      I need help. I'm on iPhone 5 6.0 and I'm trying to update to 6.0.2 but I keep getting iTunes error 3194 and it won't update?? OTA won't work either. please help!!
      Make sure you're server is pointed at apples servers and not Cydias
    1. ohthatguyagain's Avatar
      ohthatguyagain -
      Quote Originally Posted by mlevine54 View Post
      I need help. I'm on iPhone 5 6.0 and I'm trying to update to 6.0.2 but I keep getting iTunes error 3194 and it won't update?? OTA won't work either. please help!!
      Don't update to 6.0.2. Breaks wifi stuff more than fixes. Also causes cell dhcp issue on AT&T. Update to 6.0.1 or don't even worry about it. Not worth the incredible headache.
    1. mlevine54's Avatar
      mlevine54 -
      Quote Originally Posted by ohthatguyagain View Post
      Don't update to 6.0.2. Breaks wifi stuff more than fixes. Also causes cell dhcp issue on AT&T. Update to 6.0.1 or don't even worry about it. Not worth the incredible headache.
      How do I update to 6.0.1 ??? I thought I have to update to 6.0.2 is there a way to get to 6.0.1?