• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Icon Labels Greyed Out after WinterBoard Update: SOLUTION
    UPDATE: Winterboard was updated again yesterday with an included "White Icon Labels" package, so this post is mostly unnecessary now. Original post follows for archive:


    Quote Originally Posted by finkle316 View Post
    I just updated my phone to the new winterboard. Now my text under my icons is transparent and grey. I wen into the themes folder nad deleted all the extra winterboard crap. But my icon labels are still grey and transparent. GGRGRGRGRGRGRRRRRRRRRRRRRRRRRRR Can someone please tell me how to fix this.
    To everyone with the problem that gives you light gray icon labels after updating Winterboard, three solutions for you:


    SOLUTION 1 (try this first - simple, but might create problems with your theme)
    Open Winterboard, and set 'Summerboard mode' to OFF. Respring. This will fix your icon labels, but it might make some elements of your theme go away. Try this one first, and if everything looks good, stop here.
    If anything is wrong with your theme after doing this, switch 'summerboard mode' back to ON, respring again, and proceed to Solution 2....


    SOLUTION 2 (it works - but labels might not look quite how you want)
    Download a winterboard theme in cydia called "white labels." In Winterboard, under 'Themes,' just select both 'White Labels' AND the theme of your choice. Respring. If you're happy with this look, stop here. For what's, in my opinion, closer to the stock iPhone look, go to Solution 3...


    SOLUTION 3 (advanced - gets labels to look pretty much like they did before)
    Do Solution 2 above, then navigate to Library/Themes/White Labels/ and edit info.plist

    REMOVE:
    <key>UndockedIconLabelStyle</key>
    <string>color: white</string>

    REPLACE WITH:
    <key>DockedIconLabelStyle</key>
    <string>font-family: Helvetica; font-size: 11px; color: white; text-shadow: #000000 0px -1px 0px</string>
    <key>UndockedIconLabelStyle</key>
    <string>font-family: Helvetica; font-size: 11px; color: white; text-shadow: #000000 0px -1px 0px</string>


    Then respring again.

    It should now look nearly the same as it did before the Winterboard update. If they release another Winterboard update to fix, just remember to disable or uninstall the White Labels theme.

    Cheers!

    __________________
    http://nookcolormods.com
    This article was originally published in forum thread: Icon Labels Greyed Out after WinterBoard Update: SOLUTION started by wvcachi View original post
    Comments 30 Comments
    1. lolcats1's Avatar
      lolcats1 -
      Shouldnt this be under ipad support, not news?
    1. Kyle Matthews's Avatar
      Kyle Matthews -
      Yah, but this seems to be happening to a lot of users, so a fix in a visible spot is best.
    1. wvcachi's Avatar
      wvcachi -
      Put it where you guys think is best, but know that most of us are having the problem on the iPhone, not the iPad. Maybe my title was misleading....
    1. RelentlessDan's Avatar
      RelentlessDan -
      hey nice one dude, i didnt use it for an ipad (dont have one), but i used it on my iphone to make my theme look better than the standard white labels i created
    1. Kyle Matthews's Avatar
      Kyle Matthews -
      Quote Originally Posted by wvcachi View Post
      Put it where you guys think is best, but know that most of us are having the problem on the iPhone, not the iPad. Maybe my title was misleading....
      Gotcha, title changed.
    1. peoples_flip's Avatar
      peoples_flip -
      Thank you so much fo this solution... It was killing me as to why the labels turned grey.
    1. lgreenberg's Avatar
      lgreenberg -
      All you have to do is switch Summerboard Mode to off.
    1. wvcachi's Avatar
      wvcachi -
      Quote Originally Posted by lgreenberg View Post
      All you have to do is switch Summerboard Mode to off.
      True - and I edited the post to include that as a first try option . . . Though it does solve the icon label problem, it might cause some elements of your winterboard theme to disappear (namely the summerboard ones). My dock reverted to the stock iPhone dock when I did it that way.
    1. spider_romeo's Avatar
      spider_romeo -
      I'm using droid theme, so no effect......
    1. mikerlx's Avatar
      mikerlx -
      ipad ? this info works on the iPhone too and my dock was sunken and icings were hidden about an inch on the iPhone.
    1. wvcachi's Avatar
      wvcachi -
      Yeah, I agree this is more of an iPhone issue than iPad. This is where they moved it to. I guess as long as people with the problem are finding it, we're cool.
    1. Halo2kid49's Avatar
      Halo2kid49 -
      When I switch summerboard mode off it gets rid of my SB icons im using Dulce...

      When do you think saurik will have a fix?

      P.S. This does not affect my docked icon labels

      P.P.S. Compared photo of Solution 3 white labels modified to old photo of font before update and there is still a slight difference. The white labels modified one has darker borders around the font
    1. wvcachi's Avatar
      wvcachi -
      Quote Originally Posted by Halo2kid49 View Post
      When I switch summerboard mode off it gets rid of my SB icons im using Dulce...

      When do you think saurik will have a fix?
      Read solutions 2 and 3 at the top of the post. The turning summerboard off thing is just a "try this first" fix.

      Im not sure about your status bar problem . . .
    1. Halo2kid49's Avatar
      Halo2kid49 -
      Update:

      This does not affect my docked icon labels

      Compared photo of Solution 3 white labels modified to old photo of font before update and there is still a slight difference. The white labels modified one has darker borders around the font
    1. wvcachi's Avatar
      wvcachi -
      Quote Originally Posted by Halo2kid49 View Post
      Update:

      This does not affect my docked icon labels

      Compared photo of Solution 3 white labels modified to old photo of font before update and there is still a slight difference. The white labels modified one has darker borders around the font
      I see. Well it may not be a 100% exact replica of the original, but it's the closest I knew how to get. If anyone knows the exact coding in the plist file to get it perfect, feel free to contribute. Otherwise, I think this will do for most of us until they update.

      __________________
      nookcolormods.com
    1. venom800tt's Avatar
      venom800tt -
      Thank you so so much "wvcachi" your the best.

      This was killing me on my Iphone 3gs. Tried Solution 2 and didnt need to proceed to Solution 3. The 2nd one worked perfectly and all the labels are exactly what it was before

      BTW just registered to say THANKS
    1. EdmundGerber's Avatar
      EdmundGerber -
      I think I'll hold out for a fix before upgrading. Here's hoping that more testing is done in the future before code is shoved out the door. None of the fixes listed in this winterboard 'upgrade' are for the iphone/ipod touch, but we're the ones affected.

      I'm going to have to research every update from now on, with the ipad now in the mix.
    1. djm120607's Avatar
      djm120607 -
      i updated winter board on my ipad yesterday and after it loaded my springboard was all misplaced and i had a some blank icon apps not the titles just the apps, and also it wouldn't let me do anything in cydia so i had to restore to be able to use it agin so i was just wondering if any of the above solutions would work becasue i don't want to have to restore again any help would be appriciated thanks
    1. saurik's Avatar
      saurik -
      Quote Originally Posted by wvcachi View Post
      To everyone with the problem that gives you light gray icon labels after updating Winterboard, three solutions for you:


      SOLUTION 1 (try this first - simple, but might create problems with your theme)
      Open Winterboard, and set 'Summerboard mode' to OFF. Respring. This will fix your icon labels, but it might make some elements of your theme go away. Try this one first, and if everything looks good, stop here.
      If anything is wrong with your theme after doing this, switch 'summerboard mode' back to ON, respring again, and proceed to Solution 2....
      SummerBoard themes existed in a universe where the icon labels had always been gray: Apple only made the change to white labels with 2.x of the firmware. WinterBoard's intended behavior, and as far as I knew (and still believe), its actual behavior, was to cause icon labels to become gray if it was installed, in order to make certain these old themes worked correctly.

      This update makes a modification to that rule, deactivating this backwards-compatible behavior if SummerBoard mode is off. The ability to turn off SummerBoard compatibility is a new feature, and not something that was capable when WinterBoard was first released, so I am still adding functionality to that case.

      I have no clue why this behavior has suddenly changed for people, but let me be clear: no update of WinterBoard is ever going to come to "fix" the "bug" where the labels are gray: that is how WinterBoard is supposed to work. I can imagine releasing a version where this setting is a switch, however, defaulting to "on", and may very well add this to the next release of WinterBoard.

      Assuming the reports that this behavior has changed are correct, I am terribly sorry that there was such a long standing bug in WinterBoard: the labels being white was certainly not ever intended, and may indicate a more fundamental bug in the mechanism. I will attempt to investigate.

      Quote Originally Posted by EdmundGerber View Post
      I think I'll hold out for a fix before upgrading. Here's hoping that more testing is done in the future before code is shoved out the door. None of the fixes listed in this winterboard 'upgrade' are for the iphone/ipod touch, but we're the ones affected.

      I'm going to have to research every update from now on, with the ipad now in the mix.
      I am sorry you feel this way, but gray icon labels are NOT a bug. I /am/ terribly sorry you ever had to put up with a version of WinterBoard that had default-to-white icon labels (which is obviously incorrect in historical context, and if you read the code is certainly not what it is attempting to do), but your attitude makes no sense now that this bug has been fixed. If you want white icon labels, your theme needs to specify this fact, or you need to stop relying on SummerBoard compatibility.t

      Ok, after sitting around with a ton of themes and reading the code for this carefully, I think I'm seeing what the real symptom people are experiencing is: gray icon labels are occurring on some of the wrong themes. While gray icon labels is something WinterBoard is designed to do, it isn't designed to do them in all of the situations that people are currently experiencing them. I'm sorry about that, and I've fixed it in 0.9.3186-1.

      For the record, SummerBoard mode is incredibly complex, and has so many rules to it that I really can't "test" everything that it attempts to do with every release. I already do so much testing with WinterBoard it hurts: I have to test it on every version of the firmware from at least 2.2 onwards (2.2, 3.0, 3.1, and 3.2 all have different behavior), I have to test it on multiple devices, I have to test multiple kinds of themes... SummerBoard mode is just trying to do too many things to maintain backwards compatibility with a program I didn't even write . Please do note hate me for random changes in behavior.
    1. Krak4211's Avatar
      Krak4211 -
      Saurik I appreciate everything you do for the scene! I want to get away from using summerboard compatibility so where can put my SB icons to make them work with compatibility turned "off"?