• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Pod2g and MuscleNerd Publish Jailbreak 5.1.1 FAQ, Users Can Safely Upgrade to 5.1.1


    "You can safely upgrade to 5.1.1 now if you want to be ready" Pod2g tweeted after reposting a Jailbreak 5.1.1 FAQ MuscleNerd published earlier today.

    As usual unlockers who want to preserve their baseband should hold off on the upgrade to 5.1.1. Below is the FAQ in its entirety.

    • All info below is tentative and subject to last minute refinements
    • @pod2g's 5.1.1 jailbreak+untether is working out great. All devices are covered except for AppleTV3,1, which currently has no path for jailbreaking.
      the initial 5.1.1 plan used a kernel exploit from @westbaer which unfortunately precluded use in iPod3,1 and iPhone2,1
      @planetbeing stepped up and provided a kernel exploit that covers both of those. Those two JBers are the bomb!
    • The 5.1.1 A5 JB is very similar to the A5 5.0.1 JB. @pimskeks has done a tremendous job supporting both 5.0.1 and 5.1.1 in absinthe
    • Similar to 5.0.1, there will also be a 5.1.1 CLI "cinject" binary and redsn0w version of the 5.1.1 JB+untether. Absinthe, cinject, and redsn0w will all provide the same JB in different fashions.
      timing is indeterminate. Plans are for this week, but a number of factors can influence that.
    • For those wishing to donate, we've set up a new 5.1.1 paypal URL: paypal
    • Please don't pirate AppStore apps (seriously, please do not).
    It appears the release of the 5.1.1 jailbreak is imminent, but MuscleNerd is careful to note that the timing is "indeterminate." Nothing worse than setting deadline and missing it, especially with something as unpredictable as a jailbreak.

    Source: pod2g
    This article was originally published in forum thread: Pod2g and Musclebrain Publish Jailbreak 5.1.1 FAQ, Users Can Safely Upgrade to 5.1.1 started by Phillip Swanson View original post
    Comments 140 Comments
    1. 2k1's Avatar
      2k1 -
      Yep sad thing for sure.
    1. Darkflame's Avatar
      Darkflame -
      Quote Originally Posted by RyoSaeba View Post
      It'll only matter if they closed the holes. Unless they do that, the jailbreak should still work with little to no adjustments.

      This is probably why they are telling people to upgrade now rather then wait for them to get the JB out. Apple is probably actively working to patch it. Due to the busy schedules of the JB teams with the upcoming summits this is probably why they are saying to get on board 5.1.1 before apple stops signing it.

      Given that there's a way to downgrade back to 5.0.1 for those who previously JB I don't see any reason to not just upgrade now to 5.1.1 before the signing window closes. If for some reason you can't JB when the time comes or if the JB never ends up going public you can always run back to 5.0.1

      In all honesty i'm quite conflicted about the release of a 5.1.1 JB. A part of me was quite content giving up my JB because 5.1.1 ran much smoother for me. I'm happy to see they are catering to this new FW for me but sad if it means burning a potential hole for when the new phone drops.

      I think apple has gotten me dumbed down over the years cause I was getting along just fine without my JB for a weeks time. Maybe i'll fire up some androids just to get my head back in the game.
    1. PoEtikly's Avatar
      PoEtikly -
      A bit off topic but do I have to be on 5.1.1 to save my shsh/APTickets through tiny umbrella? Or can I just be on 5.0.1 and hook up. I've done this so many times but after the ifaith 5.0 apticket steps I just can't remember.
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by PoEtikly View Post
      A bit off topic but do I have to be on 5.1.1 to save my shsh/APTickets through tiny umbrella? Or can I just be on 5.0.1 and hook up. I've done this so many times but after the ifaith 5.0 apticket steps I just can't remember.
      You can save them with tiny umbrella. No need to go to 5.1.1 to save them.
    1. hbdragon88's Avatar
      hbdragon88 -
      I wish I could upgrade to 5.1.1, but rpetrich's Rotation Inhibitor and Belfry do not work yet as far as I know, and FullDrop is claimed to not be compatible with iOS 5 at all but works on my iPhone 4 at 5.0.1 (but not my iPad at 5.1).
    1. quidam_brujah's Avatar
      quidam_brujah -
      Quote Originally Posted by alanjf View Post
      It really should be stressed that if you're on 5.0.1/5.0.1b and jail broken (untethered), there really is nothing to be gained by jumping to 5.1.1.
      Unless there's an app or some hardware that requires it: my new HDMI adapter cable requires an update from 5.0.1 to function.

      Quote Originally Posted by c14rlf View Post
      Error 14 this time,

      Tried again and it worked, I was using an eBay bought USB charger, so tried the original and it worked!
      Tie-in to MMI article lauding Apple chargers...


      Must you use Tiny Umbrella? Doesn't Cydia save blobs? Or is something else required?

      Quote Originally Posted by GooseG View Post
      Will this cover 5.1? I'd rather not have to update.



      Yep. iPad 3 jailbroken within 2 months of release.
      You speak of the as yet unreleased JB, yes?
      AFAIK, it was shown JB but no JB tool released yet. Did I miss something?
    1. alanjf's Avatar
      alanjf -
      Quote Originally Posted by celeron View Post
      1. Play a track in Music
      2. Put device in sleep mode
      3. Unlock the device
      4. Enjoy the small lag
      I attempted this on my 4S (5.0.1b JB) and could not reproduce the lag you speak of, nor could I reproduce it on any display 4 or 4S I tried today at the local Apple Store that had songs loaded onto them. This makes me wonder if the lag is actually due to some combination of programs/tweaks that you have installed? I mean, if I can't even produce this on a stock device, then this is what I feel is safe to conclude. Perhaps there more you can tell of this issue?
    1. keenpois0n's Avatar
      keenpois0n -
      Quote Originally Posted by alanjf View Post
      I attempted this on my 4S (5.0.1b JB) and could not reproduce the lag you speak of, nor could I reproduce it on any display 4 or 4S I tried today at the local Apple Store that had songs loaded onto them. This makes me wonder if the lag is actually due to some combination of programs/tweaks that you have installed? I mean, if I can't even produce this on a stock device, then this is what I feel is safe to conclude. Perhaps there more you can tell of this issue?
      I can vouch for this fellow. it happens stock and jb 5.0.x. it's fine if you unlock it inmediately, but try listening to music for 10 mins, have it locked on the music app, ten after 10 mins of it being locked, unlock it. you'll notice it. it pees me off.
    1. oneduality's Avatar
      oneduality -
      Quote Originally Posted by Simon View Post
      You can save them with tiny umbrella. No need to go to 5.1.1 to save them.
      From my understanding, TinyUmbrella just saves the data for the current iOS you have installed.. so if you want 5.1.1 SHSH/Aptickets then you do have to upgrade to 5.1.1 to get it.. and you can, again, unless I'm mistaken.. only get them while apple is signing that firmware correct? .. you obviously can't upgrade to 5.1.1 once Apple stops signing the firmware..

      So if that is true, my advice would be to upgrade to 5.1.1 with the hopes the JB will be out this week and to make sure you can capture that information before Apple decides to update to 5.1.2 or something .. ( after you make sure you capture your 5.0.1 SHSH/Apticket ofcourse )
    1. PoEtikly's Avatar
      PoEtikly -
      Quote Originally Posted by oneduality View Post
      From my understanding, TinyUmbrella just saves the data for the current iOS you have installed.. so if you want 5.1.1 SHSH/Aptickets then you do have to upgrade to 5.1.1 to get it.. and you can, again, unless I'm mistaken.. only get them while apple is signing that firmware correct? .. you obviously can't upgrade to 5.1.1 once Apple stops signing the firmware..

      So if that is true, my advice would be to upgrade to 5.1.1 with the hopes the JB will be out this week and to make sure you can capture that information before Apple decides to update to 5.1.2 or something .. ( after you make sure you capture your 5.0.1 SHSH/Apticket ofcourse )
      I have an i4 so I can update to 5.1.1 and then downgrade back to 5.0.1 to jb, because without spire being compatible with 5.1.1 I'm not going to jb with 5.1.1. There's nothing of real significance in the update. And I think as long as apple is signing that fw you can connect to TU and it'll save the tickets. With iFaith you had to be on the fw to dump the blob and I think it's the same thing with the new version of redsn0w to dump the tickets for a5 devices. I'll try it tonight and report back what the outcome. Unless TU has changed I should be able to be on 5.0.1 and save the tickets for 5.1.1. For some reason Cydia says I have 5.1 saved but I haven't saved any since 5.0 and 5.0.1.
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by oneduality View Post
      From my understanding, TinyUmbrella just saves the data for the current iOS you have installed.. so if you want 5.1.1 SHSH/Aptickets then you do have to upgrade to 5.1.1 to get it.. and you can, again, unless I'm mistaken.. only get them while apple is signing that firmware correct? .. you obviously can't upgrade to 5.1.1 once Apple stops signing the firmware..

      So if that is true, my advice would be to upgrade to 5.1.1 with the hopes the JB will be out this week and to make sure you can capture that information before Apple decides to update to 5.1.2 or something .. ( after you make sure you capture your 5.0.1 SHSH/Apticket ofcourse )
      Your understanding is incorrect. Tiny umbrella saves the SHSH and APTicket for the current firmware that Apple is signing. It has nothing to do with what firmware your device is actually on. iFaith and redsnow are the ones that extract the SHSH from the current firmware installed on the device (A4 devices only for that).

      My iPhone 4S is on 5.0.1 and I have used tiny umbrella to save 5.1 and 5.1.1 SHSH and APTickets.

      Quote Originally Posted by PoEtikly View Post
      I have an i4 so I can update to 5.1.1 and then downgrade back to 5.0.1 to jb, because without spire being compatible with 5.1.1 I'm not going to jb with 5.1.1. There's nothing of real significance in the update. And I think as long as apple is signing that fw you can connect to TU and it'll save the tickets. With iFaith you had to be on the fw to dump the blob and I think it's the same thing with the new version of redsn0w to dump the tickets for a5 devices. I'll try it tonight and report back what the outcome. Unless TU has changed I should be able to be on 5.0.1 and save the tickets for 5.1.1. For some reason Cydia says I have 5.1 saved but I haven't saved any since 5.0 and 5.0.1.
      Cydia saves them for you automatically (sometimes). Similar to how tiny umbrella doesnt need you to be on that firmware to save them neither does cydia.
    1. quidam_brujah's Avatar
      quidam_brujah -
      Quote Originally Posted by Simon View Post
      Your understanding is incorrect. Tiny umbrella saves the SHSH and APTicket for the current firmware that Apple is signing. It has nothing to do with what firmware your device is actually on. iFaith and redsnow are the ones that extract the SHSH from the current firmware installed on the device (A4 devices only for that).

      My iPhone 4S is on 5.0.1 and I have used tiny umbrella to save 5.1 and 5.1.1 SHSH and APTickets.



      Cydia saves them for you automatically (sometimes). Similar to how tiny umbrella doesnt need you to be on that firmware to save them neither does cydia.
      Perfect -- answered my q -- thanks!
    1. alanjf's Avatar
      alanjf -
      Quote Originally Posted by keenpois0n View Post
      I can vouch for this fellow. it happens stock and jb 5.0.x. it's fine if you unlock it inmediately, but try listening to music for 10 mins, have it locked on the music app, ten after 10 mins of it being locked, unlock it. you'll notice it. it pees me off.
      You didn't say what device you were using, but I'm assuming it's not a 4S. On my 4S (5.0.1b JB), I played a song with it locked (on the music app just as you described) for 20 minutes when I was getting ready this morning. When I unlocked it, there was no pause in the music what so ever, nor was there any lag anywhere during the unlock process. It just went to the music app right away.

      Can you say what else was running in the background when you experienced it? Also, what device and what firmware exactly (5.0, 5.0.1, 5.0.1b) were you testing on? I'll also test on some display devices again next time I'm near an Apple or a cell carrier's store or any other place that has some on display with music on them, but so far I've been unable to reproduce this at a all.
    1. EVO's Avatar
      EVO -
      apparently this @legerov individual has posted an untethered 5.1.1:


      However, it doesnt seem to be doin too well, I wonder why

      I dont see any indication of a jailbroken iphone on 5.1.1
    1. towboattrash34's Avatar
      towboattrash34 -
      The real jailbreak will not be released till after the Amsterdam meeting.
    1. EVO's Avatar
      EVO -
      Edit..
    1. spice_weasel's Avatar
      spice_weasel -
      Quote Originally Posted by 6thDAY View Post
      I'm gonna feel sorry for the gullible peps that buy this crap......and you know there's gonna be some that will!
      Unlikely. It's not exactly easy to purchase the required software. And you guys do know that the required software isn't really for jailbreaking an iphone. It is just able to do it.
    1. LukeDuke's Avatar
      LukeDuke -
      Celeron thanks man but I have an iPhone 4. I'm kinda confused. When I jb in January, I did it via Cydia. When this jb releases, can I upgrade through Cydia or some other way?
    1. confucious's Avatar
      confucious -
      Cydia is the app store that is installed when you JB. You can not have cydia installed unless you are already JailBroken.
    1. PowerCamStudio's Avatar
      PowerCamStudio -
      Awesome can't wait