• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Warning: ultrasn0w May Break GPS on Baseband 6.15.00


    The Dev-Team is warning about a potential issue with ultrasn0w for iOS 4.2.1 on iPhones with the 06.15.00 baseband. An increasing number of users with that version of the baseband software are reportedly losing GPS functionality when they unlock their device. The blog post says they are looking for the root cause but haven't found it yet, and notes that it's not a problem for all or even most users with that baseband. Still, to be on the safe side, they're suggesting people should just not expect GPS to work if they want to unlock iPhones with the 06.15.00 baseband using ultrasn0w:

    Update #5: Unlockers have been reporting mixed results about GPS functionality at 06.15.00. Until we can track down what differentiates those who retain GPS vs. those who lose it, be conservative and assume youíll lose GPS at 06.15.00. As we work on finding the cause (and possibly a fix), please report your personal findings in our comments section. (Update: early indications are that while 06.15.00 is capable of GPS, it will require some further hacks. But please still be conservative and assume you will lose GPS at 06.15, in case the hacks donít work).
    Source: Dev-Team Blog
    This article was originally published in forum thread: Warning: ultrasn0w May Break GPS on Baseband 6.15.00 started by Paul Daniel Ash View original post
    Comments 175 Comments
    1. Sliyk22's Avatar
      Sliyk22 -
      Quote Originally Posted by x98car View Post
      nope, it wont fix it. 4.3 baseband is still lower than 6.15 so the baseband wont change.
      Are you saying my gps is broken forever?!
    1. Simon's Avatar
      Simon -
      I dont know if I would say forever. But for the foreseeable future.
    1. Sliyk22's Avatar
      Sliyk22 -
      Quote Originally Posted by x98car View Post
      I dont know if I would say forever. But for the foreseeable future.
      damn i was so looking forward to using the gps on the 3gs
    1. iForm's Avatar
      iForm -
      I finally sold my iphone 3GS
      now, i have a samsung glaxy S with ANDROID full opensource OS
      all works like a charm !!
      Good luck with your Apple and Dev-team :P
    1. Sliyk22's Avatar
      Sliyk22 -
      Quote Originally Posted by iForm View Post
      I finally sold my iphone 3GS
      now, i have a samsung glaxy S with ANDROID full opensource OS
      all works like a charm !!
      Good luck with your Apple and Dev-team :P
      how much did you sell it for, do u think android is better than ios?
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by Sliyk22 View Post
      how much did you sell it for, do u think android is better than ios?
      Give him time to realise just what he is missing.

      It is subjective and Android is not bad - just the combination of hardware and software and the quality of apps on the appstore combine to make the iPhone still my phone of choice.

      If you can't afford an iPhone then Android is a great choice. If money is no object then, IMHO, the iPhone is the best you can get.

      I would love to be able to afford a Galaxy S to compare the two but I can't - so my opinion is biased - if I could afford both then I wouldn't use both, so an unbiased opinion is almost impossible to get.

      All I can say is that I considered everything and ended up buying an iPhone4 - since then Android has moved on and the devices have improved. If I was buying now would I still buy an iPhone?

      The answer is almost certainly yes.
    1. IphoneThief's Avatar
      IphoneThief -
      I think it isn't ultrasnow causing the problem with the gps because i didn't install ultrasnow and i also don't have gps any more .

      I only got 4.2.1 with baseband 6.15.00!
    1. confucious's Avatar
      confucious -
      The problem is with the BB, but why on earth would you have that BB if you don't have US. The only reason to install that BB is for US.
    1. IphoneThief's Avatar
      IphoneThief -
      I didn't know that.
      I tough that it would not harm my iphone and had no knowledge of the gps problem

      In the future i will do some research before destroying my gps
    1. Sliyk22's Avatar
      Sliyk22 -
      I doubt we are ever gonna get it back. The gps
    1. hellraiserz32's Avatar
      hellraiserz32 -
      Quote Originally Posted by Sliyk22 View Post
      I doubt we are ever gonna get it back. The gps
      doesnt look like it does it!! do the dev team even care??
    1. confucious's Avatar
      confucious -
      What do you expect them to do about it?
    1. hellraiserz32's Avatar
      hellraiserz32 -
      find a way of downgrading it again so its not a phone killer upgrade, i was not warned of it when i took my phone into a shop to be unlocked, was not informed of the gps fault.
      then we have the option of having the baseband or not
    1. confucious's Avatar
      confucious -
      There is no way of downgrading the BB - people have been looking for one since the iPhone came out and the only method found was blocked within a week.
      If a shop upgraded you without warning you then I suggest you get them to buy you a new phone.
      When this method was first leased the problem was not known but it was warned that you do this strictly at your own risk. As soon as the problem was identified warnings were released. If someone ignored the warnings and still upgraded your phone then I suggest you take it up with them.
      I do not believe a fix for this problem wil be found any time soon.
    1. Eli75's Avatar
      Eli75 -
      I bought a used 3gs and read the warning before doing the upgrade. I decided to try it anyway. The GPS seems to find me on the map eventually, but none of the apps that use the GPS work. I hope there will be a fix, I really don't want to go back to my 3G after using the 3GS.
    1. gibgirl89's Avatar
      gibgirl89 -
      OK so i was really hesitant about upgrading my baseband to 6.15 but i took a dive and did it. I was originally at firmware 4.2.1 iphone 3G so i jailbroke the phone with redsnow and upgraded the baseband i was originally at 5.15.04 which cannot be unlocked. After i did the jailbreak i used ultrasnow to unlock the carrier for the phone worked great, the big issue was battery drainage i didnt even use the phone and iwas dropping 1-2% every couple mins. Did some more research and read that 4.2.1 unlocked has MAJOR battery drain problems so i downgraded the firmware to 4.0 which did the trick completely, i tried the gps and it seems to work fine as well as the applications that use the gps for location, how can this be?
      Im not a noob but im not an expert i guess i know more than the average chic lol just sharing this to you guys maybe there is a fix no one has found but i doubt it, maybe im just one of the lucky few :-/

      any input please
    1. donsamuelgeorge's Avatar
      donsamuelgeorge -
      Quote Originally Posted by saunupe1911 View Post
      I totally disagree. People should take calculated risks and play their percentages. This is why the economy is messed up now. The Dev Team always tell people the risks of jail-breaking. As of now, this upgrade is just too risky. The risks shown in their release blog was astonishing. That alone was enough for me to what it out, especially since 4.2 isn't much of an improvement over 4.1.
      Coward?!!

      I understand! But mine works great! All my notifactions are working flawlessly and my GPS is freaking precise! Soon I will downgrade my baseband (the moment they realease)!
    1. mehmetemin's Avatar
      mehmetemin -
      Quote Originally Posted by gibgirl89 View Post
      OK so i was really hesitant about upgrading my baseband to 6.15 but i took a dive and did it. I was originally at firmware 4.2.1 iphone 3G so i jailbroke the phone with redsnow and upgraded the baseband i was originally at 5.15.04 which cannot be unlocked. After i did the jailbreak i used ultrasnow to unlock the carrier for the phone worked great, the big issue was battery drainage i didnt even use the phone and iwas dropping 1-2% every couple mins. Did some more research and read that 4.2.1 unlocked has MAJOR battery drain problems so i downgraded the firmware to 4.0 which did the trick completely, i tried the gps and it seems to work fine as well as the applications that use the gps for location, how can this be?
      Im not a noob but im not an expert i guess i know more than the average chic lol just sharing this to you guys maybe there is a fix no one has found but i doubt it, maybe im just one of the lucky few :-/

      any input please
      Hello,

      as far as my understanding, your baseband 6.15.00 and your ios/fw 4.0 and you unlocked the carrier right ? and also your gps works pricesly ?

      My situation is;

      I have 3GS 32 GB
      ios/fw 4.2.1
      bb 6.15.00

      my gps sucks !

      if you say, that works fine for you, how can I install 4.0 while I am in 4.2.1 ?

      Best regards,
      Mehmet.
    1. i.Annie's Avatar
      i.Annie -
      Some people say it's working after the bb update, but it's not reliable to determine whether they are accurately testing it or not.

      Chances are though, whether someone else's GPS really is ok or not, if yours isn't working/working correctly then it's shot. You cant fix it regardless of what firmware you're on.
    1. Sliyk22's Avatar
      Sliyk22 -
      Not atleast until the next baseband comes out right?